soll nur local laufen / port 80 und 53 / NIS firewall

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

soll nur local laufen / port 80 und 53 / NIS firewall

Postby marc75 » 21. November 2005 14:37

Hallo Leute,

ich habe schon seit längerer Zeit xampp installiert und local am laufen. Nach einem Plattencrash musste ich die Hauptplatte wechseln und win neu installieren. Seit dem Springt ständig die NIS Firewall an und will Port 80 und 53 blocken (wenn man es macht geht xampp nicht mehr).

Jetzt dachte ich mir, ich ändere mal folgendes:
- httpd.conf

Listen 80
in:

Listen 127.0.0.1:80
Listen 127.0.0.2:80

- ssl.conf
Listen 443
in:

Listen 127.0.0.1:443
Listen 127.0.0.2:443

<VirtualHost _default_:443>
in:
<VirtualHost 127.0.0.1:443>
#Inhalt
</VirtualHost>

<VirtualHost 127.0.0.2:443>
#inhalt
</VirtualHost>


Wenn ich xampp jetzt starte und die firewall deaktiviere funktioniert alles soweit, sobalt ich die firewall aktiviere will diese wieder blocken, erst port 80, gebe ich diesen frei dann will er port 53 blocken und dieser läßt sich dann einfach nicht freigeben, obwohl ich eine regel dafür erstellt habe.

Weiss jemand was ich noch ändern muss das xampp nur local läuft?
mfg
marc75
marc75
 
Posts: 19
Joined: 05. July 2004 14:30

Postby deepsurfer » 21. November 2005 16:44

Wenn ich xampp jetzt starte und die firewall deaktiviere funktioniert alles soweit, sobalt ich die firewall aktiviere will diese wieder blocken, erst port 80, gebe ich diesen frei dann will er port 53 blocken und dieser läßt sich dann einfach nicht freigeben, obwohl ich eine regel dafür erstellt habe.

Weiss jemand was ich noch ändern muss das xampp nur local läuft?

Das ist aber ein Fehlverhalten von NIS, schau mal bei Norton vorbei ob in der FAQ von denen da etwas steht. Vielleicht eine Fehlerhafte Installation, oder du hast keine Berechtigung im NIS die werte zu ändern.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby marc75 » 23. November 2005 14:24

hallo,

habe jetzt noch die vhosts geändert in:

NameVirtualHost 127.0.0.1:80
<VirtualHost 127.0.0.1:80>
ServerName projekt1
ServerAdmin webmaster@projekt1
DocumentRoot E:/xampp/htdocs/projekt1/
<Directory E:/xampp/htdocs/projekt1/>
AllowOverride All
</Directory>
</VirtualHost>
NameVirtualHost 127.0.0.1:443
<VirtualHost 127.0.0.1:443>
ServerName projekt1
ServerAdmin webmaster@projekt1
DocumentRoot E:/xampp/htdocs/projekt1/

SSLEngine on
SSLCertificateFile "E:/xampp/apache/conf/ssl.crt/server.crt"
SSLCertificateKeyFile "E:/xampp/apache/conf/ssl.key/server.key"
<Directory E:/xampp/htdocs/projekt1/>
AllowOverride All
</Directory>
</VirtualHost>


Und nachdem NIS immernoch hin und wieder ansprung. Je nachdem
was wann gestartet wurde. Erst xampp dann NIS oder erst NIS dann xampp.
Habe ich heute ein NAV Alert erhalten das ein Trojanisches Pferd im Ordner mysql/data ist. Hab die wymok.dll entfernt die registry gereinigt und jetzt läuft alles ohne Probleme.

Hab dazu jetzt noch ein Sicherheitscheck von symantec durchgeführt und jetzt ist alles Dicht.

da hatte wahrscheinlich der trojaner immer versucht nach aussen zu kommen.
mfg
marc75
marc75
 
Posts: 19
Joined: 05. July 2004 14:30


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests