Fehleranzeige Port 3306

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehleranzeige Port 3306

Postby toxma » 15. November 2005 14:36

Hallo,

kann jemand helfen, habe folgendes Problem bei der Installation von xampp im zip format:

mysql is startet with mysql\bin\my.cnf (console)
051115 14:18:36 [Note] mysql\bin\mysqld: ready for connection.
Version: 5.0.15 socket: port: 3306 Source distribution.

apache starte normal aber mysql und damit die db funktionieren nicht, wenn ich mit localen Website auf die db zugreifen will.

ich arbeite mit xp pof. habe die windowsfirewall deaktiviert, da ich nur local arbeite, versucht den port manuell einzugeben aber nichts hilft.

bin leider nicht so firm in der sache.

kann jemand helfen??

beim goolen leider auch nichts richtiges gefunden.

danke schon mal

Toxma
toxma
 
Posts: 3
Joined: 15. November 2005 14:25

Postby deepsurfer » 15. November 2005 14:44

hattest du vorher schonmal MySQL als eigenständiges Produkt auf dem System ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Fehleranzeige Port 3306

Postby toxma » 15. November 2005 14:58

nein noch nicht aber mehrmals versucht xammpp zu laufen zu bringen mit alles löschen, neu rüber kopieren, auch die installer version habe ich versucht.
in c\windowos glaub ich hatte ich eine my.ini.old, diese rausgenommen, nichts und eine my.cnf gesucht, hatte gelesen, da kann man was einstellen bzw. ändern aber diese datei find ich einfach nicht.... gibts nicht.
in mysql\bin hab ich nur eine my, die geht aber nicht zu öffnen, habe alles so eingestellt, das alle dateien angezeigt werden aber nichts.

gruss toxma
toxma
 
Posts: 3
Joined: 15. November 2005 14:25

Postby deepsurfer » 15. November 2005 15:11

in mysql\bin hab ich nur eine my

jo , da ist die richtige...
Öffne ein Schreibprogramm (notepad oder write) und öffne die "my" auf manuellem Wege, also nicht über den Dateimanager sondern von Editierprogramm aus.

Du beschreibst das du mehrmals den XAMPP probiert hast, kann es sein das darunter auch der versuch war, die XAMPP komponenten als "Service" zu starten, denn wenn das so war, so hängt ein MySQL-Service im System der dir nun alles versperrt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby toxma » 15. November 2005 15:29

danke erstmal,

stimmt auch, hab ich versucht aber erst nach dem ich vergeblich versucht das ding zum laufen zu bringen.

die my.cnf stellt sich bei mir komischerweise nicht als datei dar, sondern steht nur als my, ohne .cnf und ist als symbol in der art eines fernseher dargestellt. beim öffnen passiert dann aber leider nichts. alle anderen dateien werden aber mit der entsprechenden endung wie exe oder dll oder cnt angezeigt. nur komisch, eben nicht die my.cnf. vielleicht gibt es die garnicht oder muss ich die selbst erstellen! hab das sowas gelesen bei https://www.tsunamihost.ch/hosting/faq/mysql/my.cnf.php. aber wie gesagt kenne mich da leider nicht so aus.

gruss toxma
toxma
 
Posts: 3
Joined: 15. November 2005 14:25

Habe das selbe Problem!

Postby petzal » 16. November 2005 17:15

Hallo!

Habe eure Posts gelesen und ich habe selbst ein ähnliches Problem! Außer XAMPP habe ich aber auch noch eigenständige Programme installiert gehabt. Diese sind bereits alle gelöscht.

Meine Fehlermeldung:
.....can´t start server: Bind on TCP/IP port: NO error.......
Do you already have another mysqld server running on port: 3306...

Jetzt habe ich die "my" -Datei mit WordPad geöffnet und weiß nicht weiter.

Wäre sehr dankbar für eine Hilfestellung!
petzal
 
Posts: 3
Joined: 16. November 2005 17:02

Re: Habe das selbe Problem!

Postby deepsurfer » 16. November 2005 17:21

petzal wrote:Hallo!

Habe eure Posts gelesen und ich habe selbst ein ähnliches Problem! Außer XAMPP habe ich aber auch noch eigenständige Programme installiert gehabt. Diese sind bereits alle gelöscht.

Meine Fehlermeldung:
.....can´t start server: Bind on TCP/IP port: NO error.......
Do you already have another mysqld server running on port: 3306...

Jetzt habe ich die "my" -Datei mit WordPad geöffnet und weiß nicht weiter.

Wäre sehr dankbar für eine Hilfestellung!


Stoppe bitte deinen XAMPP, wenn als DIENST installiert diese auch herausnehmen lassen.

Nun in der Prozessliste nachschauen ob das noch "mysqd" vorhanden ist, wenn ja versuchen diesen zu killen.
Dann in der "DIENST liste" nachschauen ob da noch MySQL vorhanden ist, diesen dann beenden und deaktivieren.

Jetzt nur den XAMPP über XAMPP-Controll starten, aber nicht auf "Svc" klicken !

testen und melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Getestet, nun meine Meldung ;-)

Postby petzal » 17. November 2005 16:28

Danke für den Tipp, ich konnte den Dienst "MySQL" nun deaktivieren und Apache läuft.

Doch dann ist auch schon das nächste Problem aufgetreten. Wenn ich nämlich versuche mit Firefox auf das tool phoMyAdmin zuzugreifen bekomme ich diesen Fehler:

MySQL said:
#2003 - The server is not responding

Ich möchte auf meine Datenbank endlich zugreifen können und bin shcon nahe am verzweifeln :cry: Bitte um Hilfe! Danke schon im Vorhinein

Bettina
petzal
 
Posts: 3
Joined: 16. November 2005 17:02

Postby deepsurfer » 17. November 2005 16:32

Danke für den Tipp, ich konnte den Dienst "MySQL" nun deaktivieren und Apache läuft.


Aus diesem Sinn müsstest du jetzt bitte den MySQL manuell via XAMPP-Controll starten können (wie gesagt jetzt nicht auf "Svr" klicken sondern nur MySQL --> Start.

Wenn nun der Grüne Balken erscheint mit "Running" sollte jetzt auch der zugrif mittels phpmyadmin etc. funktionieren.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby petzal » 17. November 2005 16:46

danke für die schnelle Antwort!

Ich bin ja noch sowas von grün hinter den ohren und weiß leider nicht wie ich MySQL manuell via XAMPP-Controll starten kann. Wäre dir für genauere Hilfe sehr dankbar!
petzal
 
Posts: 3
Joined: 16. November 2005 17:02

Postby deepsurfer » 17. November 2005 18:08

so....dann müssen wir ja "Back to the roots"

Vergewisser dich bitte erstmal ob in der Prozessliste und in der DIENSTliste
kein MySQL oder Apache mehr vorkommt.

Wenn alles dahingehend sauber ist, dann gehe ich mal von einem sauberen System bei dir aus.

Jetzt versuche bitte abermals den Apache-Installer zu nutzen. (da ich von ausgehe das du nicht den XAMPP benutzen willst)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests