MySQL standardmässig ohne InnoDB?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL standardmässig ohne InnoDB?

Postby Josh83 » 14. November 2005 22:23

Hi alle

Ich habe auf http://www.innodb.com/download.php gelesen, dass alle Versionen von MySQL 4.1 InnoDB integriert haben sollen. Leider zeigt mir phpMyAdmin an, dass InnoDB nicht verfügbar ist.
Ich habe die neuste Version von XAMPP. Ist das normal? Wurde InnoDB entfernt?

Gruss
Josh
Josh83
 
Posts: 15
Joined: 27. April 2005 15:00

Postby deepsurfer » 15. November 2005 11:41

Stellst sich die Frage ob MySQL 5 überhaupt noch "InnoDB" unterstützt, denn ab XAMPP 1.5.0 gibt es nur den MySQL 5 und kein MySQL 4.x.x
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ollo » 16. November 2005 23:00

deepsurfer wrote:Stellst sich die Frage ob MySQL 5 überhaupt noch "InnoDB" unterstützt, denn ab XAMPP 1.5.0 gibt es nur den MySQL 5 und kein MySQL 4.x.x


Klar unterstützt MySQL 5 auch InnoDB... Die können ja nicht einfach die meistbenutzte Engine mit Foreign Keys abschaffen.

Da bin ich mir so sicher dass ich das einfach mal ungeprüft behaupte! :)
(ich hab wider Erwarten doch noch die 1.4.15 drauf)

Bei XAMPP ist InnoDB allerdings immer standardmäßig abgeschaltet, vermutlich liegt's nur daran:

Code: Select all
skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = c:/programme/xampp1.4.15/xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = c:/programme/xampp1.4.15/xampp/mysql/
#innodb_log_arch_dir = c:/programme/xampp1.4.15/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50


in der my.cnf (wenn unter Windoof, ZUERST einen Texteditor öffnen und mit diesem dann die Datei, weil Windoof die .cnf-Endung strikt an sich reißt) ändern in:

Code: Select all
#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = c:/programme/xampp1.4.15/xampp/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = c:/programme/xampp1.4.15/xampp/mysql/
innodb_log_arch_dir = c:/programme/xampp1.4.15/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50


...die Pfade natürlich entsprechend anpassen...
ollo
 
Posts: 85
Joined: 11. November 2004 12:29

Postby Josh83 » 21. November 2005 23:27

Vielen Dank für die Infos. :-)
Josh83
 
Posts: 15
Joined: 27. April 2005 15:00

Postby Garfieldius » 03. December 2005 20:34

Habe die my.cnf nach ollo's vorschlägen geändert, aber phpMyAdmin verweigert InnoDBs weiterhin.
Bei MySQL Front kann ich zwar InnoDBs beim erstellen auswählen, am Ende kommen allerdings wieder MyISAMs raus.
Garfieldius
 
Posts: 6
Joined: 03. December 2005 10:55


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests