Installation von PHP-Erweiterungen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Installation von PHP-Erweiterungen

Postby CHESHiRE » 09. November 2005 15:59

Ich nutze XAMPP schon seit etwas über einem Jahr - ich nutze es halt nur (Sicherheit ist konfiguriert und ich schreibe meine PHP-Skripte - das war's)!

Nun habe ich aber etwas Tiefgründigeres vor, als nur zu skripten: Ich will die PHP-Erweiterung "pSpell" einbringen. Aber wie geht das? Was muss ich tun, um PHP neu zu kompilieren? Oder muss ich es vielleicht gar nicht?!

Auf PHP.net steht jedenfalls, PHP müsse neu kompiliert werden, um die Erweiterung nutzen zu können, aber weder auf PHP.net noch in den PHP.net-Newsgroups noch auf der Homepage zu der Erweiterung habe ich eine Anleitung gefunden. Im XAMPP FAQ oder hier im Forum bin ich auch nicht fündig geworden.

Ich nutze übrigens XAMPP 1.5.0 für Windows unter Windows XP.
User avatar
CHESHiRE
 
Posts: 2
Joined: 09. November 2005 15:38
Location: Dresden

Postby Wiedmann » 09. November 2005 16:03

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby CHESHiRE » 11. November 2005 11:49

Die Antwort ist twar nicht gerade sehr aussagefähig, weil das entkommentieren der einen Zeile nicht zwangsläufig bedeutet, dass auch "meine" Erweiterung schon enthalten ist, aber ich hab' trotzdem 'rausgefunden, was damit gemeint ist.
Da ist aber auch schon das nächste Problem: als ich in der Zeile
Code: Select all
;extension=php_pspell.dll
das Semikolon entfernt hatte und den Apache-Dienst neu gestartet habe, kam folgende Meldung (zwei mal):
Code: Select all
PHP Startup: Unable to load dynamic library 'C:\apachefriends\xampp\php\ext\php_pspell.dll' - Das angegebene Modul wurde nicht gefunden.

Die Datei ist aber vorhanden! Als ich dann die Datei aus dem Verzeichnis "extensions" nach "ext" kopiert und den Dienst neu gestartet habe, kam erneut die selbe Meldung. Bei "php_imagick.dll" war's genauso. Auch als ich alle anderen Erweiterungen auskommentiert habe und pspell die einzige war, kam wieder der Fehler.
Mein letzter Versuch war der, dass ich die heruntergeladene "aspell-15.dll" einfügte:
Code: Select all
extension=aspell-15.dll
Das Resultat war diese Meldung:
Code: Select all
PHP Startup: Invalid library (maybe not a PHP library) 'aspell-15.dll'
Das erwartete ich aber auch nicht anders.

Also: Wer kann mir helfen? Ich brauche die Erweiterung nämlich schon irgendwie...
User avatar
CHESHiRE
 
Posts: 2
Joined: 09. November 2005 15:38
Location: Dresden


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests