Wird mcrypt in der aktuellen XAMPP Version supportet?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Wird mcrypt in der aktuellen XAMPP Version supportet?

Postby TConnect » 07. November 2005 10:01

Hallo zusammen,

wird in der aktuellen Version von XAMPP eigentlich das Modul mcrypt (verwendet in PHP) supported? Ich habe noch eine ältere Version und wenn ich dort die entsprechenden PHP-Funktionen zur Generierung eines IV aufrufe, bekomme ich die Meldung zurück, dass die Funktion nicht bekannt sei...

Wenn es derzeit keinen Support für mcrypt gibt, wie kann ich dieses Modul nachträglich hinzufügen?


Grüße TConnect
TConnect
 
Posts: 100
Joined: 31. March 2004 22:26

Postby Wiedmann » 07. November 2005 10:03

Diese Extension einfach in der "php.ini" aktivieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Ja natürlich

Postby TConnect » 07. November 2005 10:21

Da habe ich wohl am falschen Ende gesucht. Danke...

Grüße
TConnect
TConnect
 
Posts: 100
Joined: 31. March 2004 22:26

Ähm... geht noch nicht

Postby TConnect » 07. November 2005 10:26

Hallo zusammen,

also ich habe jetzt in der php.ini und in der php5.ini die Zeilen mit

extension=php_mcrypt.dll

entkommentiert, so dass ich das Modul - wenn ich es richtig sehe - aktiviert habe. Ich habe auch den Apache noch mal restarted...

Dennoch bekomme ich noch

"Call to undefined function mcrypt_get_iv_size()" als Ergebnis.

Ideen?


Grüße
TConnect
TConnect
 
Posts: 100
Joined: 31. March 2004 22:26

Postby Wiedmann » 07. November 2005 11:46

also ich habe jetzt in der php.ini und in der php5.ini die Zeilen mit

Verrate mir mal bitte, wieso ihr immer alle möglichen Dateien editiert, anstatt die Eine, die benutzt wird.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Weil es einen PHP4/5 Switcher gibt

Postby TConnect » 07. November 2005 11:57

...und man diesen hin und wieder auch mal verwenden will.... :-)

Trotzdem geht's bei mir nicht...


Grüße TConnect
TConnect
 
Posts: 100
Joined: 31. March 2004 22:26

Re: Weil es einen PHP4/5 Switcher gibt

Postby deepsurfer » 07. November 2005 16:00

TConnect wrote:...und man diesen hin und wieder auch mal verwenden will.... :-)

Trotzdem geht's bei mir nicht...


Grüße TConnect


Wie schon Wiedmann anmerkt gibt es nur eine PHP.INI die benutzt wird. Es existieren drei, aber nur eine ist für das ganze zuständig.

Bitte ruf phpinfo auf, darin wird dir der richtige Pfad der INI gezeigt.
Ansonsten steht das auch auf der FAQ von Apachefriends, die in der Downloadpage aufgeführt wird.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests