Pear Auth funktioniert nicht mehr richtig

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Pear Auth funktioniert nicht mehr richtig

Postby frolleinwunder.net » 03. November 2005 10:29

Hallo,

kann mir jemand sagen, warum das Auth Paket von Pear nicht mehr richtig funktioniert ( XAMPP 1.4.16).
Mein Script läuft (fast) noch wunderbar. Der Login funktioniert.
Nur merkt er sich nicht mehr das ich eingeloggt bin und fragt immer wieder die login Daten ab.
Also ich kann mich einloggen. Sehe dass ich eingeloggt bin. Wenn ich z.B. die selbe Adresse nochmal eingebe, möcht er wieder User und Pass.
Dass Skript hat vorher funktioniert.
Hab jetzt nochmal das Beispiel - Script von
http://pear.php.net/manual/en/package.a ... .intro.php
genommen.
Es taucht das gleiche Problem auf.
Liegt wahrscheinlich an einer .ini . Hat jemand eine Lösung?

Grüße :D
frolleinwunder.net
 
Posts: 8
Joined: 27. October 2005 16:21
Location: Bonn

Postby Wiedmann » 03. November 2005 10:51

Hm, einen 1.4.16 hab ich grad keinen da. (nur den designierten Nachfolger...)

Jedenfalls, mit:
AUTH-1.2.3
DB-1.7.6
PEAR-1.4.1

tut das erwähnte Beispiel von dir (Example 28-1) ohne Probleme.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby frolleinwunder.net » 03. November 2005 11:25

Hi,

danke für die schnelle Antwort.
Also ich nutze auch die gleichen Versionen, abgesehen vom Xampp.
Den hab ich mir heute noch runtergeladen, da ich bei der neuen beta auch schon dieses Problem hatte.
Wie ist denn das? Wenn du dich eingeloggt hast und die Seite nochmal aufrufst, bleibst du dann eingeloggt?
Wenn ja, hast du eine Ahnung wieso das bei mir nicht klappt? Weder IE noch Firefox.
Musstest du auch das Beispiel-Script leicht abändern, damit nicht der Fehler mit der Zeile 180 kam?
Werde dass ganz jetzt nochmal auf einem anderen Rechner checken.

Schönen Gruß
frolleinwunder.net
 
Posts: 8
Joined: 27. October 2005 16:21
Location: Bonn

Postby Wiedmann » 03. November 2005 11:42

Wenn du dich eingeloggt hast und die Seite nochmal aufrufst, bleibst du dann eingeloggt?

Yup. Es wird ja ein Sessioncookie angelegt. Und solange das vorhanden/gültig ist, bleib ich eingeloggt.

Musstest du auch das Beispiel-Script leicht abändern, damit nicht der Fehler mit der Zeile 180 kam?

Wie man es nimmt. Ich hab halt Auth.php an PHP5.0.5 angepasst ;-) Mit PHP4.4.0 tritt dieser Fehler nicht auf.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby frolleinwunder.net » 03. November 2005 13:19

Hallo,

hab jetzt auf dem anderen Rechner (auch WinXp) Xampp installiert.

Version 1.4.16 -> Das selbe Problem!
Version 1.4.11 -> Alles funktioniert wunderbar, wie es sein soll :)

Jetzt werde ich mich langsam an die Version ranpirschen bis zu der es funktioniert.
Oder muss man bei 1.4.16 unter Windows Xampp als Service laufen lassen?

Grüße
frolleinwunder.net
 
Posts: 8
Joined: 27. October 2005 16:21
Location: Bonn

Postby deepsurfer » 03. November 2005 14:10

Hallo,

hab jetzt auf dem anderen Rechner (auch WinXp) Xampp installiert.

Version 1.4.16 -> Das selbe Problem!
Version 1.4.11 -> Alles funktioniert wunderbar, wie es sein soll Smile


kann es sein das auf dem PC wo das "wieder login" verhalten existiert du im Browser die COOKIES abgeschaltet hast ??
Desweiteren mal das vorhandene COOKIE im browser löschen, kann sein das du nur eine neues cookies brauchst (und nicht immer ein upgedates) damit es wieder einwandfrei geht.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby frolleinwunder.net » 03. November 2005 14:38

Sehr sehr merkwürdig!
Auf beiden Rechnern funktioniert es jetzt.
Nachdem ich auf dem 2. Rechner die 1.4.14 entpackt/gestartet hatte und dann die 1.4.16, lief dort auf einmal alles perfekt.
Dann hab ich auf dem 1. Rechner auch die 1.4.16 wieder entpackt/gestartet das selbe test.php Script laufen lassen. Wieder dass selbe Problem.
Dann die 1.4.14. dort entpackt/gestartet. Script lief wieder, dann die 1.4.16 entpackt/gestartet und auch hier läuft nun alles richtig.
Beim starten von xampp ( Vers. 1.4.14 ) ist mir folgendes aufgefallen:
Es kam in der dos-box folgende Meldung:
### Apache + MYSQL IS STARTING NOW ###
[Thu Nov...] [notice] Disable use of AcceptEx() Winsock2 API
Ich nehme an, daran lag es.

Trotzdem nochmal vielen Dank :)

Schöne Grüße
frolleinwunder.net
 
Posts: 8
Joined: 27. October 2005 16:21
Location: Bonn

Postby frolleinwunder.net » 06. November 2005 09:46

So richtig glücklich bin ich immer noch nicht.
Jedes mal, wenn ich den Rechner neu starte muss ich erst den xampp 4.1.14 starten / stoppen, damit der 4.1.16 richtig läuft.
Hat jemand einen Tip?
frolleinwunder.net
 
Posts: 8
Joined: 27. October 2005 16:21
Location: Bonn


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests