Mercury ..:: ich kapier nix ::..

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mercury ..:: ich kapier nix ::..

Postby toto75 » 21. October 2005 22:01

Hilfe, ich bin ganz neu hier, habe natürlich die Suche-funktion genutzt aber irgendwie verstehe ich nur Bahnhof...

Ich hatte bis vor kurzem Apache2 und PHP4 einzeln installiert und konnte dort Emails per Kontaktformular versenden.

Jetzt habe ich XAMPP 1.4.16 am laufen und das Script geht nicht mehr...

Folgender Fehler nach dem Absenden:
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\ (.....)

Wer kann mir sagen, was da los ist?
User avatar
toto75
 
Posts: 8
Joined: 21. October 2005 21:55
Location: D-59269 Beckum

Postby Wiedmann » 22. October 2005 08:01

Failed to connect to mailserver at "localhost" port 25

Es läuft kein Mailserver auf deinem Rechner (und PHP ist wohl so konfiguriert so einen zu benutzen)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby toto75 » 22. October 2005 08:56

Kann mir mal einer (einfach) erklären, wie ich einen Mail-Server installiere?

Oder noch besser, kann ich PHP nicht zwingen, Emails ohne den Server zu versenden?
User avatar
toto75
 
Posts: 8
Joined: 21. October 2005 21:55
Location: D-59269 Beckum

Postby Wiedmann » 22. October 2005 08:59

kann ich PHP nicht zwingen, Emails ohne den Server zu versenden?

Wie man es nimmt...


Allerdings:
Ich hatte bis vor kurzem Apache2 und PHP4 einzeln installiert und konnte dort Emails per Kontaktformular versenden.

Also weisst du doch wie es geht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby zAp!! » 22. October 2005 12:20

http://www.hmailserver.com -> Installieren -> Übers GUI konfigurieren -> Glücklich sein! :D Man kann diesen Mailserver auch übers Web konfigurieren. Ich finde diesen Server einfacher als den Mercury. Er arbeitet mit einer Mysql Datenbank.
mfg zAp!!
Anti Mysql User
because use VDB as your DB!
http://www.zap.de.tk
User avatar
zAp!!
 
Posts: 38
Joined: 28. August 2005 19:34
Location: A-Feldkirch

Postby toto75 » 26. October 2005 21:48

tja, geht nicht, denn mein mysql kriege ich schon gar nicht zum laufen...
User avatar
toto75
 
Posts: 8
Joined: 21. October 2005 21:55
Location: D-59269 Beckum

Postby deepsurfer » 26. October 2005 22:09

toto75 wrote:tja, geht nicht, denn mein mysql kriege ich schon gar nicht zum laufen...


was geht denn noch nicht bei deinem XAMPP ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby toto75 » 26. October 2005 22:31

Ich kann keine Emails aus einem Kontaktformular versenden...

Er kommt dieser Fehler:
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\kontaktformular.php on line 119

Ich gehe davon aus, das Mercury Mail icht richtig konfiguriert ist. Ich habe keinen blassen schimmer, wie das gehen soll :-(
User avatar
toto75
 
Posts: 8
Joined: 21. October 2005 21:55
Location: D-59269 Beckum

Postby Wiedmann » 26. October 2005 22:38

Ich kann keine Emails aus einem Kontaktformular versenden...

Ich denke DeepSurfer hat sich wohl grad eher darüber gewundert:
toto75 wrote:mein mysql kriege ich schon gar nicht zum laufen...


Ich gehe davon aus, das Mercury Mail icht richtig konfiguriert ist.

Der ist zwar tatsächlich nicht gross konfiguriert... Aber in deinem Fall löuft er erst gar nicht.

BTW bist du noch immer eine Antwort schuldig:
Wie hattest du PHP bisher (ohne XAMPP) konfiguriert damit du Emails versenden konntest?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby toto75 » 27. October 2005 18:35

eben; Mercury Mail läuft eben gar nicht und ich kapiere auch nicht, wie man es zu laufen bringt...

Vielleicht erbarmt sich ja jemant für ein Trottel wie mich :wink: es mir mal zu erklären...
User avatar
toto75
 
Posts: 8
Joined: 21. October 2005 21:55
Location: D-59269 Beckum

Postby nattl » 27. October 2005 18:46

wieso hat mailversenden funktioniert, *bevor* du xampp installiert hattest?
User avatar
nattl
 
Posts: 22
Joined: 26. October 2005 07:50
Location: Vienna

Postby deepsurfer » 27. October 2005 19:18

BACK TO THE ROOTS...ich seh schon das toto75 etwas überfordert sein könnte...


Hilfe, ich bin ganz neu hier, habe natürlich die Suche-funktion genutzt aber irgendwie verstehe ich nur Bahnhof...

Verstehst du nur Bahnhof was dir dei Suchmaschine als ergebnis liefert oder was du vermeintlich als ergebnis liest ?
Schreib mal deine Suchwörter hierhin..

Code: Select all
Ich hatte bis vor kurzem Apache2 und PHP4 einzeln installiert und konnte dort Emails per Kontaktformular versenden.

Also als einzelne Pakete auf deinem Windows PC installiert, oder war es auch so ein fertig Paket wie das XAMPP ?

Jetzt habe ich XAMPP 1.4.16 am laufen und das Script geht nicht mehr...

Hast du dieses Script 1 zu 1 herüberkopiert und nichts verändert ?

Folgender Fehler nach dem Absenden:
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\ (.....)

Wie deine Thread-Überschrift vermuten lässt, hast du den Zusammenhang zwischen Script und Mailserver verstanden.
Nun taucht aber daher nochmal die Frage auf ob deine vorherige Installation alles Einzel Komponenten waren oder auch ein Webserver Paket wie das XAMPP ?

Wer kann mir sagen, was da los ist?

Wollen mal schaun ob man das jetzt hinbekommt......
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby toto75 » 27. October 2005 23:01

@deepsurfer
Ja ich bin wirklich überfordert! Immerhin beschäftige ich mich schon ganze 4 Wochen (!) mit php+co, bin also noch jungfräulich...

Ich habe noch nirgens eine Anleitung gefunden, die mir erklärt, wie ich auf meinem lokalen System Mercury Mail konfiguriere, dass ich z.B. ein Kontaktformular etc. verwenden kann...

Apache2 und PHP4 waren einzeln installiert und es lief problemlos. Dann sollte MySql dazukommen. Die Installation habe ich überhaupt nicht hinbekommen, so dass ich nach etwas suchn auf XAMPP gekommen bin. Also alles deinstalliert und XAMPP installiert...

Am Script ist nix anders, im Netz gehts auch problemlos.
User avatar
toto75
 
Posts: 8
Joined: 21. October 2005 21:55
Location: D-59269 Beckum

Postby deepsurfer » 27. October 2005 23:27

Ich habe noch nirgens eine Anleitung gefunden, die mir erklärt, wie ich auf meinem lokalen System Mercury Mail konfiguriere, dass ich z.B. ein Kontaktformular etc. verwenden kann...

Dann hast du hier im Forum die SUchfunktion etwas falsch bedient, denn hier gibt es eine komplette Anleitung darüber.
Aus diesem Forum hier:
http://community.apachefriends.org/f/viewtopi ... 7424#47424

Ein sogar leicht im Internet zu finden:
http://www.bananajoe.de/mercury32_conf.html

-- -- -- -- --

Apache2 und PHP4 waren einzeln installiert und es lief problemlos.
Dann sollte MySql dazukommen.
Die Installation habe ich überhaupt nicht hinbekommen,
so dass ich nach etwas suchn auf XAMPP gekommen bin.
Also alles deinstalliert und XAMPP installiert...



Da frag ich mich wie dein (das) Script überhaupt Mails versenden konnte auf dem PC wo nur Apache und PHP Installiert waren.
(Ausgehend davon das dieses Script genauso unverändert vom Webspace auf die Apache|PHP kopiert wurde wie auch jetzt im XAMPPeingebaut ist)
Denn nach deiner Beschreibung war auf dem Apache|PHP Installation kein Mailserver vorhanden.


Am Script ist nix anders, im Netz gehts auch problemlos.

Etwas Licht bringt diese Äusserung von dir, kann es sein das dieses Script NUR auf dem Webspace funktioniert hat und nicht wie du beschreibst auf dem Installation wo Apache|PHP vorhanden war???

Sei mir nicht böse, wenn ich das soooo haarklein auseinanderpflücke, aber es ist schon ein gewaltiger Unterschied zwischen dem Webspace wo das Script funktioniert und einer Apache|PHP Installation bei dir zuhause.

Ich gehe jetzt mal von folgendem Konstrukt aus:

a) Script auf Webspace = funktioniert

b) Idee zu Hause einen eigenen Server benutzen und daher Apache und PHP Installiert, die freude war gross das dieses Script (vom Webspace) bis auf die Mailfunktion bei dir zuhause läuft.

c) Aufgrund einiger weiteren Ideen. Hast du gedacht, man könnte MySQL hinzubauen und noch glücklicher werden.......dies ging etwas daneben und es wurden Alternativen gesucht, wie etwa das XAMPP hier.

d) Dadurch das der mailversand nicht funktioniert hast du dir schon gedanken gemacht und gesehen das im XAMPP ja alles vorhanden wäre.
Apache - PHP - MySQL -Mailserver

und nun stehst du halt vor dem Problem das eben dieses Script auch im XAMPP soweit funktioniert bis auf den Mailversand und möchtest jetzt eigentlich nur den Mercury zum laufen bringen.
(Links zur Anleitung sind ja schon bekannt)

=====>> Stimmt das so ???? <<=====
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby toto75 » 28. October 2005 05:59

@deepsurfer

Du hast recht, so war es. Bis auf die Ausnahme, dass das Kontaktformular-Script lokal wirklich lief und ich mit diesem immer eine Email bekommen habe.

Werde mal sehen, ob ich die Anleitung verstehe... :?: :D
User avatar
toto75
 
Posts: 8
Joined: 21. October 2005 21:55
Location: D-59269 Beckum

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests