Xampp Installation schlägt fehl, install.php fehlerhaft

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp Installation schlägt fehl, install.php fehlerhaft

Postby 50ngrs » 06. October 2005 20:55

Hallo,

da ich den Aufbau eines Servers aus Einzelkomponenten partout nicht hinbekomme (apache2, php5, mysql4.1, phpmyadmin2.6.4), hab ich mich dafür entschieden, Xampp zu installieren. Bei einem Projekt in unserer Schule haben wir das auch verwendet, allerdings die Linux-Variante. Es lief super. Wie auch immer....

Von der alten Installtion der Einzelkomponenten habe ich alles gelöscht und deinstalliert. Dann habe ich das Zip-Archiv heruntergeladen und es nach I:\Server\install\ entpackt. Dann wollte ich im Hauptverzeichnis xampp die setup_xampp.bat ausfürhen, so wie es auf der Webseite steht. Im cmd-Fenster erscheinen aber daraufhin fortlaufend Fehlermeldungen. Immer abwechselnd(den genauen Wortlaut weiss ich nicht mehr):

ungültiges Argument install\install.php feof() 477

und

ungültiges Argument install\install.php fgets() 479

Da in Zeile 477 eine while-Schleife mit feos() beginnt (ich hab nachgeguckt), entsteht dadurch eine Endlosschleife und die Batch kann nicht beendet werden. Das ungültige Argument ist in diesem Fall $datei, das einige Zeilen vorher mit fopen() geöffnet werden sollte. Die Konfiguration wird also nicht zuendegeführt und ich kann weder Apache noch Mysql starten.

Leider kann ich mich mit dem ganzen gecode in der install.php kaum aus und würde nun gern wissen, ob es da irgendeine Lösung gibt, die Batch erfolgreich zuende zu führen und einen Webserver erfolgreich aufzustellen.

MfG
50ngrs
50ngrs
 
Posts: 2
Joined: 06. October 2005 20:24

Postby 50ngrs » 06. October 2005 20:56

Achso, ich arbeite mit WinXP SP2 mit allen aktuellen Updates...

50ngrs
50ngrs
 
Posts: 2
Joined: 06. October 2005 20:24

Postby Wiedmann » 06. October 2005 22:14

Well, für den schnellen Fix:
Installiere den XAMPP nicht in einem Verzeichnis, wo im Pfad ein Verzeichnis vorkommt das mit "install" anfängt.

Ansonsten musst du kurz warten.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Wiedmann » 07. October 2005 00:09

Sodele, mit dieser install.php (Speichern unter...) sollte es dann klappen.

BTW:
Das du nach so langer Zeit wie es diesen Code schon gibt der Erste bist der sich darüber beschwert... Der Fehler hat sich echt lang gehalten ;-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby UdoA » 10. October 2005 09:41

@Wiedmann

Bisher habe ich den XAPP 1.4.15 mit Perl Addon genutzt. Nun hab ich mir das Update auf den 1.4.16 angesehen und dabei ist mir folgendes aufgefallen:

Sowohl im xampp-upgrade-1.4.16.exe (7-ZIP) als auch im xampp-perl-addon-5.8.7-2.0.54.exe (7-ZIP) gibt es eine \install\install.php

Das was mich dabei stört ist, das man das Perl Addon normalerweise einfach in den XAMP Ordner kopiert, jedoch ist die install.php im XAMP Ordner neueren Datums als die im Perl-Addon. Somit würde ich ja die neuere Datei überschreiben. Sie unterscheiden sich auch in einigen Zeilen ....

Welche install.php ist den nun die richtige ? Oder soll ich die hier angebotene nehmen ? 8)
UdoA
 
Posts: 1
Joined: 10. October 2005 09:26

Postby Wiedmann » 10. October 2005 20:09

Hallo Udo,

jedoch ist die install.php im XAMP Ordner neueren Datums als die im Perl-Addon. Somit würde ich ja die neuere Datei überschreiben. Sie unterscheiden sich auch in einigen Zeilen ....

Tatsache. Und ich dachte im Perl-AddOn sei die gleiche wie im Upgrade. Die Vorhandene aus dem Upgrade ist dann neuer als die im AddOn.

Welche install.php ist den nun die richtige ? Oder soll ich die hier angebotene nehmen ?

Im Zweifel natürlich die Neuere ;-)

Seit diesem Post hier hat sich nochmal was in dieser Datei geändert. Siehe (sofern einen die hier besprochenen Fehler stören):
http://community.apachefriends.org/f/viewtopi ... 9192#59192
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests