seltsame Frage

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

seltsame Frage

Postby ASKOA » 28. September 2005 13:52

Ein freundliches Hallo an alle
Habe da mal eine kleine anfrage :
Ich arbeite gerne mit XAMPP und hatte bis jetzt auch keine größeren Probleme. Tja nur jetzt habe ich eines .
Auf meinem Online Server ist die Mysql version 4.0.18 installiert und jedes mal wenn ich jetzt die DB zwischen Online und Local schieben muß bekomme ich immer die nette Meldung Mysql version ...
Daher meine Frage in welcher XAMPP version war die Version von Mysql 4.0.18 enthalten und wie schaffe ich es dann diese und die aktuelle XAMPP version auf Windows gleichzeitig zu Installieren. Damit ich halt im bedarfs fall die jeweilige version laufen lassen kann.
Thanks and a nice Day
ASKOA
ASKOA
 
Posts: 4
Joined: 28. September 2005 13:32

Postby deepsurfer » 28. September 2005 15:27

http://faq.kwm-web.info/doku.php?id=xam ... und_inhalt

zu dem Thema, wie kann man den Aktuellen XAMPP mit der älteren MySQL Version einrichten...
Da muss ich passen, vielleicht melden sich aber noch einige dazu.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby ASKOA » 28. September 2005 15:42

Ich gestehe ,
diesen Link kannte ich bis jetzt nicht einmal.
Ein GROSSES DANKE.
Lade mir gleich die version für mich runter.
Muß ich halt schauen das ich meine Projekte soweit anpasse .
Aber vieleicht kennt ja jemand eine lösung.
Tja manchmal verflucht man halt den Tag and dem man seinen alten der Frau überlassen hat. So nah und doch kein ran kommen mehr ;-)

Nochmals DANKE
ASKOA
 
Posts: 4
Joined: 28. September 2005 13:32

Postby Wiedmann » 28. September 2005 20:29

Aber vieleicht kennt ja jemand eine lösung.

Gib doch beim Export einfach an für was für einen Zielserver der Export bestimmt ist?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Leider nen Shop

Postby ASKOA » 29. September 2005 11:12

ist leider ein Shop mit dB-sicherung.
Entweder nur raw-Format das läßt sich dann auch einwandfrei zurücksichern .
Leider gibt es bei dem Versuch das backup von local auf online zu importieren immer einen Versions-konflikt.
Und PHPadmin ist auf mein Server uralt.
Daher keine Ahnung wie ich die Ziel-Version angeben soll.
ASKOA
 
Posts: 4
Joined: 28. September 2005 13:32

Postby deepsurfer » 29. September 2005 12:11

Und PHPadmin ist auf mein Server uralt.

Warum installierst du nicht einfach eine neue Version auf dem OnlineServer?

Phpmyadmin ist ein standalone Produkt das nicht in ein Systembereich vordringt.
- Downloade dir das neue phpmyadmin
- entpacke es
- editiere die config.inc.php mit den Online-Server DBzugangsdaten
- schicke es via FTP hoch auf den Online-Server in ein neues Verzeichnis
- schütze dieses Verzeichnis mittels htaccess
und schon hast du eine neue Version auf deinem Pnline Server
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 29. September 2005 12:36

deepsurfer wrote:
ASKOA wrote:Und PHPadmin ist auf mein Server uralt.

Warum installierst du nicht einfach eine neue Version auf dem OnlineServer?

Das hilft ihm nicht. Er muss das ja auf seinem lokalen Server passend exportieren. Welche phpMyAdmin-Versino auf dem Zielserver ist, ist dabei uninteressant.

ASKOA wrote:Entweder nur raw-Format das läßt sich dann auch einwandfrei zurücksichern .

Und was ist das "oder"?
Muss aber ein komischer Webshop sein, der sein eigenes Format nicht auf jedem System wieder importieren kann.

Und mit phpMyAdmin kannst du lokal nicht einfach die ganze Shop-DB exportieren und remote wieder installieren? Bei dieser Methode musst du dann eben phpMyAmdin sagen was du für einen Zielserver hast. Ich würde an deiner Stelle mal beim Hersteller von diesem Shop nachfragen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Ok Fehler meinerseits

Postby ASKOA » 29. September 2005 13:20

Das RAW format nimmt der Shop auf jedem system ( wenn ich mich jetzt nicht täusche )Der RAW import klappte nur nicht immer . Vieleicht auch ein fehler von mir .
Es gab immer nur die nette meldung ... Insert ... Mysql Version.
Ist jetzt aber auch egal .
Habe mir die Version 1.4.2 von XAMPP in ein anderes Verzeichnis kopiert .
Jetzt stimmen soweit die PHP /Msql version überein.
Lieber 2 Version von XAMPP als mir noch 3x die DB zerschießen .
Da half dann halt das backup nicht mehr.
Aber es kann auch am Frust und an den kurzen nächten gelegen haben.
Aber wie gesagt das Problem ist vom Tisch der Online-Shop läuft soweit und an der Local-version arbeite ich gerade.Soweit ich es bis jetzt sehe klappt alles.
Nochmals Danke für eure hilfe.
ASKOA
ASKOA
 
Posts: 4
Joined: 28. September 2005 13:32


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests