htaccess ??

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

htaccess ??

Postby Guest » 12. June 2003 21:03

wahrscheidnlich schon der 100 Beitrag dazu, aber ich frag nochmals!

habe nur noch https also port 443 freigegeben.
möchte die ganze seite passwort schützen.

Konfigs:
*******
httpd.conf:
ServerRoot "/wampp2/apache"
AccessFileName .htaccess

.htaccess ist unter /wampp2/apache
-------------------------------
AuthType Basic
AuthName test
AuthUserFile C:\wampp2\apache\passwd
require valid-user
-------------------------------
passwd:
-------------------------------
BoNoMp3:$apr1$AH0.....$Ss1lZvOd57JPyH7f9LhN4/
-------------------------------

Benutze wampp2.1

die startseite wird ganz normal geladen ohne passwortabfrage, was mache ich fallsch?
Guest
 

Re: htaccess ??

Postby AlexPausB » 12. June 2003 22:33

Hey Gast!

Hast recht - gibt schon so einige Beiträge zu .htacces ;-) aber jetzt mal zu Deinen Problemen:

1) AccessFileName und ServerRoot passen.

2) deine .htaccess liegt falsch. Die Datei muss in das zu schützende Verzeichnis gelegt werden. D.h. also wenn du im htdocs-Verzeichnis einen Ordner "admin" hast und willst diesen schützen, _muss_ die .htaccess auch in diesem Ordner liegen. Willst du das komplette Web-Dir schützen, legst Du die Datei in den htdocs Ordner.

3) AuthUserFile C:\wampp2\apache\passwd ist falsch. Du musst den Pfad mit normalen slashes angeben, z.B. so
Code: Select all
c:/wampp2/apache/.passwd
!!

4) Verschlüsselte Passwörter innerhalb der passwd sind bei Windows-Rechnern nicht möglich. Sie _müssen_ im Klartext drin stehen! Zum Bleistift

Code: Select all
alex:geheim


Oki ? Probier das mal aus!

Tschööö
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests