root passwort geändert - komm nicht mehr rein

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

root passwort geändert - komm nicht mehr rein

Postby Klaus Ragotzky » 27. September 2005 09:23

Hei.
Sorry, ihr hört das sicher oft.
Aber es funzt nicht mehr, werd hier noch verrückt!

Bin der Meinung, dass ich diese Schritte vollziehe:
http://www.apachefriends.org/de/faq-xampp-windows.html#cpu

Aber wenn ich unter Sicherheitscheck die Passwörter für root und den Verzeichnisschutz für phpmaydaminändere, dann komme ich nicht mehr auf phgpmyadmin...

Sind ja nur 2 Passwort-Konstellationen, viel kann ich da ja nicht falsch machen

Was mache ich denn falsch?


Gruß Klaus
Das Problem sitzt mal wieder vor dem Bildschirm
Klaus Ragotzky
 
Posts: 33
Joined: 06. April 2003 09:10

Postby Wiedmann » 27. September 2005 09:43

Was für einen XAMPP hast du (Version/Lite)? Wie lädst du MySQL. Hast du MySQL nach der Passwortänderung mal neugestartet?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Klaus Ragotzky » 27. September 2005 10:14

Hei wiedmann.

Habe die installer-version 1.4 15 xampp für Windows runtergeladen, die neueste.
Wie ich MySQL lade? Weiß nicht, über klick in dem ControlPanel 2.1?

Die CD-Verwaltung will auch nicht, die anderen Beispiel ja.

Hatte vorher (ohne Passwortänderung) schon meine Datenbanken eingespielt.

Dann geändert, dannn nix mehr rauf.
In der config.inc.php auch geändert.


:cry:

Klaus


Nachtrag
Hallo.

Hilft euch das?
Ich hatte, bevor ich das Passwort änderte einen neuen Benutzer angelegt. Das Passwortweiß ich definitv. Funzt aber auch nicht. Wo finde ich denn den Benutzer? Auch in der config.inc.php?
Das Problem sitzt mal wieder vor dem Bildschirm
Klaus Ragotzky
 
Posts: 33
Joined: 06. April 2003 09:10

Postby deepsurfer » 27. September 2005 13:23

Bei der CD-DEMO musst du nach ausführen des Security-Scripts, die Datei
\xamppßhtdocs\xampp\cds.php editieren, darin das neue PW eintragen (ca. Zeile 4).

In der config.onc.php von PHPmyadmin nicht einen neuen Eintrag mit den Passwörtern eintragen sondern die schon vorhandene ändern
für PMA = ca. Zeile 79
für root = ca. Zeile 86
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Klaus Ragotzky » 04. October 2005 12:47

Hallo.
So, da ich nicht richtig rein kam. habe ich das neu aufgespielt.
Jetzt kommne ich noch nicht einmal ohne Änderung von root und Passwort auf die DB per phpmyadmin.

Jemand eine Idee, was ich falsch mache?

Danke.

Gruß
Klaus
Das Problem sitzt mal wieder vor dem Bildschirm
Klaus Ragotzky
 
Posts: 33
Joined: 06. April 2003 09:10

Postby deepsurfer » 05. October 2005 13:20

was ? hast du neu aufgespielt .... XAMPP ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Klaus Ragotzky » 05. October 2005 20:15

Hallo deepsurfer.

Ja, xampp 1.4.15 gelöscht und dann noch mal raufgeballert.

Nun funzt es so, dass ich mit der Voreinstellung auf phpmyadmin komme.

Als ich das letzte Mal unter securitycheck das Passwort änderte kam ich nicht mehr auf meine Datenbank.
:roll:
Mal sehen, wie es dieses mal funzt.

Vorgehensweise ist doch einfach beim Sicherheits-Check den Link nutzen und das Passwort für die Db ändern sowie den Verzeichnisschutz für phpmyadmin, richtig?

Gruß
Klaus
Das Problem sitzt mal wieder vor dem Bildschirm
Klaus Ragotzky
 
Posts: 33
Joined: 06. April 2003 09:10

Dreh noch durch - es funzt nicht!

Postby Klaus Ragotzky » 08. October 2005 16:11

Hallo.

Unter xampp/security stehen der Benutzer und das Passwort, das ich eben änderte.
Jetzt habe ich sie mit dem security-link wieder geändert und es geht wieder nicht.
Obwohl winmysqladmin das Passwort zeigt, das ich eingegeben habe.

Und doch kann er mich mit phpmyadmin am SQL-Server nicht anmelden.

Was ist denn da los, bitte?

Rückgängig machen funzt auch nicht (schreibe die alte config_inc.php wieder zurück, aber geht nicht)

Hilfe! Wer kann helfen?

Danke.
Klaus
Das Problem sitzt mal wieder vor dem Bildschirm
Klaus Ragotzky
 
Posts: 33
Joined: 06. April 2003 09:10

Postby deepsurfer » 08. October 2005 17:54

hast du mal testweise das .htaccess aus \htdocs\xampp herausgenommen ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Klaus Ragotzky » 08. October 2005 21:33

Hallo deepsurfer.

Unter meinem Rechner hat wohl die Xampp für Windows 1.4.15 die Probleme verursacht.
Habe die 1.4.16 runtergeladen, alles neu und wie in der Vergangenheit funzt es nun wieder.

Gruß und Danke.
KLaus
Das Problem sitzt mal wieder vor dem Bildschirm
Klaus Ragotzky
 
Posts: 33
Joined: 06. April 2003 09:10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests