IMAP aktivieren

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

IMAP aktivieren

Postby sati » 22. September 2005 13:23

hallo zusammen,

ich hab jetzt auf dem server xampp laufen und habe phprojekt installiert, das problem hierbei ist jetzt nun, dass imap aktiviert werden muss, damit der mailversand überhaupt erfolgt.
in der hilfe steht, dass im xampp der imap support für php standard deaktiviert ist, da es bei manchen homeversionen von windows zu rätselhaften initialisierungsfehlern kam. wer nt-systeme benutzt sollte nun die datei \xampp\apache\bin\php.ini öffnen und dort die zeile ;extension=php_imap.dll entkommentieren. das mache ich hier auch (habs auch schon mit den anderen php.ini`s versucht), wenn ich den apache server stoppe und von neuem starte wird der fehler "apache.exe - unable to locate DLL: the dynamic link library secur32.dll could not be found in..." und danach "php_imap.dll nicht gefunden wird" aufgeführt.
was mache ich hier falsch?
mfg
sati
sati
 
Posts: 4
Joined: 22. September 2005 12:22

Postby deepsurfer » 22. September 2005 13:46

also wenn du, wie in der Anleitung beschrieben nur diese php.ini editierst und das ";" entfernst sollte XAMPP-Apache ganz normal hochfahren.

Daher irretiert mich deine Aussage
" (habs auch schon mit den anderen php.ini`s versucht) "
denn nirgendwo stand das du eine andere php.ini editieren solltest.

Das heisst nun das du erstmal alle von dir geänderten php.ini in den grundzustand bringen solltest und dann nur die eine beschriebene php.ini editieren.
Denn bei einem gegentest eines frisch entpacken XAMPP 1.4.15 und editieren der beschribenen php.ini, startet XAMPP einwandfrei durch.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 22. September 2005 13:47

"apache.exe - unable to locate DLL: the dynamic link library secur32.dll could not be found in..."

Das wäre aber seltsam. Die "secur32.dll" gehört zu Windows, und Windows hätte arge Probleme wenn diese nicht vorhanden wäre.

Allerdings haben wir auch eine Suchfunktion, und diese Datei wurde wohl von MS mal umbenannt:
http://community.apachefriends.org/f/viewtopic.php?t=10344
Last edited by Wiedmann on 22. September 2005 13:50, edited 1 time in total.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sati » 22. September 2005 13:49

die anderen php.ini dateien habe wieder in den orginalzustand zurückgebracht, wenn ich aber bei der \xampp\apache\bin\php.ini die extension aktiviere bekomme ich diese fehlermeldung.
sollte ich vielleicht die xampp komplett neu installieren, da die version die ich benutze schon vorinstalliert war (firmen-test-server) und ich nicht weiss welche einstellungen sonst verändert worden sind.
sati
 
Posts: 4
Joined: 22. September 2005 12:22

Postby Wiedmann » 22. September 2005 13:51

Siehe Nachtrag oben.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sati » 22. September 2005 13:52

danke für den tipp werde es gleich mal ausprobieren, der beitrag hört sich nach dem selben problem an wie bei mir.
thx
sati
sati
 
Posts: 4
Joined: 22. September 2005 12:22

Postby sati » 22. September 2005 14:08

super!! danke, hat geklappt :D
sati
 
Posts: 4
Joined: 22. September 2005 12:22


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests