gettext und localhost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

gettext und localhost

Postby hajonie » 15. September 2005 18:20

Hallo!

Habe mir unter Win XP und xampp die Menalto Gallery2 installiert und in Mambo integriert. Damit das ganze auch in deutscher Sprache funktioniert, muss gettext installiert werden. Das klappt auch soweit, wenn ich in der php.ini das Semikolon vor extension=php_gettext.dll entferne.
Nun aber das merkwürdige, wenn ich im Browser http://localhost/mambo eingebe, will der Browser immer auf www.localhost.com zugreifen.
Warum passiert das?
Wenn ich php_gettext wieder ausschalte, klappt alles wieder (die Galerie natürlich wieder nur in Englisch).
Hat jemand einen Rat oder Tip für mich?

Gruß
Hajo
hajonie
 
Posts: 1
Joined: 28. March 2005 13:53

Postby deepsurfer » 15. September 2005 22:02

Schau mal in der PHP.INI nach, dort ist nur ein sendmal verweis auf localhost.com

nimm mal das ".com" dort weg und starte den gettext nochmal...
sollte das www.localhost.con nun www.localhost anzeigen, so wäre mein theroi bestätigt das der gettext aus der sendmail definition die eigene URL ausliest.

--- Wie gesagt, ist jetzt nur eine theorie von mir ---
Hab jetzt durch meine halbherzige suche nicht alles im XAMPP nach "localhost.com" durchsucht.


EDIT:
Zusatzfrage--> hast du unter umständen in der httpd.conf den
"ServerName=localhost" in "..=www.localhost.com" geändert ????
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests