XAMPP for Windows apache doesn't start.

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP for Windows apache doesn't start.

Postby htg » 13. September 2005 11:26

Hello,

I have installed XAMPP under C:\apachefriends\xampp\. I have a problem because I can't start apache. However I changed it's port too 81 (I have IIS listening under port 80). When I start apache I get this error's:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Elk socketadres (protocol/netwerkadres/poort) kan normaal slechts ÚÚn
keer worden gebruikt. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Druk op een toets om door te gaan. . .

I used httpd.conf and I changed this line:

#Listen 12.34.56.78:80
Listen 81


In the control panel of XAMPP there will be no option to click Stop. Because the service simple doesn't run. What is my problem? I have also checked port 8080. I don't see a page at http://localhost:81.


Thank you 8)

htg
Last edited by htg on 13. September 2005 11:30, edited 1 time in total.
htg
 
Posts: 6
Joined: 21. June 2005 11:20

Postby deepsurfer » 13. September 2005 11:29

you must change port 443 in "ssl.conf"
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby htg » 13. September 2005 11:30

Ok I will. What is the second port for SSL?

Thanks!
htg
 
Posts: 6
Joined: 21. June 2005 11:20

Postby deepsurfer » 13. September 2005 11:45

htg wrote:Ok I will. What is the second port for SSL?

Thanks!


try 445
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 13. September 2005 11:58

try 445

Not really a good idea. 445 is the port for smb sessions on Windows... If you don't use SSL, you can disable SSL completly.

What is the second port for SSL?

Where is no second port for SSL. SSL have the Port 443.
And HTTP have the port 81. (81 is not a second Port for HTTP)

Why want you change these ports?

BTW:
If you want use your own ports, you should use ports greater then 1024.
eg: 8080 and 8443.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests