mercury als service / dienst

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mercury als service / dienst

Postby j©sh » 06. September 2005 09:41

hallo,

habe mir gestern die aktuellste version von xampp installiert und alles läuft bisher prima - bis auf eine "kleinigkeit".

der mercury mailserver lässt sich einfach nicht als dienst unter XP installieren, das heißt das ich ihn nach einem reboot des systems manuell starten muß.

bei den servicesettings im control panel habe ich einen hacken bei mercury gemacht, aber das hat keine auswirkungen. svc bleibt im hauptmenü grau unterlegt und nicht wie alle anderen mit einem hacken aktiviert.

was kann /muß ich da ändern, damit mercury automatisch mit allen anderen komponenten startet.

beste grüße,
josch
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Postby deepsurfer » 06. September 2005 14:41

als notlösung hätte ich jetzt anzubieten eine Verknüpfung ins "Autostart" von Mercury zu setzen, dann würde er gestartet.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby j©sh » 06. September 2005 14:54

ne, das ist mir zu blöd - ich möchte das alles "silent" im hintergrund läuft.

gibts denn keine möglichkeit den mailserver als dienst zu starten, bzw was ist der grund warum das nicht geht?

gibts evtl. ein tool was die dienstverwaltung von xp dahingehend tuned das man manuell services hintzufügen kann?
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Postby Wiedmann » 06. September 2005 15:20

der mercury mailserver lässt sich einfach nicht als dienst unter XP installieren,

Der Mercury lässt dich nicht (ohne Zusatztools) als Dienst installieren.
Wie das im Control Panel gehandelt wird kann ich nicht sagen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby j©sh » 06. September 2005 15:32

also die option ist im control panel (bei mir zumindest) nicht verfügbar.

prima das es wenigstens ein zusatztool gibt womit ich mein problem lösen kann.

würde mich über einen tipp freuen wonach ich googeln kann, oder wo ich so ein zusatzsoftware direkt finde.
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Postby Wiedmann » 06. September 2005 15:42

Running Mercury/32 as an NT Service
http://kbase.pmail.gen.nz/viewfull.cfm? ... 08C709E5EC
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby j©sh » 06. September 2005 16:03

probiere gerade das tool zu nutzen, da ich aber mit XP unterwegs bin gibts gerade probleme mit dem "how-to", da ich kein instsrv auf meinem system habe. :-/

ich googel dann mal weiter - vielleicht weiß noch jemand was, damit ich schneller ans ziel gelange.
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Postby Wiedmann » 06. September 2005 16:23

ich googel dann mal weiter - vielleicht weiß noch jemand was, damit ich schneller ans ziel gelange.

Zuwas googeln? Schneller als mit dieser Schritt für Schritt Anleitung kommst du nicht ans Ziel... (jedenfalls nicht mit FreeWare)

da ich aber mit XP unterwegs bin gibts gerade probleme mit dem "how-to", da ich kein instsrv auf meinem system habe.

Das hat nichts mit XP zu tun, da dieses Tool bei keinem Windows dabei ist. Allerdings beschreibt der Ansprechende Punkt im How-To ja was zu tun ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby j©sh » 06. September 2005 17:40

ich habe das how-to wohl gelesen, dort steht:

Type: INSTSRV Mercury32 c:\winnt\system32\srvany.exe

es kann also nicht srvany.exe - welches ich natürlich wie beschrieben in system32 kopiert habe ausgeführt werden, da die ausgabe kommt: instsrv nicht gefunden.

was mache ich da?
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Postby Wiedmann » 06. September 2005 17:52

da die ausgabe kommt: instsrv nicht gefunden.

Hast du dann instsrv auch da hinkopiert?

BTW:
es sollte bei XP dann alternativ auch so gehen:
Code: Select all
sc create Mercury32 binPath= c:\%windir%\system32\srvany.exe
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby j©sh » 06. September 2005 19:27

also mit sc create hat es geklappt. mercury32 steht nun bei den diensten zur auswahl.
leider lässt sich der dinest aber nicht starten, bzw. schließt sich automatisch wieder mit der meldung:

dienst wurde gestartet und wieder angehalten - da er sich im leerlauf befindet.

wieso wird es mir nur so schwer gemacht dieses proggy auch noch als service zu starten. :roll:
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Postby Wiedmann » 06. September 2005 19:45

leider lässt sich der dinest aber nicht starten

Die Registry-Einträge wie in der FAQ beschrieben hast du gemacht?

wieso wird es mir nur so schwer gemacht dieses proggy auch noch als service zu starten.

Weil das Programm ursprünglich nicht dafür gedacht/gschrieben wurde? ...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby j©sh » 06. September 2005 19:55

yup, die registryeinträge habe ich natürlich gemacht.

aber mal was anderes - wie kann man einen emailserver für windows entwickeln, ohne ihn dort als service laufen lassen zu können???

ist das einfach nur vergessen worden oder hat das einen bestimmten grund?
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Postby Wiedmann » 06. September 2005 20:08

yup, die registryeinträge habe ich natürlich gemacht.

Mach mal einen Export des entsprechenden Zweiges und poste den hier.

wie kann man einen emailserver für windows entwickeln, ohne ihn dort als service laufen lassen zu können???

Ist das eine Voraussetzung? Und wie gesagt. Das genannte Tool ist ja genau dafür entwickelt worden. Also warum das in den Server auch noch einbauen? (Setzt natürlich ein gewisses Wissen des Serverbetreibers über das Betriebssytem das er benutzt voraus ;-)

BTW ist dieser Mailserver ursprünglich für Novell Netware entwickelt worden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby j©sh » 06. September 2005 21:07

also jetzt wird mercury32 angeblich gestartet, aber funzt nicht. :-/

über das controlpanel wird angezeigt das mercury gestartet ist, aber ich kann es nicht administrieren.

hab vielleicht zuviele einträge in der registry?!
wieviele müßen es sein - hab einen unter /service/Mercury32 und dann taucht mercury32 noch woanders auf- ist das richtig?

hier mein registryeintrag:
Code: Select all
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mercury32]
"Type"=dword:00000110
"Start"=dword:00000002
"ErrorControl"=dword:00000001
"ImagePath"=hex(2):63,00,3a,00,5c,00,77,00,69,00,6e,00,64,00,6f,00,77,00,73,00,\
  5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,72,00,76,\
  00,61,00,6e,00,79,00,2e,00,65,00,78,00,65,00,00,00
"ObjectName"="LocalSystem"
"DisplayName"="Mercury32"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mercury32\Parameters]
"Application"="c:\\xampp\\mercurymail\\mercury.exe"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mercury32\Security]
"Security"=hex:01,00,14,80,90,00,00,00,9c,00,00,00,14,00,00,00,30,00,00,00,02,\
  00,1c,00,01,00,00,00,02,80,14,00,ff,01,0f,00,01,01,00,00,00,00,00,01,00,00,\
  00,00,02,00,60,00,04,00,00,00,00,00,14,00,fd,01,02,00,01,01,00,00,00,00,00,\
  05,12,00,00,00,00,00,18,00,ff,01,0f,00,01,02,00,00,00,00,00,05,20,00,00,00,\
  20,02,00,00,00,00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,0b,00,00,00,00,\
  00,18,00,fd,01,02,00,01,02,00,00,00,00,00,05,20,00,00,00,23,02,00,00,01,01,\
  00,00,00,00,00,05,12,00,00,00,01,01,00,00,00,00,00,05,12,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mercury32\Enum]
"0"="Root\\LEGACY_MERCURY32\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001
j©sh
 
Posts: 10
Joined: 06. September 2005 09:33

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests