mysql server startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mysql server startet nicht

Postby Yupa » 02. September 2005 09:08

Hallo,

ich habe folgendes Problem:
Ich versuche nach dem Vorgehen, das in der README angegeben ist, den ApacheServer und den MySqlServer zu starten. Mit dem Apache habe ich kein Problem, nur beim starten des MySqlServer bekommen ich folgende Ausgabe:
MySQL is starting with mysql/bin/my.cnf
Befehl oder Dateiname nicht gefunden
MySQL konnte nicht gestartet werden


Im Taskmanager wird mir nun aber einen laufende mysql Anwendung angezeigt, die aber nur über diesen zu stoppen ist.
Versuch ich mit xampp_control.exe die Server zu starten, klappt es mit beiden, aber ich kann nicht auf mysql zugreifen. Hab's mit myPHPAdim probiert und immer eine Fehlermeldung bekommen. Bin im Moment ein bisschen überfragt, wo das Problem liegt.
Hier noch ein paar Angaben zu meinen System:
windows 98 (Hardware bedingte Benutzung)
xampp Version win32-1.4.15 (die setup_xampp.bat vorher ausgeführt)

Gruß Yupa
Yupa
 
Posts: 4
Joined: 02. September 2005 08:25

Postby deepsurfer » 02. September 2005 12:47

hattest du voher mal den MySQL als eigenes Produkt Installiert gehabt, oder mal ein anderes WAMPPsystem ausprobiert wo MySQL mit drinne war ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 02. September 2005 13:01

Hallo Yupa,
Hier noch ein paar Angaben zu meinen System:
windows 98 (Hardware bedingte Benutzung)
xampp Version win32-1.4.15 (die setup_xampp.bat vorher ausgeführt)

kopiere die aktuallisierten Batchdateien über die vorhandenen (Ziel speichern unter...):
\xampp\apache_start.bat
\xampp\mysql_start.bat
\xampp\apache\makecert.bat
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Yupa » 02. September 2005 19:18

Danke erst mal für die Antworten.

@deepsurfer Ich hatte bisher kein mysql auf meinem System laufen.

@Wiedmann Was sollen die veränderten Dateien bringen? Es öffnet sich nur ein DOS-Fenster in dem 'OFF' steht, aber einer der Server wird nicht gestartet.

Gruß Yupa
Yupa
 
Posts: 4
Joined: 02. September 2005 08:25

Postby Wiedmann » 02. September 2005 19:58

Es öffnet sich nur ein DOS-Fenster in dem 'OFF' steht, aber einer der Server wird nicht gestartet.

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Yupa » 02. September 2005 21:39

Ok, vielleicht ein bisschen zu ungenau.

Es öffnet sich eine MSDOS-Eingabeaufforderung(Console) mit dem Titel
'Beendet - mysql_start' und in diesem Fenster steht OFF, wie auch bei Apache_start.bat. Es scheint als würde keine der beiden Datei etwas starten.
Ich habe die neue und die alte Datei verglichen und die alte ursprüngliche Datei (mysql_start.bat) um '--console' erweitert. Nach dem Start erscheint folgende Meldung:
D:\XAMPP\MYSQL\BIN\MYSQLD.EXE ready for connections
Version: '4.1.13' socket: '' port: 3360 Source distribution

Anscheinend startet mysql oder nicht?.
Wenn ich nun über http://127.0.0.1 den Apache anspräche, steht unter Status, dass die MySQL Datenbank nicht aktiviert ist und phpmyadmin liefert die Meldung:
#2013 - Lost connection to MySQL server during query

:?:

MfG Yupa
Yupa
 
Posts: 4
Joined: 02. September 2005 08:25

Postby Wiedmann » 02. September 2005 22:48

Ich habe die neue und die alte Datei verglichen und die alte ursprüngliche Datei (mysql_start.bat) um '--console' erweitert

Dann hast du die Dateien aber nicht wirklich gut verglichen...

Aber war tatsächlich mein Fehler. Die Dateien lagen im UNIX-Format auf dem Server. Hab die jetzt ins DOS-Format konvertiert. Entweder du lädst sie nochmal runter, oder du konvertierst die wo du hast selber.

#2013 - Lost connection to MySQL server during query

Da fällt mir gerade nicht wirklich was ein...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Yupa » 03. September 2005 11:21

Es läuft jetzt :D

Besten Danke noch mal.

Gruß Yupa
Yupa
 
Posts: 4
Joined: 02. September 2005 08:25


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests