PHP und PhPMyAdmin Funktionen ?!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP und PhPMyAdmin Funktionen ?!

Postby Anny » 27. August 2005 15:00

Hi,

Ich habe mir heute mal XAMPP geladen und installiert.
Nun frag ich mich die ganze Zeit wo zum Teufel sind bitte die PHP und die PHPmyAdmin Button zum administrieren?!

Muss ich das erst irgendwo aktivieren?
Habs schon mit imap versucht aber das war wohl nur n Emaildienst oder soetwas he?

Egal kA ich will nur PhpMyadmin in der Lsite des Proggis finden,wäre nett wenn mir jemand weiterhelffen kann.

MfG,

anny
Anny
 
Posts: 8
Joined: 24. August 2005 20:18

Postby Anny » 27. August 2005 15:07

und ich hätte da noch eine frage...
und wazr kann ich unter http://127.0.0.1/xampp/xamppsecurity.php nichts aufrufen obwohl apache und alles am laufen ist.
Warum??
Hat das damit was zu tun vll. das ich noch einen Server installiert habe??
also noch nen Apache 2?
Dannn dürfte im CP aber nicht stehn das es läuft oder?!
Naja,dankeschonmal für die Antworten...

MfG,

Anny
Anny
 
Posts: 8
Joined: 24. August 2005 20:18

Postby Wiedmann » 27. August 2005 15:10

Nun frag ich mich die ganze Zeit wo zum Teufel sind bitte die PHP und die PHPmyAdmin Button zum administrieren?!

In der Hölle sind sie jedenfalls nicht...

Wo suchst du denn die Buttons? In den XAMPP Demoseiten (http://localhost/xampp/) gibts links im Menü einen Link zu phpMyAdmin. Den man natürlich auch jederzeit so aufrufen kann:
http://localhost/phpmyadmin/

PHP lässt sich nicht "administrieren". Wie für den Apache, gibt es hier nur eine Konfigurationsdatei ("\xampp\apache\bin\php.ini") um Einstellungen zu ändern.

und wazr kann ich unter http://127.0.0.1/xampp/xamppsecurity.php nichts aufrufen obwohl apache und alles am laufen ist.
Warum??

k.a. was passiert denn?
BTW müsste es doch dieser Link sein?
http://localhost/security/
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Anny » 27. August 2005 23:39

Not Found

The requested URL /xampp/ was not found on this server.

Das kommt!
Bei allen angeblich laufenden servicen!!!
Nichts!
Hab den anderen apache vorhin deinstalliert,und nun geht da garnichts mehr?
Ich denk ich installier XamPP und es läuft alles?
Was hab ich falsch gemacht?!

MfG und danke schonmal,

Anny
Anny
 
Posts: 8
Joined: 24. August 2005 20:18

Postby Anny » 27. August 2005 23:51

dazu kommt jetzt nach deinstallation von apache das auch mein mysql nicht mehr starten kann?!
Hallooo??
Was soll denn das.
Sorry wenns jemanden langweilt aber ich muss/ und tu auch das ganze ernst nehjen und hoffe mir hilft wer bei meinen Probs...

ThX mfg,

Anny
Anny
 
Posts: 8
Joined: 24. August 2005 20:18

Postby deepsurfer » 28. August 2005 02:09

hhhmmmm... mal durchatmen.

====================
In deinem Fall jetzt "back to the roots", weil wir erstmal einen Konsens brauchen um zu wissen was nun bei dir vorhanden ist.

Im moment lese ich aus den Zeilen folgendes:
- OS = Windows (aber keine angabe welches und ob Service Packs drauf sind)
- Selbst Installierter Apache (1.3.x oder 2.0.x ???)
- Selbst Installiertes MySQL (Version ?)
- Selbst Installiertes PHP (PHP4 oder PHP5)

- Installierter XAMPP 1.4.15 (Installer / ZIP / EXE-Zip ????)

Bisher hast du immer mit den einzel Programmen gearbeitet und hast nun einfach mal den XAMPP Installiert und ärgerst Dich jetzt das dieser nicht Funkioniert, weil aus logischen Denken her ja schon die Programme von dir Installiert wurden.
Aus deinen Ausführungen erkennt man auch das Du die Fehlermeldungen die da kommen "müssen" entweder schlicht weg nicht verstehst oder diese einfach nur falsch Interpretierst.
====================

Wie Wiedmann schon andeutet, bringt das sinnlose herumfluchen nix, zum einen tun die finger danach weh und zum anderen wird es deutlich schwieriger deinen Ausführungen zu folgen.

Bringe bitte erstmal dein System in einen Zustand als ob kein XAMPP und kein Separater Apache installiert wurde.
Ich bevorzuge in Deinem Fall diese Vorgehensweise, weil wie ich schon geschrieben habe, ich der Meinung bin das Du nicht weisst was da in deinem System gerade passiert.
Ein CrachKurs in zusammenhang mit deinen Äusserungen würde dann diesen Thread erheblich aufblähen.

Daher, wie einleitend gesagt "Ein Konsens schaffen" sodass wir hier in bezug auf Webserver Konfiguration auf einer Wellelänge sind.

----------- Schritt 1 -----------
Ich gehe nun davon aus das du weisst wie du den separaten Apachen DeInstallierst und auch weisst wie du eventuelle DIENST (Services) Einträge von dem Separaten Apachen aus deinem System entfernst.

Das selbe bitte auch mit dem Separaten MySQL.

Wenn Du das nicht weisst, können wir da sicherlich auch noch helfen.

----------- Schritt 2 wenn Schritt ein von dir beantwortet wurde -----------
Jetzt den XAMPP Installieren, und bitte nur mit dem XAMPP testen ob mit der eingabe im Browser http://localhost der Willkommenscreen von XAMPP erscheint.

Ich bitte Dich an dieser Stelle noch NICHTS am / im / um dem XAMPP etwas zu ändern, denn das kommt nachher dran.

Nun ?
- Läuft der XAMPP-Willkommenscreen, mit all seinen LINKs zum testen ?

Wenn JA dann haben wir den Konsens um weiter zu machen.
Beim Testen des Willkommenscreen wirst du sicherlich auch auf dem phpMyAdmin gestossen sein und wie Wiedmann schon erklärte kannst du den phpMyAdmin entweder über dem Willkommenscreen aufrufen ODER mittels direkt eingabe im Browser http://localhost/phpmyadmin

Sollte der XAMPP und der Willkommenscreen nicht funktionieren so ist es ratsam zu schreiben was Du nun gemacht hast ohne fluchen und dergleichen, damit wir hier es nachvollziehen können was Du mit der Maus und deiner Tasta so anstellst.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Anny » 28. August 2005 12:29

Oookay...

OS:WinXP ServicePack1

Selbst installiertes Apache = Jetzt deinstalliert
Selbst installiertes MySQL = Jetzt deinstalliert
Selbst installiertes PhP 5.0.4 = Jetzt deinstalliert
Selbst installiertes PhPMyAdmin = Jetzt deinstalliert
Selbst installiertes XamPP.exe 1.4.15 = Jetzt deinstalliert

Fehlermeldungen = 0 = nicht zu verstehn wenn da nichts kommt.
Wie Wiedmann schon andeutet, bringt das sinnlose herumfluchen nix, zum einen tun die finger danach weh und zum anderen wird es deutlich schwieriger deinen Ausführungen zu folgen.

Entschuldigung das ich in meinem ersten Post einmal wo zum Teufel sagte...

Nunja back to the Roots ;)
Also...

Ich hab jetzt alles deinstalliert.
Und soll nun einfach Xampp neu installieren?
Brauche nichts seperates,vorinstalliertes?
Ich probiers aus,deinstallieren kann man ja immenroch! =)

Hoffe es klappt ansonsten meld ich mich nochmal,

MfG,

Anny
Anny
 
Posts: 8
Joined: 24. August 2005 20:18

Postby deepsurfer » 28. August 2005 12:39

Ich hab jetzt alles deinstalliert. <<-- Super, somit gehen wir davon aus das dein system erstmal keinerlei Webserver am laufen hat.
Falls der Interne IIS (Webserver von Microsoft) an ist, so wird das nachher der XAMPP mit einer Fehlermeldung quitieren.

Und soll nun einfach Xampp neu installieren? << -- Ja, denn jetzt kommen wir zu unserem Konsens ;)

Brauche nichts seperates,vorinstalliertes? <<-- Nein, denn das XAMPP Paket enthält alles was man für einen Webserver braucht.

Ich probiers aus,deinstallieren kann man ja immenroch! =) <<-- Das nenn ich mal eine Positive einschätzung der ganze Sache ;)

Hoffe es klappt ansonsten meld ich mich nochmal, <<-- Will ich doch schwer hoffen das nun soweit alles klappt und wenn nicht sind ich (wir) gerne bereit zu helfen.
Wenn Fehler auftauchen, bitte die Fehlermeldung hier mitteilen, denn damit kann man erst herausfinden was los sein könnte.

Als zusatz Tipp noch eine Kurzanleitung, wenn XAMPP über den XAMPP-Conroll nicht starten sollte.
http://community.apachefriends.org/f/viewtopi ... 1022#51022
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests