wampp2 und passthru, exec, system

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

wampp2 und passthru, exec, system

Postby bionaut » 05. June 2003 08:23

Hallo ihr alle,

ich habe mir mit wampp2 mehere Apache Instanzen eingerichten (Admin, KnowHow, Apache2) und mir eine Seite gebastelt mit der ich die Instanzen verwalten kann. Start, Stop, Service-(Un)Install, Restart.

Das lief bis jetzt unter wampp1 auch wunderbar. Gar kein Prob enfach per PHP ein:

Code: Select all
echo "<pre>";
$command = '/wampp1/apache/apache -n "KnowHow-Apache" -k restart';
echo $command."<br>";
passthru($command; $returnval);
print("Returncode: $returnval <br>");
echo "</pre>";


zu machen und schon war die Instanz restartet.
Nun bin ich umgezogen auf wampp2.1. Hab die Skripte ein wenig angepasst, da die Apache.exe ja jetzt unter /wampp2/apache/bin/apache.exe zu finden ist aber leider laufen die Skripte nicht. An der DOSe kann ich wunderbar mit

Code: Select all
apache -n KnowHow-Apache -k restart


die Instanz neu starten aber nicht mehr mit meinem PHP Skript.

Liegt das Prob jetzt am Apache2 oder an PHP oder daran, dass es draussen viel zu warm ist ??? Meines Wissens stehen die Sterne momentan nicht so unguenstig dafuer :)

Vielleicht kann mir ja jemand helfen. Vielleicht habe ich ja nur vergessen irgendwo etwas anzupassen, vielleicht geht es auch einfach nicht. Ist dann auch OK, dann steig ich wieder um auf wampp1.

Danke fuer jede Hilfe
Gruesse
bio*
Blutwurst sagt: komm Leberwurst !
User avatar
bionaut
 
Posts: 20
Joined: 17. April 2003 06:31

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests

cron