Upload Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Upload Problem

Postby sabato » 12. August 2005 23:06

Moin Moin,

habe nen kleines Problem mit dem Upload.
Also ich habe Xampp neueste Version, alles läuft auf einem Windows Server. Ich habe als Blog den Serendipidy (www.s9y.org) installiert. Als Gallery habe ich 4images. Beides beherbergt eine Uploadfunktionalität zum uploaden von Mediendateien.

Nun kommen wir zu meinem/en Problem/en:
Keine Uploadfunktionalität funktioniert !
Ich habe mir bereits selber ein Php Upload gebastelt. Hier mit kann ich zumindestens *.txt hochladen. Sobald ich versuche irgendwas anderes hochzuladen, läd er bis ins unendliche und gibt leider keinen Fehler aus.

Diese Fehler treten allerdings immer nur dann auf, wenn ich das ganze vom Internet versuche. Sobald ich mich innerhalb des Netzwerkes befinde in dem sich auch der Xampp server befindet, funktioniert jeder Upload.

Ich gehe davon aus, dass es eine Einstellung mit den Zugriffsrechten ist. Allerdings ahbe ich unter dem win2k Server soweit jedem user erst einmal das rech gegeben datein hinzuzufügen, bzw. zu bearbeiten. Sollte also im Grunde gehen.

Hat einer ne Idee woran es liegen kann ? ich habe die php.ini auch schon soweit eingestellt, dass ich größere Dateien und so hochladen kann.

Was mich verwundert, ist das es vom lokalen Netz aus geht, aber nicht vom Internet.

Danke für Eure Mühe

Grüße
sabato
sabato
 
Posts: 1
Joined: 12. August 2005 22:35

Postby nattl » 26. October 2005 08:54

hallo,

ich hatte das gleiche problem nur unter linux. im intranet hat alles super funktioniert, sobald ein request von draussen kam, ging nix mehr. ich glaub' ich hab dann aber trotzdem eine lösung gefunden:

ein verzeichnis für temporäre dateien anlegen z.b. tmp und den apache-user (nobody) darauf berechtigen. dann in der php.ini den wer 'upload_tmp_dir' auf genau dieses verzeichnis richten. seitdem gehts problemlos, auch große dateien... ich schätze mal, dass das problem unter windows ähnlich gelagert ist...
User avatar
nattl
 
Posts: 22
Joined: 26. October 2005 07:50
Location: Vienna

Postby deepsurfer » 26. October 2005 11:37

dann in der php.ini den wer 'upload_tmp_dir' auf genau dieses verzeichnis richten. seitdem gehts problemlos, auch große dateien... ich schätze mal, dass das problem unter windows ähnlich gelagert ist...


hhmm.... hat die WindowsXAMPP auch
ca. zeile 497 upload_tmp_dir = "\xampp\tmp"

@sabato
trag mal dort den genauen Pfad ein z.b.
upload_tmp_dir = "c:\apachefriends\xampp\tmp"
sofern du diese Verzeichnisstruktur hast, ansonsten deine Pfade eintragen.

testen und melden ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Auch Upload Problem

Postby airchanjo » 05. November 2005 10:22

Hallo erstmal,

Ich beschäftige mich zwar schon eine Weile mit Xampp, aber hier im Forum bin ich neu.

Jetzt zu meinem Problem.
Ich habe ein php script, mit dem man Dateien hochladen, in die Datenbank eintragen und auch sofort zum Download zur Verfügung stellt.

Ich hatte bis jetzt noch nie Probleme irgendwas hochzuladen. Aber da waren es nur kleine Dateien. Bei größeren wird nach ca. 4-5 Minuten die Übertragung abgebrochen und "Die Seite kann nicht angezeigt werden" erscheint.

Der tmp Pfad in der php.ini ist der volle Pfad und stimmt. Gibt es irgendwann einen Verbindungsabbruch wegen Zeitüberschreitung? Und wo stelle ich das in der ini ein?

Danke im Vorraus, airchanjo
airchanjo
 
Posts: 5
Joined: 05. November 2005 09:27
Location: Berlin


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests