php.exe

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

php.exe

Postby Olaf » 28. December 2002 17:44

Hallo !

Leider habe ich ein klitze kleines Problem, welches mich noch umbringt.
Ich verwende den wampp2c und WinXP Pro.
Jedesmal, wenn ich nen kleinen Bug etc. in PHP programmiert habe, werden im Taskmanager zigtausende php.exe aufgerufen/angezeit.
Auf meinem Linuxserver (der leider immer noch checkdisk macht) funktionieren die Scripts aber, ohne, dass das System gleich zusammenbricht.

Kann mir jemand helfen??

Danke + Gruss
Olaf
Olaf
 
Posts: 32
Joined: 27. December 2002 11:15

Postby deep » 04. January 2003 10:04

das hatte ich unter win98 auch mal gehabt (lag scheinbar auch am php 4.21 selbst), da hatte ich mal 13 am stück gehabt !! - welche distri benutzt du genau? die aktuelle 'wampp 0.2.4c' ??

meine frage (weil ich auch noch nicht wusste, woran es genau lag):
Könnte es vielleicht an dem undefinierten path-standard liegen oder am windows-IE selbst, dass mit einem neuen browserfenster jeweils auch eine neu aufgerufene php.exe im systray geöffnet wird??
Denn: seit Mozilla 1 oder Opera6 (Teilfenster = keine extra-applikation, wie beim IE) hab ich das problem auch bei ner älteren distri nicht mehr gehabt...

php.ini-code / Paths and Directories:

...

; Windows: "\path1;\path2"
include_path=
...


ne aufklärung wäre nett :-)

gruss
deep
User avatar
deep
 
Posts: 23
Joined: 03. January 2003 16:14
Location: Cologne

re

Postby Olaf » 04. January 2003 10:15

Hi,

danke für die Antwort.
Habe aber nun nen LinuxServer auf den ich den LAMPP laufen lasse.
Somit muss ich mich nicht mehr mit lästigen Fehlern herumschlagen und übe nebenbei noch ein wenig Linux. :D

Gruss
Olaf
Olaf
 
Posts: 32
Joined: 27. December 2002 11:15

Postby Twix3k » 04. January 2003 12:58

Ich glaube eher, dass das daran liegt, dass der Apache2 alles in einem eigenen Prozess durchführt und somit seine Preformance massiv steigert :)
I see the sadness in their eyes, melancholy in their cries
Devoid of all the passion, the human spirit cannot die
Look at the pain around me, this is what I cry for
Look at the pain around me, this is what I'll die for
User avatar
Twix3k
 
Posts: 120
Joined: 29. December 2002 15:48

Postby deep » 04. January 2003 13:58

der apache1.3.26 machte aber auch viele-viele php.exen, also denke ich mal, liegt es wohl scheinbar irgendwo am win-BS...

gruss
deep
User avatar
deep
 
Posts: 23
Joined: 03. January 2003 16:14
Location: Cologne

Postby xbs » 04. January 2003 23:51

der apache1.3.26 machte aber auch viele-viele php.exen, also denke ich mal, liegt es wohl scheinbar irgendwo am win-BS...


hehe.. sicher nich...
beim apache 1.3 läuft PHP als SAPI und somit werden die php4ts.dll und php4isapi.dll genutzt und ebend NICHT die php.exe darum ist der pfad im
übrigen in der httpd.conf auskommentiert...
#Action application/x-httpd-php "/php/php.exe"
xbs
 
Posts: 44
Joined: 04. January 2003 23:08

Postby deep » 06. January 2003 07:05

stimmt, die php4ts.dll und php4isapi.dll musste man auch bei eigenen Konfigurationen in den systemordenr kopieren ! bei der wampp13cs ist es bereits gelöst und so eingebunden...

--
ScriptAlias /php/ "/wampp13cs/php/"

AddType application/x-httpd-php .php .php4 .php3
Action application/x-httpd-php "/php/php.exe"
---


...aber wenn es selbst zusammengestrickt ist / war, sah es so aus dass die php.exe im CGI-verzeichnis bei mir eingebunden werden musste:

---
ScriptAlias /cgi-bin/ "D:/apache/Apache/cgi-bin/"

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

Action application/x-httpd-php "/cgi-bin/php.exe"
---

die konfig ist somit eigentlich identisch... - aber warum es dabei zu dieser "sagenhaften vermehrung" der php´s kam, bleibt mir weiter ein rätsel - anyway: wenden wir uns wieder der zukunft zu ;-)


gruss
deep
User avatar
deep
 
Posts: 23
Joined: 03. January 2003 16:14
Location: Cologne


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests