Es wird einfach kein PHP wiedergegeben?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Es wird einfach kein PHP wiedergegeben?

Postby funnyfrosch » 03. August 2005 16:43

Hallo, ich habe winXP-Home mit SP2 und das Thema PHP ist neu für mich!
Um PHP zu lernen und lokal zu testen hab ich mir euer xampp mit dem Installer installiert, funktioniert sehr gut, bis auf das mir keine PHP Seiten angezeigt werden bzw. nur der eingegebene Text.
Ich glaube ich habe dieses Forum letzte Nacht durchstudiert, habe aber keine Lösung gefunden.
Natürlich rufe ich direkt über dem Broser die Seiten mit http://localhost/xxx/xxx.php auf.
In der Anleitung steht das xampp sich nicht selbst im System registriert, heißt das das ich selbst irgendetwas per Hand installieren muss?
Vermutlich ist es ein simpler anfängerfehler meinerseits, ich bitte das zu entschuldigen!

Andreas
funnyfrosch
 
Posts: 11
Joined: 03. August 2005 16:26
Location: Hannover

Postby deepsurfer » 03. August 2005 17:29

Nachdem du den XAMPP gestartet hast, erscheint bei eingabe http://localhost
der Willkommenscreen von XAMPP ?

- Funktionieren, die im Willkommenscreen von XAMPP, hinterlegten LINKs einwandfrei ?


XAMPP FAQ Hinweis
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby funnyfrosch » 03. August 2005 17:52

Ja, der willkommensbildschirm usw gehen alle, auch die Beispieldskripte funktionieren einwandfrei.
Nur selbstgeschriebene Skripte gehen nicht.
funnyfrosch
 
Posts: 11
Joined: 03. August 2005 16:26
Location: Hannover

Postby funnyfrosch » 03. August 2005 18:45

Hab den Fehler gefunden, danke!
funnyfrosch
 
Posts: 11
Joined: 03. August 2005 16:26
Location: Hannover

Postby deepsurfer » 03. August 2005 18:50

funnyfrosch wrote:Hab den Fehler gefunden, danke!

Was für ein Fehler lag denn vor?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby funnyfrosch » 03. August 2005 19:24

Irgendwie habe ich die PHP-Skripte mit dem Win-Editor geschrieben und dann einfach mit xxx.php abgespeichert.
Na reichlich dämlich, aber normalerweise kann man das doch mit dem Win-Editor machen? oder muß ich das dann anders abspeichern?
funnyfrosch
 
Posts: 11
Joined: 03. August 2005 16:26
Location: Hannover

Postby deepsurfer » 03. August 2005 19:32

Du meinst den "notepad"....

Besorg dir lieber einen PHPeditor (gibt es auch als Freeware)

hhmmm, ansonsten mein ich das der DOSeditor auch UNICODE abspeichert.
(Wiedmann !?!)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby funnyfrosch » 03. August 2005 19:54

Ich hab jetzt nicht weiter ausprobiert, aber ich habe mir den PSPad heruntergeladen, gefällt mir ganz gut. Welchen benutzt ihr denn hier so?
Ach bevor ich vergesse, hab zwar meinen Fehler selbst gefunden aber trotzdem herzlichsten Dank für die schnellen Hilfsangebote!!!
funnyfrosch
 
Posts: 11
Joined: 03. August 2005 16:26
Location: Hannover

PHP Probleme

Postby K2000 » 16. August 2005 09:07

Auch ich habe ein Problem mit PHP.
Habe ein mit Swish erstelltes Mailformular, kann aber die mail nicht senden.
Ich weiss nicht genau ob es an Xampp oder Swish liegt.
Wenn ich die PHP direkt im Browser (Firefox) wie folgt eingebe:
http//:localhost/mailtest/mail.php
erhalte ich folgende Meldung:

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in L:\xampp\htdocs\mailTest\mailform1_script.php on line 48

Was soll das heissen?
line 48: mail($rec_email, $subject, $msg_body, $header_info);

Für Hilfe bin ich sehr dankbar. :x :lol:
K2000
 
Posts: 1
Joined: 16. August 2005 08:51
Location: Schweiz

Postby the-piep » 16. August 2005 09:14

Das Problem liegt weder an Xampp noch dem Formular - du musst einen Mailserver auf deinem Rechner installieren.

der Mailserver Mercury Mail ist bei Xampp dabei, den muss man dann starten und konfigurieren - kann sein, dass man auch etwas in der php-konfigurationsdatei einstellen muss (httpd.conf)
User avatar
the-piep
 
Posts: 19
Joined: 18. February 2005 14:08
Location: Erde

Postby deepsurfer » 16. August 2005 11:20

@the-piep

kann es sein das du da etwas verwechselst ??
kann sein, dass man auch etwas in der php-konfigurationsdatei einstellen muss (httpd.conf)


php-konfigurationsdatei = php.ini
apache-konfigurationsdatei = httpd.conf
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby the-piep » 16. August 2005 12:40

öhm, ja - aber ich glaube es würde k2000 mehr helfen, wenn man ihm sagt was er eintragen muss, damit das mit dem verschicken von mails funzt - ich hab da nämlich auch keine ahnung :wink:
User avatar
the-piep
 
Posts: 19
Joined: 18. February 2005 14:08
Location: Erde

Postby deepsurfer » 16. August 2005 13:08

hi hoooo,

the-piep wrote:öhm, ja - aber ich glaube es würde k2000 mehr helfen, wenn man ihm sagt was er eintragen muss, damit das mit dem verschicken von mails funzt - ich hab da nämlich auch keine ahnung :wink:


Wäre kein Problem , wenn es nicht schon hier im Forum zigfach gefragt und durchaus Lösungswege bestehen.

Du hast mit deinem Hinweis "Mercury Mail" eigentlich schon den Hinweis gegeben was man in der Suchfunktion dieses Forum eintragen könnte.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests