Der phpmyadmin User pma

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Der phpmyadmin User pma

Postby dAk0Ta » 28. July 2005 18:35

Hallo Liebe leute.
Ich habe ein komisches problem:
Also ich installiere xampp usw es klappt ja auch alles so wie es sein muss, auch dem User root bei mysql habe ich ein Passwort gesetzt alles klappt. Eigene User mit Passwort kann ich auch hinzufügen. Also müsste es ja soweit sicher sein. Doch nun zum Problem es ist ja automatisch nach der xampp Installation der User pma mit in der mysql UserDB und da ist auch kein PW vor doch setze ich dort ein Passwort habe ich absolut keine Kontrolle über meine Datenbanken mehr mit keinem User kann ich mich einloggen, geschweige denn neue User hinzufügen ich komme einfach nicht mehr an die DB. Auch wenn ich den User pma lösche habe ich keinen Zugriff auf meine DB. Aber dabei ist das doch eine riesen Sicherheitslücke wenn der pma User ohne PW da ist, da kann ich ja dann den User root auch ohne PW lassen. Was muss ich machen damit ich entweder den user pma löschen kann oder wenigstens ein Passwort vorsetzen kann damit nicht jeder zugriff hat. Vielen Dank im Voraus...
dAk0Ta
 
Posts: 3
Joined: 28. July 2005 18:22

Postby deepsurfer » 28. July 2005 19:30

die config.inc.php von phpmyadmin editieren und in der section des PMA das passwort eintragen das du genommen hast... (eigentlich logisch, oder ?)


oder das:
http://community.apachefriends.org/f/viewtopi ... t=user+pma
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby dAk0Ta » 28. July 2005 19:44

Ja das ist richtig. Aber ich habe auch schon die config Editiert mit dem PW was ich wollte doch ich konnte mich ja dann nichtmehr anmelden weder mit pma noch mit root noch mit irgendeinem anderen User das ist ja das Problem... :(
dAk0Ta
 
Posts: 3
Joined: 28. July 2005 18:22

Postby dAk0Ta » 28. July 2005 22:00

So oki habs geschaft, nun hat der User pma auch ein Passwort.
Unzwar habe ich genau die gleiche Methode genommen wie ich das root Passwort gesetzt habe. Also ich bin nach der FAQ Methode 0 gegangen...
trotzdem danke für die Hilfe... mfG
dAk0Ta
 
Posts: 3
Joined: 28. July 2005 18:22


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests