PHP läuft nicht im Safe Mode

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP läuft nicht im Safe Mode

Postby Catja » 19. July 2005 13:04

:oops: :?: Hallo,
bin leider ein blutiger Anfänger und verstehe - nix!
Habe heute meinen eigenen Apache Server installiert.
Benutze Windows XP Home Edition.
Jetzt versuche ich seit Stunden verzweifelt, eine PHP Testdatei
auf dem Server hochzuladen.
Bitte nicht lachen - was geht das mit dem hochladen ?
Außerdem habe ich festgestellt, dass mein PHP nicht im safe-mode läuft.
Wie kann ich es safe machen ?
Ich bin soweit gekommen, dass ich die Datei config.inc.php unter
PHPMyAdmin mit dem Editor geöffnet habe. Wie aber geht es nun weiter?

Der Hintergrund ist, dass ich über Dreamweaver ein Kontaktformular und
ein Bestellformular erstellen möchte (ob ich es hinkriege, weiss ich wirklich nicht, wenn ich schon an den elementarsten Dingen scheitere.)

Für jede Hilfe bin ich unendlich dankbar!
Catja - mal wieder völlig ahnungslos!
Catja
 
Posts: 4
Joined: 19. July 2005 12:46
Location: Hamburg

Postby deepsurfer » 19. July 2005 13:14

Der Hintergrund ist, dass ich über Dreamweaver ein Kontaktformular und
ein Bestellformular erstellen möchte (ob ich es hinkriege, weiss ich wirklich nicht, wenn ich schon an den elementarsten Dingen scheitere.)


Folglich erstmal die elementarsten Dinge anlernen :)


Ok.. zum safe_mode, dieser wird in der php.ini an oder abgeschaltet.
standartmässig ist dieser bei xampp abgeschaltet.

den genauen pfad zum benutzen php.ini siehst du wenn du phpinfo im xampp aufrufst.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby rift » 19. July 2005 15:28

Die php.ini wirst du wahrscheinlich in folgendem Verzeichnis finden, wenn du xampp ganz standardmäßig installiert hast.

c:\apachefriends\xampp\apache\bin\php.ini

Öffne die Datei mit einem Texteditor und suche nach "safe". Das erste Ergebnis (bei mir Zeile 165) ist der Anfang der Safe Mode Konfiguration.

In Zeile 167 siehst du folgendes stehen:

Code: Select all
safe_mode = Off


Daraus machst du:

Code: Select all
safe_mode = on


Was der Safe Mode bewirkt und was die anderen Einstellungen bewirken kannst du hier nachlesen:

http://de3.php.net/features.safe-mode
User avatar
rift
 
Posts: 26
Joined: 19. July 2005 10:32
Location: Hamburg

Postby Catja » 19. July 2005 17:45

:oops:
Danke Euch beiden für die Antworten.
Habe das jetzt auch so gemacht, aber beim Sicherheitscheck erhalte ich nach wie vor den Hinweis PHP läuft nicht im Safe Mode.
Neustart habe ich auch schon ausgeführt. Ohne Erfolg.
Warum ist das nur so verdammt schwer ?
Catja - mal wieder völlig ahnungslos!
Catja
 
Posts: 4
Joined: 19. July 2005 12:46
Location: Hamburg

Postby deepsurfer » 19. July 2005 17:48

hast du denn auch die richtige php.ini genommen (pfad hat ja rift genannt) ?

Ich frage deshalb, weil die php.ini mehrmals vorkommt und wenn du nicht die im richtigen Pfad nimmst, so ist der status richtig.

Teste aber zusätzlich ob phpinfo() dir auch den safe_mode off anzeigt oder richtigerweise safe_mode on
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Catja » 19. July 2005 18:02

:cry: nein, unter dem Pfad (c:\apachefriends\xampp\apache\bin)
ist bei mir kein php-ini.
Ich habe unter dem Pfad (c:\apachefriends\xampp\php\php4) 2 Dateien gefunden: php INI-DIST Datei und php INI-Recommended-Datei
in beiden Dateien habe ich Safe Mode von off in on geändert.
Catja - mal wieder völlig ahnungslos!
Catja
 
Posts: 4
Joined: 19. July 2005 12:46
Location: Hamburg

Postby Catja » 19. July 2005 18:04

Ach so - und unter php-info steht gar nichts von Safe-Mode
Catja - mal wieder völlig ahnungslos!
Catja
 
Posts: 4
Joined: 19. July 2005 12:46
Location: Hamburg

Postby Wiedmann » 19. July 2005 18:07

nein, unter dem Pfad (c:\apachefriends\xampp\apache\bin)
ist bei mir kein php-ini.

Wie schon mehrmals geschreiben wurde, nennt sich die Datei php.ini und ist dort bei jedem XAMPP zu finden.

Ich habe unter dem Pfad (c:\apachefriends\xampp\php\php4) 2 Dateien gefunden: php INI-DIST Datei und php INI-Recommended-Datei
in beiden Dateien habe ich Safe Mode von off in on geändert.

Was du in anderen Dateien änderst ist uninteressant.

BTW würde es auch noch jeweils eine "php.ini" geben in:
"c:\apachefriends\xampp\php"
und
"c:\apachefriends\xampp\php\php4"
die aber nur für's CLI interessant sind.

Ach so - und unter php-info steht gar nichts von Safe-Mode

Dann schau dir diese Seite genauer an...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rift » 20. July 2005 07:55

Catja wrote::cry: nein, unter dem Pfad (c:\apachefriends\xampp\apache\bin)
ist bei mir kein php-ini.


Könnte es vielleicht sein, dass dein System ini-Dateien versteckt bzw. nicht anzeigt? Überprüfe das mal.

Catja wrote:Ich habe unter dem Pfad (c:\apachefriends\xampp\php\php4) 2 Dateien gefunden: php INI-DIST Datei und php INI-Recommended-Datei
in beiden Dateien habe ich Safe Mode von off in on geändert.


Diese beiden Dateien solltest du nicht ändern.

Die Datei php.ini-dist ist eine Ini-Version für den entwicklerischen ABER NICHT produktiven Einsatz. Mache die Änderung dort wieder Rückgängig.

Die Datei php.ini-recommended ist eine Ini-Version mit mehr Sicherheit, schränkt aber auch die Möglichkeiten beim programmieren ein. Warum dort aber der Safe-Mode = off ist, darüber läßt sich streiten und gehört nicht hierher :). Ergo: Auch hier die Änderung rückgängig machen.

Achja: Ich vermute mal dass dein wirklich System wirklich Ini-Dateien versteckt, da du nur diese beiden Ini-Dateien gefunden hast, die aber in Wirklichkeit keine Ini-Dateien sind, da ihre Dateiendung ini-dist und ini-recommended lautet. Deswegen zeigt dein System diese beiden auch an.
Ein Blick empor zum Lichte, ein Vorwärts nur und kein Zurück.
User avatar
rift
 
Posts: 26
Joined: 19. July 2005 10:32
Location: Hamburg


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests