SSI: include virtual: php-Script bekommt Parameter nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

SSI: include virtual: php-Script bekommt Parameter nicht

Postby GordonG » 10. July 2005 15:46

Hallo zusammen,

ich nutze seit einiger Zeit XAMPP für Windows Version 1.3, funktioniert weitestgehend wunderbar. :)

Nun möchte ich bei einer neuen Website, die ich mit Xampp entwickle, über "include virtual" ein .php-Script in eine .htm-Seite einbinden. Ich habe Xampp bereits so konfiguriert, daß neben .shtml auch .htm-Seiten "geparst" werden.

Die Ausgabe des Scripts wird auch angezeigt, aber wenn ich Parameter mit übergebe bspw. so:

Code: Select all
<!--#include virtual="./templates/template_content.php?modell=weiss" -->


... wird der Parameter vom Script nicht erkannt. $modell ist leer, ebenso $_GET['modell'].

Rufe ich das .php-Script aber direkt mit dem Parameter auf (nicht über "include virtual" in einer .htm-Seite), erkennt das Script die Variable völlig normal.

Da ich vermute, daß das an der Konfiguration meines Xampp-Servers liegt, habe ich die beteiligten Dateien schon einmal testweise auf den späteren Online-Server bei alturo hochgeladen. Und siehe da, dort geht die Parameter-Übergabe wie gewünscht mit "include virtual".


Kann mir bitte jemand auf die Sprünge helfen, was ich bei der Xampp-Konfiguration ändern/zufügen muß, damit das auch lokal mit Xampp geht? (Oder ist das möglicherweise ein Fehler von Xampp - ich nutze Xampp für Windows Version 1.3)


TIA!
GordonG
 
Posts: 5
Joined: 10. July 2005 15:15

Postby deepsurfer » 10. July 2005 16:50

welche PHP Version benutzt alturo ?, ist diese die selbe wie du sie beim xampp 1.3 hast ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby GordonG » 10. July 2005 18:17

deepsurfer wrote:welche PHP Version benutzt alturo ?, ist diese die selbe wie du sie beim xampp 1.3 hast ?


Eben mal nachgesehen - alturo hat 4.3.10 laufen, mein Xampp 4.3.4.

Meinst Du nicht, daß es eine Konfigurationssache ist (htaccess oder php.ini) ? (Weil, dies "include virtual" ist doch eher ne Standardsache!?)
GordonG
 
Posts: 5
Joined: 10. July 2005 15:15

Postby GordonG » 16. September 2005 22:57

Ein Upgrade auf eine modernere Xampp-Version hat das Problem gelöst.
GordonG
 
Posts: 5
Joined: 10. July 2005 15:15


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests