XAMPP 1.4.14 -Absturz

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP 1.4.14 -Absturz

Postby Gerhard Merz » 05. July 2005 04:31

Hallo

Ich habe XAMPP 1.4.14 unter win2000SP4 installiert und folgendes Problem:
Wenn ich mich mit http://localhost eingeloggt habe, und z.B. phpinfo oder phpmyadmin aufrufe, kommt sofort eine Fehlermeldung, daß Apache.exe einen Fehler verursacht hat und neu gestartet wird.
Ich benutze keines der im Forum angeführten Programme, die Probleme verursachen könnten.
Ich gehe auf diesem Rechner mit der Fritzcard-DSL ins Internet.
Im Ereignisprotokoll gibt es keine entsprechende Meldung.

So, und jetzt noch eine Erfolgsmeldung:
Wenn ich mich mit https://localhost eingeloggt habe, läuft alles einwandfrei.

Weiß jemand Rat zu diesem Problem ?

Danke und Gruß
Gerhard Merz
Gerhard Merz
 
Posts: 7
Joined: 05. July 2005 04:13
Location: Frankfurt / Main

Postby Wiedmann » 05. July 2005 07:14

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

XAMPP 1.4.14 -Absturz

Postby Gerhard Merz » 05. July 2005 09:32

Hallo

Danke für die Mitteilung.
Den AVM-Webprotect hatte ich schon vorher deaktiviert ohne das sich eine Besserung eingestellt hätte. Und eine Deinstallation der AVM-Software, die ja das Problem lösen soll, kommt deshalb nicht in Frage, weil ich ja sonst mit diesem Rechner nicht mehr ins Internet komme.
Ich werde mich also mit AVM in Verbindung setzen, und wenn ich ein Ergebnis habe, hier im Forum veröffentlichen.

Danke und Gruß
G.Merz
Gerhard Merz
 
Posts: 7
Joined: 05. July 2005 04:13
Location: Frankfurt / Main

Postby Wiedmann » 05. July 2005 11:17

Wer will denn schon ins Internet *g*

Aber nochmal zu deinem Problem. Diese Datei scheint ja ein LSP zu sein. In diesem Fall könnte es auch helfen folgende Zeile in die "httpd.conf" mit aufzunehmen:
Code: Select all
Win32DisableAcceptEx
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

XAMPP 1.4.14 -Absturz

Postby Gerhard Merz » 05. July 2005 11:36

Hallo

Win32DisableAcceptEx hatte ich auch schon getestet - ohne Erfolg.

Danke und Gruß
G.Merz
Gerhard Merz
 
Posts: 7
Joined: 05. July 2005 04:13
Location: Frankfurt / Main

Postby Wiedmann » 05. July 2005 11:43

Tja. Dann weis ich auch nichts mehr.

Hmm, evtl. könntest du den Apache ja mal nur an deine interne Netzwerkkarte binden?

BTW:
zuwas braucht man denn die AVM-Software um ins Internet zu kommen, ging doch früher auch ohne?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

XAMPP 1.4.14 -Absturz

Postby Gerhard Merz » 05. July 2005 12:05

Hallo

>Hmm, evtl. könntest du den Apache ja mal nur an deine interne Netzwerkkarte binden?
Tja, dann funktioniert es natürlich. Die Datei Sarah.DLL ist, wie bereits an anderer Stelle beschrieben, der Auslöser des Crashes.

>zuwas braucht man denn die AVM-Software um ins Internet zu kommen, ging doch früher auch ohne?
Die AVM-Software ist nötig, um die Kombikarte DSL + ISDN zu betreiben. Alles sehr proprietär, halt AVM.

Ich habe schon den Support von AVM kontaktiert, und melde mich wieder.

Gruß
G.Merz
Gerhard Merz
 
Posts: 7
Joined: 05. July 2005 04:13
Location: Frankfurt / Main

Postby Wiedmann » 05. July 2005 12:14

Tja, dann funktioniert es natürlich. Die Datei Sarah.DLL ist, wie bereits an anderer Stelle beschrieben, der Auslöser des Crashes.

Wenn das dann tut, würde dir das nicht langen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Gerhard Merz » 05. July 2005 12:38

Ich habs zwar nicht ausprobiert, aber ich vermute mal, dass dann Dyndns nicht mehr funktioniert, weil die Fritz-DSL-Card ja eine Netzwerkkarte emuliert und das Routing nicht funktioniert. (Sarah.DLL)
Wenn AVM keine Lösung zu bieten hat, werde ich aber selber mal handgreiflich ;-)

Danke und Gruß
G.Merz
Gerhard Merz
 
Posts: 7
Joined: 05. July 2005 04:13
Location: Frankfurt / Main

Postby Wiedmann » 05. July 2005 12:46

Naja, der Apache hat ja mit DynDNS nichts zu tun, oder hast du mit DynDNS auch Probleme?

Allerdings wäre dann der Apache aus dem Internet nicht mehr erreichbar (du weist, das der XAMPP eine lokale Entwicklungsumgebung ist?).

Da du aber Routing ansprichst:
Sollte diese Software tatsächlich einen NAT-Router beinhalten (oder das benutzen des Win-Routers zulassen), bräuchtest du ja nur ein Mapping von Port 80 auf die interne IP einrichten, damit er wieder aus dem Internet erreichbar ist.

BTW:
Wenn man was nicht getestet hat, kann man doch schlecht sagen das es dann natürlich funktioniert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Hasse » 07. July 2005 17:24

Moins,

ich hatte das gleiche Problem. Nachdem ich in FRITZ!webprotect unter Einstellungen das Häckchen aus "Fritz!webprotect-Schutz aktivieren" entfernt habe, läuft der Apache ohne Probleme und stürzt beim Aufruf von phpinfo() und dem phpmyadmin nicht mehr ab.

Hasse
Hasse
 
Posts: 7
Joined: 07. July 2005 14:44

Postby Gerhard Merz » 11. July 2005 06:46

Danke, das hilft fürs erste.
Gerhard Merz
 
Posts: 7
Joined: 05. July 2005 04:13
Location: Frankfurt / Main

Postby Gerhard Merz » 11. July 2005 06:48

Komischerweise aber nur das Deaktivieren. Das Programm garnicht erst starten zu lassen, hilft nicht.
Gerhard Merz
 
Posts: 7
Joined: 05. July 2005 04:13
Location: Frankfurt / Main

Postby Hasse » 11. July 2005 07:34

Irgendwie läßt das darauf schließen, dass webprotect im Hintergrund trotzdem lief.
Hasse
 
Posts: 7
Joined: 07. July 2005 14:44


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests