Problem mit einer Datei Namens - sarah.dll

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit einer Datei Namens - sarah.dll

Postby badbear » 20. June 2005 16:14

Zunächst einmal "Hallo" alle zusammen!
Bin neu hier im Forum und auch relativ neu in diesem Thema. Beginne gerade mit dem erlernen von PHP und habe zu diesem Zweck XAMPP 1.4.14 LITE auf meinem Rechner installiert.

Die Installation, wenn man das so überhaupt sagen kann und auch der Start verliefen einwandfrei. Statusabfrage = alles grün!

Beim anklicken von phpinfo, phpmyadmin oder auch der Beispieldatei "FlashArt" erhalte ich jedoch sofort bei Aufruf die gleiche Fehlermeldung:
Apache HTTP Server hat ein Problem festgestellt und muss beendet werden. AppName: apache.exe, AppVer: 2.0.54.0, ModName: sarah.dll, ModVer: 3.5.11.2001, Offset: 00003d02.
Trotzdem kann ich die Beispielanwendungen starten. phpmyadmin zeigt mir allerdings nur den linken Frame, ansonsten kann die Seite nicht angezeigt werden.

Wo könnte hier das Problem liegen?

System:
P4, 512 MB Ram, WinXP prof SP2

Schon im voraus besten Dank für jeden Tip.
best regards
Uwe alias badbear
von
badbear.de
User avatar
badbear
 
Posts: 5
Joined: 20. June 2005 15:45

Postby deepsurfer » 20. June 2005 19:37

Hoffe ich sag jetzt nichts falsches (schiele zu Wiedmann rüber)

Soweit ich weiss existiert keine sarah.dll im XAMPP.

wenn man im Google direkt nach sarah.dll sucht, wird man mit Trojaner warnungen überschüttet.
GOOGLE Ergebnisliste

Schau diesbezüglich mal nach ob nicht dein PC infiziert ist !?!?!?

Selbst ein suchen expliziet nach sarah.dll auf meinem PC hier ist ergebnislos verlaufen, habe hier noch die XAMPPlite 1.4.13 entpackt vorliegen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby quatkum » 20. June 2005 21:45

Habe das gleiche Problem !!!!!

Wer kann helfen ????

Habe die Version 1.4.14 Vollversion
quatkum
 
Posts: 1
Joined: 20. June 2005 21:42
Location: Duisburg

Postby badbear » 20. June 2005 22:08

So ... ich hatte zwar die :idea: aber es läuft trotzdem noch nicht :evil:

@deepsurfer
Es kommen zwar viele Meldungen mit Trojanerverdacht .... aber eher aus Unwissenheit.

Habe das System komplett gescannt ..... alles sauber!

Es handelt sich dabei um eine DLL von AVM. Gehe mit einem DSL-Router von AVM ins Netz. Die Datei befindet sich auch im AVM Verzeichnis. Irgendwie hat diese Datei mit dem Routing zu tun und stört primär wohl die Adressierung des Apachen (hört sich jetzt vielleicht ein wenig Laienhaft an ..... bin aber auch Laie ... was dies anbelangt) :wink:

Wenn ich die Datei umbenenne und xampp starten möchte erscheint folgende Meldung:
Der angeforderte Dienstanbieter konnte nicht geladen oder initialisiert werden.
: alloc-listener: failed to get a socket für 0.0.0.0
Syntax error on line 120 of x:xampplite/apache/conf/httpd.conf:
Listen setup failed
Can´t create IP socket: No error
050620 xx:xx:xx ERROR Aborting

Der Apache wird nicht gestartet, das Fenster schliesst sich.


Jetzt die Frage aller Fragen: Wie kann man dieses Problem lösen ... wer kennt sich aus?
best regards
Uwe alias badbear
von
badbear.de
User avatar
badbear
 
Posts: 5
Joined: 20. June 2005 15:45

Postby deepsurfer » 21. June 2005 15:08

Es handelt sich dabei um eine DLL von AVM. Gehe mit einem DSL-Router von AVM ins Netz.


hhmmm... Wenn ich richtig liege hast du für den Router die Adminsitrations-Software von AVM auf deinem PC Installiert, damit verbunden existiert nun die sarah.dll in dem AVM Verzeichniss oder im System32 Verzeichnis.

Ich würde jetzt mal hingehen und die AVM Software abschalten und auch aus der Autostartsequenz nehmen (Entweder unter START-->PROGRAMME-->Autostart oder in der Registry
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
den AVM startbefehl herausnehmen. (Kopie erstellen !!)

System neu starten und dann mal XAMPP starten, wenn nun der Apache funtkioniert liegt es an der AVM-Software.
Diesbezüglich auch mal bei AVM vorbeischauen, ob da nicht sogar schon ein Hinweis über diese sarah.dll vorliegt.

Gegebenenfalls bei AVM den Support-Connect benutzen (wenn es den noch gibt), dort waren damals immer Developer Hinweise untergebracht.

Ich sage hiermit bewusst, das ich es so testen würde. Denn ich gehe mal davon aus das du die Admin-Software von AVM nur zum Einstellen des Routers benötigt hattest ansonsten ist diese Soaftware für dich absolut sekundär auf dem PC Installiert.


ZUSATZ:
Der hiermit beschrieben Weg in die REGISTRY sollte nur durchgeführt werden wenn du weisst wie man damit umgeht. Für Spätfolgen die mit diesem Eingriff in der Registry verursacht werden bin ich keinefalls in Verantwortung zu ziehen !
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby badbear » 21. June 2005 19:54

Hi!

So, habe mit AVM telefoniert. Witzigerweise (oder auch nicht witzig) kannten die selbst ihre eigene Datei nicht!

Es gibt ja mehrere Möglichkeiten, die Fritz-Box anzuschließen: Als DSL-Modem per USB oder als Router (wie in meinem Fall) am LAN.
Bei der USB Variante muss die mitgelieferte Software installiert werden. Darauf kann man beim LAN Anschluss komplett verzichten.

Die Datei sarah.dll ist Bestandteil der AVM eigenen Firewall Webprotect. Da ich trotz LAN Anschluss kontrollieren wollte, welche Programme sich mit dem Internet verbinden, habe ich Webprotect mitinstalliert (wohlgemerkt - bei LAN Anschluss nicht erforderlich!)

Habe gerade die AVM Software komplett deinstalliert und siehe da - xampp funktioniert einwandfrei!

User, die mit USB arbeiten, werde also nach wie vor dieses Problem haben.

Der AVM Supporter hat mir jedoch gesagt, das diese Datei trotzdem keinen Fehler verursachen dürfte. Ich werde AVM mein Ergebnis morgen mitteilen.
best regards
Uwe alias badbear
von
badbear.de
User avatar
badbear
 
Posts: 5
Joined: 20. June 2005 15:45

Postby deepsurfer » 22. June 2005 14:16

Der AVM Supporter hat mir jedoch gesagt, das diese Datei trotzdem keinen Fehler verursachen dürfte. Ich werde AVM mein Ergebnis morgen mitteilen.


Jo, mach das... Wäre super wenn du die darauffolgende Antwort von AVM hier Auszugsweise Posten könntest. Die Thematik ist recht interessant.


@quatkum
Wie sieht es bei dir aus ?
Hast du die LAN oder USB Variante ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Fritz! Webprotect und XAMPP

Postby allgaeupit » 19. July 2006 08:52

@badbear:

Hast Du inzwischen Rückmeldung von AVM hierzu erhalten? Ich hatte nämlich bei mir unter XP Professional mit XAMPP 1.5.3a das gleiche Problem (Apache HTTP Server hat ein Problem festgestellt und muss beendet werden. - und dann in den Details der Verweis auf Sarah.dll ...).
Nach langem Suchen habe ich auch diesen Forenbeitrag gefunden und Fritz! Webprotect deaktiviert und aus dem Autostart herausgenommen. Dann den PC neu gestartet und schon funktioniert XAMPP beim Aufruf von PHP-Seiten wieder ohne Probleme.

Nun interessiert mich nur die Rückmeldung von AVM! Haben sich die Supporter schon gemeldet?
allgaeupit
 
Posts: 3
Joined: 19. July 2006 08:01

Postby JayKay » 15. September 2006 13:03

Hi allgaeupit,
...und merkst Du, mit und/oder ohne WebProtect, irgendeinen Unterschied?
Muss ich WebProtect denn zwingend notwendig haben?

Ich habe auch mal auf der AVM Site eine Suche nach 'sarah.dll' gestartet. Zu diesem Thema wird bei AVM nichts angeboten.

bye
JayKay
User avatar
JayKay
 
Posts: 4
Joined: 13. September 2006 06:39
Location: Mad Island

Postby allgaeupit » 17. September 2006 19:02

WebProtect muss meiner Meinung nach nicht zwingend aktiviert sein. Ist evtl. ein erweiterter Schutz. Aber wenn Du eine gute Firewall und ein gutes AntiViren-Programm (z.B. NOD32) hast, brauchst Du diesen Schutz nicht unbedingt. In der aktuellen Version von XAMPP 1.5.4 besteht das Problem nach wie vor. Mir fehlt die Zeit und Lust, dies mit AVM abzuklären. Daher lasse ich den WebProtect deaktiv. Evtl. kann ja apachefriends.org mal direkt auf AVM zugehen...
allgaeupit
 
Posts: 3
Joined: 19. July 2006 08:01

Postby th1alb » 29. October 2006 21:48

Ich schreibe hier über einen öffentlich account, weil ich echt keine bock habe mich hier für extra zu reggen: Selbst wenn man webprotect deaktiviert sollte das immer noch nicht die erhoffte Lösung bringen, das Problem liegt ein wenig tiefer ;) Die Sarah.dll klingt sich im winsock call stack ein um eingehende Pakete dort abzufangen. Die bis lang einzig wirklich verlässliche Methode das Problem los zu werden ist im Moment die Benutzung des Tools Winsock fix. Zumindest für nicht ganz so versierte Windows Benutzer. Das Tool kann hier bezogen werden: http://www.snapfiles.com/get/winsockxpfix.html

Erfahrenere Anweder werden vermutlich jetzt schon wissen, was ansonsten zu tun ist. Stichwort registry und netsh.

Viel Spaß damit
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Postby deepsurfer » 31. October 2006 11:03

Soweit sogut... ABER :D , dieses Problem ist ja von AVM ausgehend und da sollte eigentlich der Support (Programmierer) von AVM etwas dagegen machen, denn diese Art der Umleitungen von Winsock-Stacks ist eine Bevormundung seitens AVM was sicherlich nicht im Sinne des Nutzers ist.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mahadmaganja » 04. November 2006 15:15

Ich habe jetzt nicht alles gelesen, also nichts für ungut wenn ich jetzt was sage, was schon gesagt worden ist oder außgeschlossen wurde


Versuch mal

Spybot UND HijackThis

und wenn es um Registry sachen geht :

RegCleaner



Alles Freeware und über google oder chip.de downloadbar :-)
mahadmaganja
 
Posts: 16
Joined: 02. November 2006 14:43


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests