PHP-Skripte bei Apache - wohin

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP-Skripte bei Apache - wohin

Postby Tassi » 13. June 2005 22:07

Hallo zusammen,

habe auf meinen Rechner XAMPP installiert und möchte nun erste Erfahrungen mit PHP sammeln. Auf einer anderen Seite habe ich einige Bespielskripte entdeckt, mit welchen ich erst Erfahrungen sammeln möche. Diese Skripte gebe ich einen ganz normalen Texteditor ein und speicher sie zum Bespiel unter ....xampp/htdocs/test.php ab.
Wenn ich nun in meinem Browser localhost/test.php eingebe, erhalte ich nicht das erhoffte Ergebnis.
Welche Fehler mache ich? Aud der anderen Seite laß ich was von Editoren usw. - ist es verkehrt Skripte im normalen Texteditor zu erstellen und anschließend mit der Dateiendung php abzuspeichern?

Danke - Tassi
Tassi
 
Posts: 1
Joined: 13. June 2005 21:53

Postby Wiedmann » 14. June 2005 10:55

Diese Skripte gebe ich einen ganz normalen Texteditor ein und speicher sie zum Bespiel unter ....xampp/htdocs/test.php ab.
Wenn ich nun in meinem Browser localhost/test.php eingebe, erhalte ich nicht das erhoffte Ergebnis.

Sondern?

BTW:
Du bist sicher, dass sich diese Datei auf deiner Platte nicht "test.php.txt" nennt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Phate » 14. June 2005 15:06

wenn du nicht explizit in den Ordneroptionen die Option "verstecke dateiendungen bei bekannten Typen" o.ä. ausschaltest, kannst du sooft du willst an den Dateinamen test eine .php anhängen wie du willst, am Ende steht immernoch das .txt!

HTH
Phate
 
Posts: 6
Joined: 15. May 2005 16:42

Postby DJ DHG » 14. June 2005 15:45

Phate wrote:wenn du nicht explizit in den Ordneroptionen die Option "verstecke dateiendungen bei bekannten Typen" o.ä. ausschaltest, kannst du sooft du willst an den Dateinamen test eine .php anhängen wie du willst, am Ende steht immernoch das .txt!

HTH


Davon habe ich nocht nicht gehört bzw. kann ich mir nicht vorstellen
das es daran liegt.

Da von einem normalen Text-Editor die Rede ist, gehe ich davon aus,
dass notepad.exe gemeint ist.
Hier muss, beim Speichern unter, als "Alle Dateien" ausgewählt werden. Sonst kommt es halt zu foobar.php.txt.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Phate » 14. June 2005 16:43

doch, es ist so, aber deine Lösung könnte das umgehen!

hast du mal test.php.txt versucht?
Phate
 
Posts: 6
Joined: 15. May 2005 16:42

Postby DJ DHG » 14. June 2005 16:58

Phate wrote:doch, es ist so, aber deine Lösung könnte das umgehen!

hast du mal test.php.txt versucht?


Wenn als Textdatei gespeichert wird, wird immer .txt drangehängt.
Das soll gerade verhindert werden, mit als "Alle Dateien"!

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests