Problehme mit PHP (oder Apache?!?)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problehme mit PHP (oder Apache?!?)

Postby mastermary » 10. June 2005 21:07

Hy,
ich habe heute Apache (xampp-win32-1.4.13-installer) auf meinen PC installiert...
(will ich später auf meinen XP Server installieren, das tut aber jetzt nichts zur Sache)
Naja, soweit funzt alles. Die Kofigurationsseite von XMPP wurde auch richtig angezeigt. Nun habe ich einen Ordner erstellt, da noch einen Ordner und dann noch einen Ordner erstellt.... naja dorthin habe ich meine Webseite dann reinkopiert. Die html dateien werden auch korrekt angezeigt.

Allerdings erscheint, bei jeder meiner selbst erstellten php datei, folgende Fehlermeldung:

Warning: Unknown(D:\apachefriends\xampp\htdocs\Jamassoft Online Webpräsenz\modules\gaestebuch\index.php): failed to open stream: No such file or directory in Unknown on line 0

Warning: (null)(): Failed opening 'D:\apachefriends\xampp\htdocs\Jamassoft Online Webpräsenz\modules\gaestebuch\index.php' for inclusion (include_path='.;d:\apachefriends\xampp\php\pear\') in Unknown on line 0

Und das obwohl ich frisch Installier habe!!!
Zuerst dachte ich das währe ein fehler meinerseits... folgendes sind meine Problehme:

- bei einer leeren .php Datei zeigt der Server an ddas diese nicht exestiert
- bei einer mit html gefüllten .php Datei (ohne PHP!!) kommt der besagte PHP fehler
mastermary
 
Posts: 2
Joined: 10. June 2005 20:05

Postby mastermary » 10. June 2005 21:10

OKOK.... das hab ich jetzt dochnoch hinbekommen... im Ordner in der sich die php Dateien befanden hatte Umlaute in der Bezeichnung... jetzt wüste ich aber schon gerne, wiso PHP bei Umlauten nicht funktuioniert, aber der normale Apache schon..? PHP copiliert doch nur, oder?

Gut, diese Frage ist nicht lebenswichtig, es würde mich aber doch interresieren... PS: Kann man Apache und MySQL eigendlich auch auf Windows Server 2003 Installieren?
mastermary
 
Posts: 2
Joined: 10. June 2005 20:05

Postby Wiedmann » 10. June 2005 21:40

im Ordner in der sich die php Dateien befanden hatte Umlaute in der Bezeichnung... jetzt wüste ich aber schon gerne, wiso PHP bei Umlauten nicht funktuioniert, aber der normale Apache schon..?

Hm, der normale Apache verhällt sich da manchmal auch schon seltsam.

BTW:
Mit PHP als CGI funktioniert es, nur als Apachemodul geht es nicht.

PS: Kann man Apache und MySQL eigendlich auch auf Windows Server 2003 Installieren?

Yup. (auch wenn du da ja schon einen WebServer hast der unter Win wohl besser läuft als der Apache...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: wodim and 21 guests