Einbindung von Zusatzmodul scheitert

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Einbindung von Zusatzmodul scheitert

Postby baerli » 07. June 2005 14:25

Hallo,

ich habe die Installer-Version für Windows und das Addon Perl installiert.
Keine Probleme.

Jetzt habe ich unterhalb von Perl/lib/WWW noch das Modul Mechanize.pm eingefügt, und erhalte nach Aufruf "use WWW:Mechanize;" die Fehlermeldung:
Code: Select all
HTML::Parser object version 3.38 does not match bootstrap parameter 3.43 at C:/apachefriends/xampp/perl/lib/DynaLoader.pm line 253., ..failed in require at C:/apachefriends/xampp/perl/lib/HTML/Entities.pm line 136., ...failed in require at C:/apachefriends/xampp/perl/lib/HTML/TokeParser.pm line 11., ... failed C:/apachefriends/xampp/perl/lib/HTML/TokeParser.pm line 11., referer: http://localhost/form0.html
... failed in require at C:/apachefriends/xampp/perl/lib/WWW/Mechanize.pm line 101.


Ein Scan über /apachefriends nach "3.38" und "3.43" als Ausdruck in einer Datei bringt kein Ergebnis. Woher stammt die Meldung "object version 3.38 does not match bootstrap parameter 3.43". Ich habe es mit verschiedenen Versionen von WWW::Mechanize probiert ohne Erfolg. Es hat ohnehin keine eine dieser Versionsnummern.

Vielleicht kann mir jemand weiterhelfen. Letztes Jahr ging die Einbindung dieses Moduls in ActivePerl unter XITAMI problemlos.
Muss ich bei der Einbindung eines nicht in XAMPP + Perl-Addon enthaltenen Perl-Modules etwas in den Konfigurationsdateien ändern ?

Vielen Dank für Euere Hilfe
baerli
 
Posts: 6
Joined: 07. June 2005 11:58
Location: Stuttgart

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests