Apache im lokalen Netzwerk wird nicht gefunden - XP mit SP2

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache im lokalen Netzwerk wird nicht gefunden - XP mit SP2

Postby Riebensiel » 26. May 2005 22:56

Hi,

ich habe ein kleines serverbasiertes Netzwerk und habe auf einem Rechner mit XP und SP1 xampp 1.411 installiert, diese Server werden ohne Probs gefunden im Intranet und im Internet, sowohl http als auch ftp. Auf einem anderen Rechner mit XP und SP2 habe ich im Prinzip die gleiche Installation (nur Version 1.413) und sie wird nicht gefunden im lokalen Netzwerk. Auf dem SP2 Rechner kann ich den Server als localhost oder unter dem Rechnernamen ansprechen, der Server läuft richtig incl. MySQL, PHP, FTP und allem anderen, aber er wird im lokalen Netzwerk nicht gefunden. Ob dieser Server von außen gefunden wird, kann ich nicht sagen, da ich einen Router dazwischen habe. und alle Rechner hinter dem Router sind und über lokale IPs kommunizieren. Es kann nicht an der XP Firewall liegen, da die nicht installiert/aktiviert ist, ich habe zu Testzwecken auch alle anderen Firewalls abgeschaltet. Der Rechner wird gefunden, ich kann von jedem anderen Rechner einen ping absetzen, aber der Server wird nicht gefunden, weder http noch ftp. Auch wenn ich auf dem Rechner mit SP1 die Server abschalte, funzt es nicht. Das Netzwerk ist so klein und es sind auch nicht immer alle Rechner an, dass sich DHCP nicht lohnt, die Rechner haben also feste lokale IPs (ist für das Durchschleifen der IP über die virtuellen Server im Router auch günstiger).
Schöner wäre es ja andersrum. So wie es jetzt ist, kann ich entweder Windows nicht updaten oder muss auf meinen eigenen Web- und FTP Server verzichten - schlechte Alternative. Der Server auf dem SP1 Rechner soll platt gemacht werden, wenn der neue Server auf dem SP2 Rechner alle Funktionen übernehmen kann und dann soll dort das zyklische Neuaufsetzen des Systems stattfinden, so wie es jetzt ist, muß ich den Hobel aber erstmal so laufen lassen, wie er ist und das ist lästig.
Hat jemand einen Hinweis oder ähnliche Erfahrungen gemacht?

Ich danke Euch

Riebensiel
Riebensiel
 
Posts: 12
Joined: 19. January 2004 23:20
Location: Hamburg

Postby Wiedmann » 26. May 2005 23:10

- wenn "http://localhost/" tut
- "ping x.x.x.x" vom anderen PC auch
- "http://x.x.x.x/ vom anderen PC nicht
--> PC hat eine Firewall

"ftp://x.x.x.x/" dürfte ja dann vom anderen PC auch nicht gehen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests