Virtual Host + Proxy Server

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual Host + Proxy Server

Postby Bean » 20. May 2005 21:41

Hallo,

ich habe folgende Angaben in der httpd.conf



NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
DocumentRoot W:/apachefriends/xampp/htdocs
</VirtualHost>

<VirtualHost *:80>
ServerName www.local.meineseite.de
DocumentRoot W:/apachefriends/xampp/htdocs/meineseite
ServerAlias www.local.meineseite.de
ErrorLog logs/www.local.meineseite.de-error_log
<directory W:/apachefriends/xampp/htdocs/meineseite>
AllowOverride All
</directory>
</VirtualHost>


In der host steht
127.0.0.1 localhost
127.0.0.1 www.local.meineseite.de


Trotzdem funktioniert das nicht.
Wenn ich jetzt http://www.local.meineseite.de/ aufrufe kommt folgende Meldung
Warning: Unknown(): open_basedir restriction in effect. File(/www/htdocs/index.php) is not within the allowed path(s): (/tmp) in Unknown on line 0


Ich arbeite auf einem Win2000 Rechner an einem Proxy-Server. Und der hängt hinter einem Router. Kann diese Konstellation Probleme machen?

Weiß jemand eine Lösung?

Gruß
Bean
Bean
 
Posts: 4
Joined: 20. May 2005 21:25

Postby Wiedmann » 20. May 2005 23:00

Warning: Unknown(): open_basedir restriction in effect. File(/www/htdocs/index.php) is not within the allowed path(s): (/tmp) in Unknown on line 0

Diese Meldung kommt von PHP das irgendwie danebenkonfiguriert ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bean » 25. May 2005 20:36

Das verstehe ich nicht.
Ich habe XAMPP komplett neu installert.
D. h. ich arbeite mit den Standardeinstellungen von PHP.

Damit sollte doch ein virtueller Host funktionieren. Oder?
Bean
 
Posts: 4
Joined: 20. May 2005 21:25

Postby Wiedmann » 25. May 2005 20:47

Ich habe XAMPP komplett neu installert.
D. h. ich arbeite mit den Standardeinstellungen von PHP.

Nicht möglich, da beim XAMPP kein open_basedir konfiguriert ist...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bean » 25. May 2005 22:16

Stimmt. Das sehe ich auch so, obwohl ich mich in diesen Dingen nicht auskenne. Bei mir ist auch open_basedir nicht konfiguriert.

; open_basedir, if set, limits all file operations to the defined directory
; and below. This directive makes most sense if used in a per-directory
; or per-virtualhost web server configuration file. This directive is
; *NOT* affected by whether Safe Mode is turned On or Off.
;open_basedir =


Irgendwie komme aber trotzdem nicht weiter.
Bean
 
Posts: 4
Joined: 20. May 2005 21:25

Postby Wiedmann » 25. May 2005 22:29

Bei mir ist auch open_basedir nicht konfiguriert.

Wenn du das wissen willst, musst du schon in phpinfo() nachschauen...

BTW:
Der Pfad in der Fehlermeldung sieht schon exotisch für ein Windowssystem aus...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Bean » 25. May 2005 22:37

phpinfo()

Anzeige bei PHP Core

open_basedir no value no value


Ich habe die XAMPP Version 1.4.9 als Installer Version installiert. Bisher keine Änderungen an der php.ini vorgenommen.
Nur 2-3 Einstellungen in der httpd.conf. Bisher läuft auch alles einwandfrei. Bis auf virtual Host.
Bean
 
Posts: 4
Joined: 20. May 2005 21:25


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests