Problem mit WEBDAV unter SSL

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit WEBDAV unter SSL

Postby svorlow » 15. May 2005 13:14

Hallo,

WEBDAV funktioniert bei mir (Testumgebung Win XP) prima, solange ich HTTP als Protokoll verwende. EinZugriff auf HTTPS unter:
- Start/Netzwerkumgebung/Netzwerkressource hinzufügen/"https://localhost"

scheitert leider, wogegen http://localhost einwandfrei funktioniert.
Ich bekomme noch die Zertifikatsabfrage, aber danach kehrt der Dialog einfach nicht mehr zurück und kann nur noch abgebrochen werden.

An der Default moddav.conf habe ich keine wesentlichen Änderungen bislang vorgenommen. Kann mir jemand vielleicht einen Tip geben, SSL ist in der 1.4.12. Variante von XAMPP ja bereits konfiguriert und läuft.

Ich bin etwas ratlos.

Viele Grüße

Stephan
svorlow
 
Posts: 3
Joined: 28. January 2005 20:35

Postby kozi » 15. July 2005 12:31

Würde mich auch interessieren wie man ssl mit webdav bzw. webdav mit ssl einrichtet.
Hat da keiner Erfahrungen oder sogar ein laufendes System? Muss ja nicht ein Windows System sein. Die Konfigurationsdateien sind ja überall ähnlich.
kozi
 
Posts: 10
Joined: 23. June 2005 18:42

Postby ollo » 15. July 2005 16:08

bei mir funktionierts mit :

Code: Select all
LoadModule dav_module         modules/mod_dav.so
LoadModule dav_fs_module      modules/mod_dav_fs.so

DAVLockDB "C:/WINNT/Temp"
DAVMinTimeout 600

###########
# default #
###########

NameVirtualHost *:80
<VirtualHost *:80>
   ServerName dav.foobar.net
   redirect permanent / https://dav.foobar.net/
</VirtualHost>

NameVirtualHost *:443
<VirtualHost *:443>
   ServerName dav.foobar.net
    DocumentRoot "X:/!Data_Apache"
    SSLEngine on
   SSLCertificateFile "X:/!Data_Server/https_foobar.net.crt"
   SSLCertificateKeyFile "X:/!Data_Server/https_foobar.net.key"
    <Location />
      DAV on
      AuthType Basic
      AuthName "foobar WebDAV"
      AuthUserFile "X:/!Data_Server/dav_auth.txt"
      Require valid-user
      ForceType text/plain
   </Location>
</VirtualHost>
ollo
 
Posts: 85
Joined: 11. November 2004 12:29


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests