Bitte um Hilfe HTML und Kofigurattionsseite!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Bitte um Hilfe HTML und Kofigurattionsseite!

Postby mac_20 » 02. May 2005 09:05

habe eine domain die wird umgeleitet auf eine dyndns domain… router
einträge und so hab ich alles gesetzt so dass alle web
anfragen(port80) an meiem “server” rauskommen müssen… aber wenn ich
nun im browser www.meinedomain.de eingebe komme ich immer am router
herraus gibt es eine möglichkeit wie ich testen kann wie man meinen
server im “externen netz” sieht?

das ander wie kann ich wenn ich die httpd.conf geändert habe auf die
ursprungsseite zurückkommen (von extern)? meine die seite wo ich
alles einstellen kann, und wie muss ich die hhtp.conf einstellen dass
meine internetseite im ordner wwwroot zu sehen ist??
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

Postby Wiedmann » 02. May 2005 09:45

gibt es eine möglichkeit wie ich testen kann wie man meinen
server im “externen netz” sieht?

Verwende den Proxy von deinem Provider.

wie kann ich wenn ich die httpd.conf geändert habe auf die
ursprungsseite zurückkommen (von extern)?

Dazu müsste man ja wissen was du geändert hast. Ansonsten ist die Demopage so zu erreichen:
http://www.example.com/xampp/

und wie muss ich die hhtp.conf einstellen dass
meine internetseite im ordner wwwroot zu sehen ist??

Dazu könntest du den DocumentRoot und den dazugehörigen <Directory>-Abschnitt anpassen (allerdings geht dann die Demopage nicht mehr. Dafür müsste man dann einen Alias einrichten). Das Vorhergehen ist in der FAQ erklärt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mac_20 » 02. May 2005 10:20

entweder bin ich dooof oder hab tomaten auf den augen aber wo finde ich das thema mit den links im FAQ????kann mir jemand den link oder so psoten!?
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

Postby Wiedmann » 02. May 2005 10:27

Xampp für Windows - htdocs verschieben?
http://faq.kwm-web.info/index.php?actio ... artlang=de
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mac_20 » 02. May 2005 11:04

da steht nur dass man ein alias macht aber nicht wo und wie dieses aussiht sorry kannst du mir helfen?? meine http dokumente sollen in htdocs/wwwroot/ liegen und ich will mit /localhost/xamp/ meine xamp seite sehen welche einträge muss ich

wo
und
wie
ändern???


vielen lieben dank!
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

Postby deepsurfer » 02. May 2005 11:30

ist gemein, aber ich mein das nicht böse.


Schau mal in die vorhandene httpd.conf rein, dort sind ALIAS namen eingetragen die du für dich nachbauen kannst.

Ansonsten ist die Umstellung von /htdcos auf /wwwroot nach durchlesen der FAQhilfe wohl kein Problem mehr....

Etwas Kreativität kann man doch herauskitzeln und nicht immer gleich alles vorkauen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mac_20 » 02. May 2005 11:55

doch auch nach den faq's ist das für mich ein prüblem!! sorry finde in den faqs nur dass man ein alias setzen muss aber nicht wo in der httpd.conf und nicht wie!!!
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

Postby deepsurfer » 02. May 2005 14:47

nungut.... noch ein stück vom puzzel-spiel 8)


Ich öffne die httpd.conf \xampp\apache\conf\httpd.conf
und finde ab Zeile 209 schon den ersten ALIAS eintrag von den XAMPP machern. (Alias für Webalizer)
Ab Zeile 224 sogar noch einen, der Alias für den phpmyadmin
233 für xampp-excel
242 für xampp-pdf
251 für xampp-tmp

Aus diesen Vorgaben kannst du dir leicht einen eintrag für das alte XAMPP-htdocs Verzeichnis bauen, damit der willkommensbereich wieder vorhanden ist.


Zeile 313 ist der erste Eintrag für das Hauptverzeichnis was bei dir dann dementsprechend (/wwwroot) abgeändert werden müsste

Zusätzlich noch die Zeile 338 für dein /wwwroot abändern und nun sollte dein Wunsch in Erfüllung gehen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Jack » 02. May 2005 14:58

muss mich mal ganz kurz einmischen ich hab das jetzt nach euerer "anleitung" gemacht und was passiert ?!

Not Found

The requested URL / was not found on this server.

Apache/2.0.53 (Win32) mod_ssl/2.0.53 OpenSSL/0.9.7c PHP/5.0.4 Server at localhost Port 80



toll und dann hab ich mir gedacht kein problem du hast ja die datei davor gebackupt und ich loade das einfach zuück *mach* und was seh ich da?

Not Found

The requested URL / was not found on this server.

Apache/2.0.53 (Win32) mod_ssl/2.0.53 OpenSSL/0.9.7c PHP/5.0.4 Server at localhost Port 80




!!!!!!!!!!!!!!


das kann doch nicht sein ?! hab grade alles nochmal durchgekugekugt und nix gefunden was ich faslch gemacht haben könnte, habt ihr mir noch nen tiP!?



ACH JA ICH HAB DEN pc SCHON 10x neu gestartet an dem kanz nicht leigen



////////////////////////////////////EDIT\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
!!!!ES GEHT *freu* nachdem ich den Xampp neu installt hab gings jetzt mit jeder Folder
User avatar
Jack
 
Posts: 50
Joined: 07. April 2005 13:16
Location: Nürtingen

Postby mac_20 » 02. May 2005 16:19

so webserver zeit das indexfile an! was muss ich aber machen damit ich wieder die xamp seite sehe welches alias muss ich setzen????
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

Postby mac_20 » 02. May 2005 17:17

und wenn ich im phpadmin mein root passwort für localhoast ändere bzw. eine s definiere dann kommt wenn ich ihn erneut aufrufe sql error ... was mache ich falsch????
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

HELPPPPPP

Postby mac_20 » 02. May 2005 18:15

also super hab nen link hinbekommen hier der auszug aus der conf datie


Alias /xampp "W:/apachefriends/xampp/htdocs/xampp/splash.php"

<Directory "W:/apachefriends/xampp/htdocs/xampp/splash.php">
Options Indexes MultiViews ExecCGI
AddHandler cgi-script .cgi .exe
Order allow,deny
Allow from all
</Directory>



wiso klappt es nicht dass ich dann auf der startseite auf deutsch klicken kann????? also ich kann nur auf die obere ebene klicken tiefere links gehen nicht!
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

Postby Wiedmann » 02. May 2005 18:17

Ein Alias zeigt (normal) auf Verzeichnisse, und nicht auf Dateien.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 03. May 2005 07:35

Alias /xampp "W:/apachefriends/xampp/htdocs/xampp"

<Directory "W:/apachefriends/xampp/htdocs/xampp/splash.php">
Options Indexes MultiViews ExecCGI
AddHandler cgi-script .cgi .exe
Order allow,deny
Allow from all
</Directory>



Die XAMPP-Standart Installation und dessen aufruf ist folgender...(HTML Grundfunktionen, ich mach ein Fernkurs auf)
Im /htdocs Verzeichnis gibt es eine index.html, deren Funtkion darin bestand innerhalb von null Sekunden automatisch das Verzeichnis zu wechseln in /htdocs/xampp um dort direkt die splash.php aufzurufen.

Dadurch das du nun dein Dokumentenroot Verzeichnis umgebogen hast (wwwroot) wird halt auf diese index.html nicht mehr zugegriffen.

Falls du diese Datei noch im /htdocs hast, so kopiere diese bitte in das /htdocs/xampp verzeichnis und editiere diese index.html.
Du siehst dann im HTMLcode das in einer META angabe der wechsel definiert ist. Diese musst du nur anpassen weil ja nun ein wechsel nicht mehr nötig ist.

Wenn Du nun nichts weiter umgebogen hast funktioniert dein Konstrukt wie folgt.

http://localhost --> wird durch Alias wwwroot in ein anderes Dokumentroot Verzeichnis geschickt....(so willst du es ja)

http://localhost/xampp --> wird nun durch den Alias (siehe hier oben den richtigen Aufbau) direkt in das /htdocs/xampp verzeichnis geschickt und jetzt greift die von dir erstellte (kopierte und abgeänderte) index.html und öffnet die splash.php
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mac_20 » 03. May 2005 07:45

ja so habe ich heute nacht es schon hinbekommen es tut danke dir aber trotzdem!!

Aber nun habe ich nen Neues Problem!!!

bin in ADoB gegangen wollte mal die CD sammlung testen und dann kam folgender fehler

Warning: mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on '196.168.1.2' (10060) in W:\apachefriends\xampp\php\pear\adodb\drivers\adodb-mysql.inc.php on line 340

was mach ich falsch?
mac_20
 
Posts: 22
Joined: 02. May 2005 08:56

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests