tomcat addon: kein setup_java.bat!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

tomcat addon: kein setup_java.bat!

Postby Josh83 » 27. April 2005 15:06

hallo alle!

ich verwende seit einem jahr xampp auf windows xp und bin sehr zufrieden damit; danke an das entwicklerteam für ihre grossartige arbeit an dieser stelle! :)

nun arbeite ich mich in java server pages ein und war hocherfreut, ein tomcat plugin für xampp gefunden zu haben, denn ich möchte die vorteile von apache auch für jsp nützen, vorallem das mod_rewrite modul.

ich habe also die exe runtergeladen und installiert. leider fand ich keine setup_java.bat datei, obwohl im readme steht, diese müsse ausgeführt werden.
ich versuchte den service etc. zu starten, und tatsächlich konnte ich über den port 8080 connecten; leider aber nicht über den default port etc. :(

ich hatte zuvor testweise eine standalone version von tomcat 5 installiert, und weiss nun nicht, ob diese evtl. stört; sie ist deaktiviert.

ich wäre um hilfe sehr dankbar, denn ohne mod_rewrite bin ich nur ein halber webmaster! ;)

vielen dank und grüsse aus der schweiz
Josh
Josh83
 
Posts: 15
Joined: 27. April 2005 15:00

Postby carsten_baz » 28. April 2005 06:33

ich habe also die exe runtergeladen und installiert. leider fand ich keine setup_java.bat datei, obwohl im readme steht, diese müsse ausgeführt werden.

Das sieht so aus, als ob du die Installerversion heruntergeladen hast. Diese hat keine setup_java.bat.
Von Xampp und Tomcat gibt es sowohl Installer-Versionen (.exe) als auch Zip-Dateien.
Diese sind laut Doku nicht kreuzweise kompatibel.
Also wenn du XAMPP mit dem Installer installiert hast, dann musst du auch von Tomcat den Installer nehmen. Hierbei gibt es keine setup Dateien die auszuführen sind.
Wenn du jedoch die ZIP-Dateien verwendet hast, dann sind auch die setup-Dateien dabei.

Bei mir gab es da jedoch mit dem Installer ein kleines Problem siehe
http://community.apachefriends.org/f/viewtopic.php?t=11518
So habe ich jetzt auch den Tomcat nur standalone :cry:
Ciao,
Carsten
carsten_baz
 
Posts: 7
Joined: 27. April 2005 07:41
Location: BS

Postby Josh83 » 28. April 2005 08:42

ich habe von beiden die installer version. installation läuft auch problemlos, und ich kann per port 8080 auf tomcat zugreifen.
nur möchte ich per default port darauf zugreifen können, damit ich per htaccess datei die funktionen von apache auch für jsp ordner verwenden kann (z.b. für url rewriting per mod_rewrite).

ich habe eine antwort zu deinem thread geschrieben... vielleicht können wir uns gegenseitig helfen. :)
Josh83
 
Posts: 15
Joined: 27. April 2005 15:00

Postby carsten_baz » 28. April 2005 09:43

Hallo,
ich hab jetzt einfach die Tomcat zip Datei entpackt. Und dann die setup_java.bat aufgerufen.
Der Tomcat läuft jetzt. Auch mit den Beispielen aus dem Readme. Oder wie du schriebst: über den Default Port.

Das einzige was nicht so schön ist: Der Tomcat ist nicht in das XAMPP Control Panel integriert.

Versuchs doch auch mal mit der ZIP-Datei.
Im Installer scheint ja irgendwie der Wurm drin zu sein.
Ciao,
Carsten
carsten_baz
 
Posts: 7
Joined: 27. April 2005 07:41
Location: BS

Postby Josh83 » 28. April 2005 09:48

hui, gewagt! :wink:

werds also auch mal so probieren... mehr als schiefgehen kanns ja nicht. ;)
Josh83
 
Posts: 15
Joined: 27. April 2005 15:00

Postby BastianW » 28. June 2005 13:46

Josh83 wrote:hui, gewagt! :wink:

werds also auch mal so probieren... mehr als schiefgehen kanns ja nicht. ;)


Und wie sieht es bis jetzt aus? Ich habe hier das gleiche problem...
BastianW
 
Posts: 1
Joined: 28. June 2005 13:42

Postby Josh83 » 28. June 2005 13:52

hat gut geklappt...
Josh83
 
Posts: 15
Joined: 27. April 2005 15:00


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests