Zeichensatzprobleme beim Import einer MySQL-DB

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Zeichensatzprobleme beim Import einer MySQL-DB

Postby le block » 22. April 2005 16:35

Hallo, Ihr Apache'n.

beim Backup meiner lokalen Mysql-Datenbank und dem versuchten Import bei meinem Provider (Hosteurope) bin ich auf folgenden Fehler gestoßen.

phpmyadmin des Providers gibt mir folgenden Fehler aus:
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate latin1_general_ci NOT NULL default '',
`address_emai


der Header sieht so aus:
Code: Select all
-- phpMyAdmin SQL Dump
-- version 2.6.1
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Erstellungszeit: 22. April 2005 um 17:21
-- Server Version: 4.1.10
-- PHP-Version: 5.0.3
--
-- Datenbank: `capoeira`
--
-- --------------------------------------------------------
--
-- Tabellenstruktur für Tabelle `phpwcms_address`
--
CREATE TABLE `phpwcms_address` (

`address_id` int( 11 ) NOT NULL AUTO_INCREMENT ,
`address_key` varchar( 255 ) COLLATE latin1_general_ci NOT NULL default '',
`address_email` varchar( 255 ) COLLATE latin1_general_ci NOT NULL default '',
`address_name` text COLLATE latin1_general_ci NOT NULL ,
`address_verified` int( 1 ) NOT NULL default '0',
`address_tstamp` timestamp NOT NULL default CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP ,
`address_subscription` blob NOT NULL ,
PRIMARY KEY ( `address_id` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci AUTO_INCREMENT =2


Die Jungs vom phpwcms-forum meinten,es würde an meinem XAMPP Version (1.4.12) liegen, welcher Probleme mit den Zeichensätzen hätte und ich solle mich vertrauensvoll an Euch wenden.Hiermit Getan!

Wie kann ich denn diesen Fehler beheben bzw. den provider-phpmyadmin dazu überreden,daß es meine Datenbank annimmt?
Exportiert Mysql die Daten im verkehrten Format(falsche Zeichensätze)?
Hilft ein überschreiben des XAMPP mit einer älteren/neueren Version?
Gehen dabei die Daten in der DB flöten?

Fragen über Fragen :D

Vielleicht noch ein paar Informationen über mein lokalen Xampp:
XAMPP 1.4.12 , phpMyAdmin 2.6.1, MySQL 4.1.10

Ich danke schonmal. le block


PS: Ich kann phpwcms allen empfehlen die ein kleines, schlankes aber mächtiges CMS brauchen. guckst du hier:
http://www.phpwcms.de
Last edited by le block on 22. April 2005 17:18, edited 1 time in total.
le block
 
Posts: 2
Joined: 22. April 2005 15:49
Location: Leipzig

Postby Wiedmann » 22. April 2005 17:09

Code: Select all
mysqldump.exe --compatible=mysql40 --default-character-set=latin1 --user=root --password capoeira > backup.sql
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby le block » 22. April 2005 17:26

Danke erstemal. Ähem, jetzt muss ich mich wohl als newbie outen.

wo finde ich denn die command line in phpmyadmin? oder muss ich die mysqldump.exe über die windows konsole ausführen? und warum funktioniert die export-funktion denn nicht richtig?
le block
 
Posts: 2
Joined: 22. April 2005 15:49
Location: Leipzig

Postby Wiedmann » 22. April 2005 18:22

oder muss ich die mysqldump.exe über die windows konsole ausführen?

Ja.

und warum funktioniert die export-funktion denn nicht richtig?

Hast du im Exportdialog überhaupt die "SQL-Export-Kompatibilität" angegeben (das du beim Provider eine andere Version benutzt ist ja klar...)? Früher zumindest gab es dann trotzdem hin und wieder Exports in UTF-8 (dem man z.T. mit dem Einstellen einer anderen Kollation begegnen konnte). Musst halt testen ob dieses langt --> Das Sicherste ist jedenfalls die Konsole.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests