Wampp13cs: Nach Passwortvergabe für DB nur noch Fehler

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Wampp13cs: Nach Passwortvergabe für DB nur noch Fehler

Postby karli » 15. May 2003 14:48

Ich habe die Wampp13cs unter XP Home installiert und es läuft alles prima. Sobald ich ein User-Passwort vergeben will ist Feierabend.
Ich bin so vorgegangen:
Mit PhpMyAdmin habe ich in der DB mysql in die Tabelle user zusätzlich einen neuen Benutzer angelegt mit
host='localhost',
User='hund',
Passwort='katze', und mit allen Rechten ausgestattet.
Ein Zugriff auf die vorhandene DB test mit 'localhost', 'hund', 'katze' ist nicht möglich, dito mit PhpMyAdmin, wenn ich folgendes in die config.inc.php eintrage:

$i = 1;
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'hund';
$cfg['Servers'][$i]['password'] = 'katze';

In der my.cnf habe ich versuchsweise folgendes eingetragen:
[WinMySQLadmin]
Server=/wampp13cs/mysql/bin/mysqld.exe
user=hund
password=katze,
das und andere Experimente haben nichts gebracht

Wo ist der Hund begraben? Oder anders, was muss ich beachten wenn ich einen zusätzlichen Benutzer mit allen Rechten und zusätzlich weitere Benutzer mit beschränkten Rechten anlegen möchte.

Noch eine Frage:
Als ich mich lehrgangsmäßig mit MySQL beschäftigte (unter Linux) konnte ich direkt im Consolenfenster arbeiten. Im installierten Wampp geht das nicht. Ist das normal? Die letzten Zeilen im Consolenfenster lauten:
MySQL is starting with \wampp13cs\mysql\bin\my.cnf (console)
F:\wampp13cs>mysql\bin\mysqld –default-file=\wampp13cs\mysql\bin\my.cnf
Im Forum wurde schon einmal auf dieses Problem hingewiesen, leider ohne abschließende Lösung.

karli
karli
 

Postby DJ DHG » 17. May 2003 15:48

Moin Moin

warum hast du nicht unter rechte oder benutzer (je nach version phpmyadmin)
einen oder mehrere neue benutzer angelegt?

du willst doch einene login für mysql wo sich jeder mit seinem pw
anmelden kann oder?

dann stellt folgendes so ein

Code: Select all
$cfg['Servers'][$i]['auth_type']     = 'cookie';
$cfg['Servers'][$i]['user']          = '';
$cfg['Servers'][$i]['password']      = '';


und mach das in der my.conf wieder rückgängig...

mfg DJDHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby karli » 19. May 2003 21:20

Danke für die Tipps. Habe auch noch einige im forum zu phpmyadin gefunden. Ich muss die Dinge jetzt erst ausprobieren. Dann melde ich mich noch einmal.
karli
 

Postby karli » 19. May 2003 22:20

Danke, es hat funktioniert. Allerdings beim ersten Einloggen nur mit dem Benutzer und ohne Passwort (Kennwort). Nach dem Einloggen habe ich das Kennwort geändert und jetzt flutscht es. :lol:
Eine Frage noch: Geht es auch ohne Cookies?
karli
 

Postby DJ DHG » 20. May 2003 03:30

jo geht

von
Code: Select all
$cfg['Servers'][$i]['auth_type']     = 'cookie';


nach

Code: Select all
$cfg['Servers'][$i]['auth_type']     = 'http';


umändern

mfg DJDHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests