mp3-Files im Tag <BGSOUND> werden nur teilweise gespie

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mp3-Files im Tag <BGSOUND> werden nur teilweise gespie

Postby jradler » 13. April 2005 13:06

Hallo,

ich habe in einem php-script folgenden html-code:

<BGSOUND SRC="bgsound.mp3" LOOP=INFINITE>

Auf meinem XAMPP wird von dieser Audiofile immer nur kurz der Anfang und nicht das komplette Stück gespielt.
Muß ich noch etwas spezielles konfigurieren, damit das komplette Stück geladen wird?
jradler
 
Posts: 4
Joined: 13. April 2005 12:49

Postby the-piep » 13. April 2005 19:18

das hört sich wieder nach

Suche mal im Pfad deiner Apache-Installation nach dem Verzeichnis "/xampp/apache/conf". Dort öffnest du die Datei "httpd.conf".
Suche nach den Einträgen:

# EnableSendfile Off
und
# EnableMMAP Off

Diese änderst du in

EnableSendfile On
und
EnableMMAP On


an...nur eben nicht mit bildern sonders soundfiles - wär auf jeden fall ne vermutung von mir...
User avatar
the-piep
 
Posts: 19
Joined: 18. February 2005 14:08
Location: Erde

Postby jradler » 14. April 2005 08:35

Die Einträge waren bei mir gar nicht vorhanden. Habe sie wie folgt eingebaut:

#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule mysql_auth_module modules/mod_auth_mysql.so

EnableSendfile On
EnableMMAP On

<IfModule mod_dav.c>
<IfModule mod_dav_fs.c>
Include conf/moddav.conf
</IfModule>
</IfModule>

Aber leider ohne Erfolg!

Ich werden die XAMMP-Version 1.4.2 unter Windows 2000 pro

Apache/2.0.49 (Win32) mod_perl/1.99_13 Perl/v5.8.3 PHP/4.3.6 mod_ssl/2.0.49 OpenSSL/0.9.7d mod_autoindex/color

Bei Verwendung der mp3-File in reinem HTML wird diese wie gewünscht
auch abgespielt.

Hat noch jemand ein Idee?
jradler
 
Posts: 4
Joined: 13. April 2005 12:49

Postby adi99 » 14. April 2005 18:37

dann hast du wohl falsch programmiert. Gib doch mal das PHP Dokument(Ausgabe+Source).
User avatar
adi99
 
Posts: 115
Joined: 15. January 2004 16:08
Location: Switzerland

Postby jradler » 14. April 2005 18:59

Wirklich?
Was kann man an <BGSOUND SRC="bgsound.mp3" LOOP=INFINITE>
falsch programmieren?

Zur Info auf dem Host meines Providers (Apache/2.0.46 (Red Hat)funktioniert es ja...
Eben nur bei mir lokal nicht...
jradler
 
Posts: 4
Joined: 13. April 2005 12:49

Postby Wiedmann » 14. April 2005 19:32

Was kann man an <BGSOUND SRC="bgsound.mp3" LOOP=INFINITE>
falsch programmieren?

Da hast recht. Eigentlich sollte man da wirklich nichts mehr falsch machen können...
Code: Select all
<bgsound src="bgsound.mp3" loop="infinite">
                                ^        ^


Das dürfte aber nicht dein Problem lösen (vor allem wenn dies die selbe Datei wie beim Provider ist). Folgende Ideen:
src="bgsound.mp3"

Welchen Content-Type schickt der Server vom Provider, und welchen der XAMPP bei MP3-Dateien?

Die Einträge waren bei mir gar nicht vorhanden.

Die gibt es bei jedem XAMPP in der "httpd.conf". Deine Einträge könnten als also durch die Einträge die schon da waren immer noch überschrieben werden. Wenn "On" nicht geht, solltest du es noch mit "Off" probieren ("On" ist dabei der Standard wenn dieser Eintrag nicht vorhanden ist).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jradler » 14. April 2005 20:27

Wiedmann, das war es!!! :lol:

Der letzte Hinweis (on/off) war erfolgreich:

In der "httpd.conf":

#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule mysql_auth_module modules/mod_auth_mysql.so

EnableSendfile Off
EnableMMAP Off

<IfModule mod_dav.c>
<IfModule mod_dav_fs.c>

In dem php-Script:

<BGSOUND SRC="bgsound.mp3" LOOP=INFINITE>

Der Vorschlag:

<bgsound src="bgsound.mp3" loop="infinite">

ließ jedoch gar keine Musi erklingen?!?

Eine kurze Frage noch zum Schluß:

Wo erfährt man bzw. steht, welchen Content-Type ein Server schickt?

Vielen, vielen Dank!
jradler
 
Posts: 4
Joined: 13. April 2005 12:49


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests