Script läuft im Netz aber nicht auf dem WAMPP

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Script läuft im Netz aber nicht auf dem WAMPP

Postby Tatinka » 14. May 2003 13:36

Hi,

das folgende Script läuft im Netz (UNIX) aber nicht auf meinem lokalen WAMPP (register_globals=off). Ich bekomme folgenden Fehler:
Warning: Invalid argument supplied for foreach() in C:\Daten\Projekte\aerzte-service ordner\aerzte-service\test.php on line 23
Line 23 ist: foreach($timetable as $key => $value) {

Wer weiß Rat?
Vielen Dank schon jetzt,
Tatinka

Das Script:

<?
$array_namen = array("name1","name2","name3","name4");

function maketimestamp($date) {
$exploded = explode(".", $date);
$return = mktime(0,0,0,$exploded[1],$exploded[0],$exploded[2]);
return $return;
}

$time_lower = maketimestamp("1.5.2003");
$time_upper = maketimestamp("15.5.2003");
$indexlength = sizeof($array_namen) - 1;
$currentindex = 0;

while($time_lower <= $time_upper) {
if( (strftime("%u", $time_lower) == 1) || (strftime("%u", $time_lower) == 2) || (strftime("%u", $time_lower) == 5)) {
$timetable[$time_lower] = $array_namen[$currentindex];
if($currentindex == $indexlength) $currentindex = 0; else $currentindex++;
}
$time_lower += 86400; // next day
}

foreach($timetable as $key => $value) {
echo(strftime("%d.%m.%Y", $key) . " => " . $value . "<BR>");
}

?>
Tatinka
 

Postby alex_n » 14. May 2003 14:06

hi
ich denke mal das heist forseach mit ,,s" aber irgendwie kommt dann bei mir:

Parse error: parse error in H:\wampp2\htdocs\test.php3 on line 23

ansonsten kann ich nicht viel helfen!

Gruß alex_n
alex_n
 
Posts: 18
Joined: 10. May 2003 07:29
Location: Düsseldorf

Postby AlexPausB » 14. May 2003 16:32

alex_n wrote:hi
ich denke mal das heist forseach mit ,,s"


Im Leben net! "foreach" stimmt schon! "forseach" gibts nich, what soll das auch heissen? deswegen der parse error...

Aber leider hab ich auch keinen Rat was da nicht stimmen könnte!
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby DSB » 14. May 2003 17:16

strftime stützt sich auf die Einstellungen von setlocale() und so werden nicht immer alle Kürzel (%u) unterstützt.
Siehe hier: http://www.phpcrawler.de/phpmanual/func ... rftime.php

Wenn Du aber in strftime statt %u %w nimmst, dann geht es (aber Achtung -> [0-6] wobei: 0 = Sonntag ist).

Gruß, DSB
DSB
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: fussel01 and 11 guests