XAMPP-Status nicht alles aktiv

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP-Status nicht alles aktiv

Postby kokosnuss » 05. April 2005 06:57

Hallo,

ich habe hier unter "Windows XP Pro SP2" folgendes in dieser Reihenfolge
installiert:
xampp-win32-1.4.121.zip
xampp-patch-1.4.12-pl1.zip
xampp-perl-addon-1.4.12.zip

Wenn ich dann mittels "XAMPP-Control" alles starte und dann mittels
"http://localhost/xampp/status.php" mir den Status anzeigen lasse,
dann sind "Perl mit mod_perl" und "FTP-Server" deaktiviert.

Ich habe dann alles destopped, "setup_xampp.bat" gestartet und da "Perl mit mod_perl" ausgewählt. Aber auch das brachte keine Statusänderung.

Wie erreiche ich es, das PERL aktiv wird und er FTP-Server aktiv bleibt?

In der FAQ und in alten Beiträgen habe ich nichts gefunden.

MfG
Heiko Rompel
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
Operating System: Windows 7 Pro

Postby deepsurfer » 07. April 2005 12:06

Wie erreiche ich es, das PERL aktiv wird und er FTP-Server aktiv bleibt?


Ich weiss nicht woher du den Status hast das PERL nicht aktiv sei ???
PERL ist eine Modulksprache wie PHP und bedarf keiner Statusanzeige.

Was standartmässig nicht aktiviert wird ist der
FTP-Server (File Transfer)
SMTP-Server (Mail Server)

Den FTP, startest du seperat mit \xampp\filezilla_start.bat
Den SMTP, startest du seperat mit \xampp\mercury_start.bat

Zu beiden Programmen bedarf es einer zusätzliches studierung der Dokumentation damit es einwandfrei funtkioniert.
Hier im Forum gibt es dazu etliche Texte mit Hinweisen/Lösungen etc.

In der FAQ und in alten Beiträgen habe ich nichts gefunden.

Passwörter für die zwei Programme
\xampp\readme_de.txt

Generelle Anleitungen zu den Programmen findest du auf den Projektseiten dieser Programme.
Für den FilZilla ist sogar hier im Forum ein eigenes Topic vorhanden.

Für den Mercury-Mail Server findest du hier im Forum genügend Texte und Hilfestellungen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kokosnuss » 07. April 2005 12:34

deepsurfer wrote:Ich weiss nicht woher du den Status hast das PERL nicht aktiv sei ???
PERL ist eine Modulksprache wie PHP und bedarf keiner Statusanzeige.


Wie ich schon schrieb: "http://localhost/xampp/status.php"
Eine Datei die mitgeliefert wird.

Was standartmässig nicht aktiviert wird ist der
FTP-Server (File Transfer)
SMTP-Server (Mail Server)

Den FTP, startest du seperat mit \xampp\filezilla_start.bat
Den SMTP, startest du seperat mit \xampp\mercury_start.bat

Okay, die beiden kann ich auch mittels "XAMPP-Control" starten
(vorausgesetzt ich habe sie dann eingerichtet.)
Danke für die Hinweise.

Was mich jetzt etwas stutzig macht, ist folgendes:
Ich habe XAMPP installiert, dann den Patch und dann das ADD-ON für Perl.

Installiere ich das Perl-Add-On, dann heißt es im Status:
"Common Gateway Interface (CGI) Deaktiviert" - ???
Installiere ich das Perl-AddOn nicht, dann klappt alles.

Aber das gehört in ein eigenes Topic.

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
Operating System: Windows 7 Pro

Postby deepsurfer » 07. April 2005 13:02

aaahhhhhhhhh jetzt kapier ich...

Also... der status des Common Gateway Interfaces CGI wird dadurch geprüft ob im verzeichniss \xampp\cgi-bin\ die datei cgi.cgi vorliegt.

Solltest du nun dieses Verzeichniss in der HTTPD.CONF fürs system geändert haben und oder die Datei gelöscht, so kann der Status report nur mitteilen das CGI nicht aktiv sein...(logisch)

Zu finden wenn du unterhalb der statusmeldung auf "Den Quellcode einblenden" klickst, dann erscheint der Webcode des status und dort ist auch der befehl wonach der status für CGI sucht enthalten.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kokosnuss » 07. April 2005 13:19

Hallo,

deepsurfer wrote:aaahhhhhhhhh jetzt kapier ich...

Also... der status des Common Gateway Interfaces CGI wird dadurch geprüft ob im verzeichniss \xampp\cgi-bin\ die datei cgi.cgi vorliegt.

Solltest du nun dieses Verzeichniss in der HTTPD.CONF fürs system geändert haben und oder die Datei gelöscht, so kann der Status report nur mitteilen das CGI nicht aktiv sein...(logisch)


Aha, jetzt ja.....
Also kommt diese Anzeige daher, das ich in der httpd.conf
den Eintrag für das cgi-bin aus kommentiert habe, um Sripte nicht nur da ablegen zu können.

Alles klar. Danke.

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
Operating System: Windows 7 Pro

Postby kokosnuss » 07. April 2005 13:26

Nachtrag,

kokosnuss wrote:Also kommt diese Anzeige daher, das ich in der httpd.conf
den Eintrag für das cgi-bin aus kommentiert habe, um Sripte nicht nur da ablegen zu können.


Lege ich in "x:/xampp/htdocs" ein Verzeichnis "cgi-bin" an und kopiere die
"cgi.cgi" da rein, ist die Anzeige wieder "in Ordnung".

Tja, was ist der beste Weg - für jede Homepage ein Unterverzeichnis in "htdocs" mit eignem CGI-BIN-Verzeichnis oder ein zentrales CGI-BIN?

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
Operating System: Windows 7 Pro

Postby deepsurfer » 07. April 2005 13:38

grundsätzliches:
Die standart httpd.conf am besten so lassen wie sie ist.

Für weitere einträge benutzt man am besten VirtuelHost einträge.
In diesen VHOST kann du dann cgi-bin verzeichnise hinlegen wohin du willst.

Im grunde genommen geht es dir nur darum alles Grün auf der statuspage zu haben. Überlege dir dahingehend ob es für den weiteren Verlauf notwendig ist.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests