Indexanzeige / Directory Index

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Indexanzeige / Directory Index

Postby marcus_NRW » 27. March 2005 12:59

Hallo zusammen, habe folgendes Problem:

Im meinem "wwwroot" Verzeichnis liegt eine Index.html.
Die httpd.conf ist so konfiguriert das eben diese bei einer Anfrage ausgegeben wird. Funktioniert alles wunderbar.

Jetzt habe ich innerhalb des wwwroot Ordners einen Ordner mit Namen "Projekt" der auch wieder einer Index.html beinhaltet und vom obig aufgeführten per Link zu erreichen ist. Funktioniert auch tadellos.

Innerhalb des Ordners "Projekt" gibt es wieder einen, nämlich den Ordner "content"

Dieser beinhaltet Dateien die nach Eingabe folgendes Pfades im Explorer: "http://www.domainname.de/project/content" angezeigt werden sollen.

Was aber kommt ist eine Fehlermeldung:

Forbidden
You don't have permission to access /Projekt/content/ on this server.

Weiss vielleicht jemand was zu tun ist??

Muss die httpd.conf vielleicht um etwas in dieser Art ergänzt werden? Und wenn, an welcher Stelle genau?

Alias /content "c:/apachefriends/xampp/wwwroot/project/content/"

<Directory "c:/apachefriends/xampp/wwwroot/project/content">
DirectoryIndex index.htm
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

Für Hilfe währe ich sehr dankbar!
marcus_NRW
 
Posts: 6
Joined: 27. March 2005 12:38

Postby deepsurfer » 27. March 2005 13:06

setze in das /content verzeichniss eine .htaccess die nur mit der Anweisung zur Indexierung gefüttert ist, dann hast du dein gewünschtes ergebnis.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby marcus_NRW » 27. March 2005 13:30

Ich habe noch nicht soviel Erfahrung mit .htaccess Dateien, aber folgende Inhalte verhelfen noch nicht zum gewünschten Ergebniss! :

AuthType Basic
AuthName "phpBB2 Testzone"
AuthUserFile ..\apache\auth\.ht_nutzer
require valid-user
DirectoryIndex index.html index.html.var

habe ich das denn mit der Indexierung so richtig umgesetzt?

Vielen Dank schon mal für die "erste Hilfe"! :D
marcus_NRW
 
Posts: 6
Joined: 27. March 2005 12:38

Postby deepsurfer » 27. March 2005 13:46

.htaccess ist nicht gleichbedeutend mit einer Authentifierung (Passwort abfrage)...
Mit einer htaccass kannst du vorgaben innerhalb der httpd.conf aushebeln und andere vorgaben definieren, so auch das "FencyIndexing"

Die .htacces im /content Verzeichnis für dich sollte nur so gefütter sein.
Code: Select all
FancyIndexing On



Damit du weitere Funktionen nachlesen kannst
http://www.trash.net/faq/htaccess.shtml
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 27. March 2005 15:36

<Directory "c:/apachefriends/xampp/wwwroot/project/content">
DirectoryIndex index.htm
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

Ersetze Zeile 2 + 4 durch:
Code: Select all
DirectoryIndex none
Options Indexes
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby marcus_NRW » 27. March 2005 17:41

Oh Jungs, das funzt immer noch nicht! :(

->Wiedmann: bei Deiner Lösung weiss ich gar nicht so genau an welche Stelle der Einschub gehört, zu "Include conf/ssl.conf" oder weiter unten hin?!?!?

Ich habs mal versucht, bleibt aber Fehler 403!!
Was ist denn mit der "Alias" Zeile benötige ich Die gar nicht?

->Deep: hier tut sich was!

Es gibt nen Fehler 500 mit Verweis auf error.log, welche aussagt:
The FancyIndexing directive is no longer supported. Use IndexOptions FancyIndexing.

Schreib ich in die .htaccess anstantt FancyIndexing IndexOptions gibt das wieder nen 500 mit Verweis auf error. log welche aussagt:
Invalid directory indexing option

Ich weiss nicht mehr weiter....
marcus_NRW
 
Posts: 6
Joined: 27. March 2005 12:38

Postby Wiedmann » 27. March 2005 18:44

->Wiedmann: bei Deiner Lösung weiss ich gar nicht so genau an welche Stelle der Einschub gehört, zu "Include conf/ssl.conf" oder weiter unten hin?!?!?

Wo steht in dem Zitat oben etwas von "Include conf/ssl.conf" :?:
Genau den Directory-Block den du selbst geschrieben hast sollst du auch benutzten und darin nur 2 Zeilen anpassen. Die Zeilen in dem Zitat wirst ja zählen können um zu wissen welche zwei ich mein (sollte sich ja auch anhand des Directivennamens ergeben...)

Was ist denn mit der "Alias" Zeile benötige ich Die gar nicht?

Nein. Deshalb hab ich sie auch nicht zitiert...


Vielelicht versteh ich dich auch falsch. Meinst du mit "Einschub" die Anweisungen die du selbst gepostet hast? Wo hast du denn die bisher hingeschrieben? Ohne den Aufbau deiner Conf zu kennen, würd ich jetzt einfach mal schätzen: einfach mal am Schluss anfügen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests