1.4.4 mySQL schnell => 1.4.12 mySQL laaangsam

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

1.4.4 mySQL schnell => 1.4.12 mySQL laaangsam

Postby saerdna » 21. March 2005 16:32

Hallo,

ich habe ein eigenartiges Geschwindigkeits-Problem.

Ich hatte XAMPP 1.4.4, lief im Intranet absolut zuverlässig ohne Probleme.
Die Version 1.4.12 ist allerdings beim Zugriff auf PHP4-Seiten mit mySQL-Daten sehr langsam. Es dauert ca. 5-6 Sekunden, bis sich die Seite aufgebaut hat. Unter 1.4.4 war es für die gleichen Seiten unter einer halben(!) Sekunde.
An der Applikation (Shop-System mit wenigen Testartikeln und Benutzern) oder Hardware kann es folglich doch nicht liegen.

Kann man in XAMPP/mySQL 1.4.12 irgendetwas "tunen", was in 1.4.4 noch nicht drinnen war?

Es wurde nix neues installiert, Firewall zur Probe deaktiviert.

Seiten mit PHP ohne DB-Zugriff sind rattenschnell.

Noch zur Diagnose: der Taskmanager zeigt keine nennenswerte Auslastung an, solange die o.g. 5-6 Sekunden verstreichen. Es scheint, als ob das System eine "Denkpause" einlegt.

Der Server, auf dem es läuft: Pentium 700 Mhz, 512 MB RAM, 80 GB Festplatte, NT 4 SP6a.


Ich weiss kein Rat mehr und bin dankbar für jede Hilfe. :(

Gruß
Saerdna
saerdna
 
Posts: 2
Joined: 21. March 2005 16:20
Location: Stuttgart

Postby saerdna » 21. March 2005 20:38

Hi,

ich habe die Ursache selbst gefunden. Die DB war auf 192.168.2.61, konfiguriert., dieses ist die IP des Netzwerkkarten-Devices
Wenn man Sie auf 127.0.0.1 (Loopback-Device) stellt, dann läuft Sie wieder sehr schnell.

Warum das so ist, keine Ahnung, scheint aber wirklich irgendwo von 1.4.4
auf 1.4.12 der Fall zu sein.


Bye,
Saerdna :D
saerdna
 
Posts: 2
Joined: 21. March 2005 16:20
Location: Stuttgart

Postby aixtreme » 24. March 2005 10:15

Hallo,
habe genau das selbe Problem.

Was ist ein Lookback Device und wie stell ich dies ein ??

Danke im Voraus.
aixtreme
 
Posts: 10
Joined: 14. January 2005 09:07

Postby aixtreme » 24. March 2005 10:34

Ok, hab gefunden was du meinst.

Für den Server ist das Problem gelöst.

Nur wenn man ihn als externen DB server nutzen will ist das schlecht :(
Kann man das irgendwie umstellen ??
aixtreme
 
Posts: 10
Joined: 14. January 2005 09:07


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests