Localhost = meine web-page

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Localhost = meine web-page

Postby Mario Lanz » 17. March 2005 12:13

Hallo,

Sorry ganz blöde frage...

Wenn ich unter xampp im htdocs verzeichnis meine Page habe, sollte doch, wenn ich localhost eingebe,meine Seite erscheinden, oder nicht?

Denn leider ist mein Server nach einem Stromausfall bei mir zuhause ausgefallen, und konnte nicht mehr gestartet werden...
Ist schon lange her, seit ich das letzte mal den xampp installiert habe....

ich dachte, ich wüsste alles noch, aber scheint nich der fall zu sein, denn ansonste würde es ja laufen....!!!

Ich habe meine alte page, die ich gottsei dank noch den Tag zuvor gesichert habe, ins htdocs verzeichnis kopiert....

Nur leider wird meine page nicht angezeigt...
Der Server läuft, hat mir auf jedenfall keine Fehlermeldung gegeben...

Was muss ich noch ändern, damit der Server läuft?

Danke
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby Ceelight » 17. March 2005 12:26

Wenn Deine Seite index.html heisst, dann sollte sie erscheinen.
There's no place like 127.0.0.1
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby Mario Lanz » 17. March 2005 12:31

tut sie zu 100%....

denn, wenn ich den ie öffne und den pfad eingebe, öffnet er die seite....

wenn ich localhost eingebe bekomme ich die seite von xampp, am start... dass das ganze funktioniet, dass weiss ich jetzt danke... ;)

muss ich irgendwo nen Pfad ändern oder so?
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby Mario Lanz » 17. March 2005 12:34

habe noch was vergessen...

ich habe eine feste ip, aber wenn ich die eingebe, findet der nichts, und der server ist bereits am laufen...

vielleicht muss ich noch was am w2k3 server einstellen?

hätte nicht gedacht, dass das so schwierig ist... das letzte mal fand ich es einfacher....
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby deepsurfer » 17. March 2005 12:37

leere bitte mal deinen Browser-CACHE !!!! dann sollte es mit localhost gehen
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Mario Lanz » 17. March 2005 12:49

deepsurfer wrote:leere bitte mal deinen Browser-CACHE !!!! dann sollte es mit localhost gehen


aber warum komme ich nicht über die ip auf die page von extern, oder über die URL?

die internent IP adressen sind die gleiche geblieben....
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby deepsurfer » 17. March 2005 13:28

Zur Verständigung:

Der PC unterm Tisch bei dir hat die feste Intranet-IPnummer 192.168.0.1 (oder ähnlich)

Wenn Xampp läuft dann erreichst du den XAMPP
mit http://localhost oder http://127.0.0.1 oder http://192.168.0.1

Dies sind die drei varianten für einen INTERNEN connect zu xampp.

Wenn nun dieser PC eine Internetleitung besitzt und kein router, firewall,proxy etc dazwischen liegt dann kannst du kollegen und freunden deine InternetIPnummer mitteilen.
http://www.ipnummer.de/z/ippopz.pl

Damit können dann die kollegen über ihre internetleitung auf deinen Xamppserver kommen.

Das, soweit zu den möglichkeiten.

Was geht nun bei dir nicht ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Mario Lanz » 17. March 2005 13:34

Also, das von aussen an den pc zu kommen geht nicht...

ich habe ein Router/Firewall und habe den port 80 and die interne IP weitergeleitet....

jetzt, ich habe 2 IP's am pc, da 2 Netzwerkkarten... macht das ein unterschied?

Gruss mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby deepsurfer » 17. March 2005 13:42

jetzt, ich habe 2 IP's am pc, da 2 Netzwerkkarten... macht das ein unterschied?


Die IP der Netzwerkkarte die zum Router geht (internet) muss als Port-Forward eingetragen werden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Mario Lanz » 17. March 2005 13:49

deepsurfer wrote:
jetzt, ich habe 2 IP's am pc, da 2 Netzwerkkarten... macht das ein unterschied?


Die IP der Netzwerkkarte die zum Router geht (internet) muss als Port-Forward eingetragen werden.

gehen beide zum router....

meine Frage wahr mehr, kommt es drauf an, an welche ich es weiterleite?
Denke nicht, da xampp einfach auf port 80 horcht und dem es dann egal ist von welcher IP das kommt, oder?
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby Mario Lanz » 17. March 2005 14:55

werde das problem mal in www.winhilfe.ch einbringe, da es eher ein W2k3 Server problem zu sein scheint...

Thread im Winhilfe Forum:
http://www.winhilfe.ch/wbb2/thread.php?threadid=16689

Hoffe, dass es einfach behoben werden kann....
Denke, dass es mehr ein win problem ist, als ein xampp!!!!

Gruss Mario
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests