Localhost startet meine Index.html nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Localhost startet meine Index.html nicht

Postby cosmo » 15. March 2005 21:15

Localhost öffnet nicht meine index.html sondern eine auflistung meiner
kompletten mp3 dateien in html, und wenn ich auf einen link der ganzen Liste klicke kann ich meine eigenen Dateien downloaden welch Ironie !!!
der browser will ums verrecken nicht meine seite im htdocs Ordner anzeigen sondern immer diese auflistung.....

Bitte helft mir !
cosmo
 
Posts: 4
Joined: 15. March 2005 21:02

Postby deepsurfer » 16. March 2005 12:35

bitte schau mal ob du wirklich index.html als namen benutzt und nicht in irgendeiner Forum mit Gross und Kleinbuchstaben und oder mehrfach Punkten etc.

Ich weiss das dem Windows die Nameneinträge egal sind, aber das ist das erste was mir in den Sinn kommt.

Du hast also in \xampp\htdocs einiege MP3 Dateien hineinkopiert, dazu eine eigene index.html geschrieben.
Trifft das so zu ??

An XAMPP und dessen Einstellungen hast du nichts geändert, oder doch ??? (wenn ja, was hast du geändert)

Mal den Browser-Cache Leeren, ich behaupte mal das du vor der eigenen index.html den Aufruf der Dateiliste gewünscht hattest. (wäre somit etwas in der httpd.conf einzustellen, dann hast etwas geändert)
Last edited by deepsurfer on 16. March 2005 14:50, edited 1 time in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Ceelight » 16. March 2005 13:58

Ich nehme auch an, dass der Name der index.html irgendwie falsch geschrieben wurde.

Die mp3-Liste wird wohl die standardmäßige Verzeichnissicht von Apache sein, wenn er keine index findet. Dass dann ein Download startet is ja klar. Is ja Sinn der Sache ;)
There's no place like 127.0.0.1
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby cosmo » 16. March 2005 18:41

Habe am apche bzw. am xampp nichts verändert, habe lediglich die dateien im htdocs durch meine ersetzt.
ich habe eine mp3 datei und eine flash datei die auf die eine mp3 datei zugreift im Ordner !

Der Testserver funktionierte bei mir auch einwandfrei bis vor ein paar Tagen. Dann auf einmal hat er anstatt meine homepage zu öffnen immer diese auflistung von meinen mp3's gemacht die ich unter "Eigene Musik" liegen habe !

Ich bin total planlos hab auch schon alles neu installiert aber kein Erfolg ?

meine Index heißt index.html.....
cosmo
 
Posts: 4
Joined: 15. March 2005 21:02

Postby deepsurfer » 17. March 2005 11:39

deine index.html, hat diese datei die aufgabe in das "Eigene Musik" Verzeichnis zu schauen und gegebenenfalls daraus MP3 Stücke anzuzeigen, oder hat die index.html eine ganz andere Funtkion.

Wodrauf ich hinaus will ist zu erfahren was die index.html für eine funktion hat.

Hattest du ausgetestet nach der neu-Installation ob xampp über den browser einwandfrei läuft ?????
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby cosmo » 17. March 2005 16:52

meine index.html hat die aufgabe die einzelnen frames meiner website zu öffnen. Die Website besteht nur aus html und beinhaltet nur eine flash datei swf. die auf die mp3 datei die nur als hörprobe dient zu greift. meine eigenen mp3's haben nicht im entferntesten was mit dieser site zu tun, daß bringt mich ja um den Verstand.

Nach dem ich xampp neu installiert hatte hat er die start site von xampp einwandfrei geöffnet sobald ich aber die xampp dateien aus dem htdocs ordner durch meine ersetze klappt's wieder nicht.

.......?
cosmo
 
Posts: 4
Joined: 15. March 2005 21:02

Postby deepsurfer » 17. March 2005 17:18

bitte schau nochmal den htmcode genau an.
zum gegentest mal den Flashfiel aufruf herausnehmen <!-- --> und gegentesten.

irgendwas bringt den browser dazu auf das verzeichnis zu springen
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby cosmo » 19. March 2005 01:16

Ne bringt auch nichts, hab beide files also die flash und mp3 datei herausgenommen !hab auch den code nachgeschaut ist aber alles normal stehen nur die metas drin und welche frames er laden soll ! :shock:
cosmo
 
Posts: 4
Joined: 15. March 2005 21:02


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests