xampp läuft unter router nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby deepsurfer » 14. March 2005 11:31

Back to the Roots: Hinweis zur Entwirrung, es ist der Netgear Web/Safe RP614
http://netgear.de/Produkte/Router/Inter ... index.html

- Der Router übernimmt die vollständige Einwahl zu deinem Provider, soll heissen das dein Router den DSLaccount gespeichert hat und ins Internet geht.

- AN diesem Router (es sind vier steckerplätze vorhanden) wurde mittels Netzwerkkabel der erste PC angeschlossen und am weiteren Steckplatz am Router der zweite PC.

Frage #1 an noctua: Trifft das so zu ??
--------------------------------------------------------------------------------------
- In den Netzwerkeinstellungen des ersten PCs wurde eine feste IP eingetragen - 192.168.0.3

- In den Netzwerkeinstellungen des zweiten PCs wurde eine feste IP eingetragen - 192.168.0.4

Frage #2 an noctua: Trifft das so zu ??
--------------------------------------------------------------------------------------

- Auf dem ersten PC läuft der XAMPP, und dieser ist mit dem zweiten PC im Browser (http://192.168.0.3) abrufbar.

Frage #3 an noctua: Trifft das so zu ?? (lokales Netzwerk funktioniert)
--------------------------------------------------------------------------------------

- In den Router-Optionen musst du bei dem Begriff "Port Forwarding" den Port 80 auf die IP des ersten PC einstellen, ab jetzt sollte eine Anfrage aus dem Internet direkt an deinen ersten PC gehen und derjenige sieht auch den XAMPP.

- Wenn du dazu noch FTP benutzen willst, so müsstest du den Port 21 hinzufügen.

- Wenn du dazu noch einen "offenen" MySQL-Server haben möchtest, so müsstest du den Port 3306 hinzufügen.

- Wenn du eine sicherche HTMLverbindung aufbauen lassen möchtest, so musst du noch den Port 443 hinzufügen, dann funktioniert auch der Aufruf mit https://InternetIP und XAMPP meldet sich.

- Da der NetGear eine Integrierte Firewall besitzt, solltest du nach der Anleitung schauen ob die soeben genannten Ports nicht zusätzlich von der Firewall blockiert werden.



http://netgear.de/download/RP614/RP614v2_GRManual.pdf Seite 49 bsi 51 wird das Port-Forwarding genau erklärt !!!
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby noctua » 14. March 2005 23:46

naja es stimmt halbwegs.

---------------------------------
Frage #1 :
Ja das stimmt so


---------------------------------
Frage #2 :
ich habe derweil nur einen PC angeschlossen, aber "ja" er hat die IP 192.168.0.2 (jetzt ist '2' weil ich ihn an nen anderen anschluss gesteckt habe)

---------------------------------
Frage #3 :
da ich nur einen Rechner angeschlossen habe hab ich es auch nur mit dem getestet, aber "JA" über die IP 192.168.0.2 komme ich auf den xampp server



problem. sowas wie "Port Forwarding" hat er nicht, nur "Portweiterleitung" was ja eigentlich das selbe ist. Dort habe ich jetzt den Anfangs-Port und den End-Port '80','443' und '5190' auf die IP 192.168.0.2 freigegeben. aber über meine externe IP kommt trozdem keiner auf den xampp server



ps: da steht was von WAN IP Adresse, über die andere auf meinen server zugreifen. Diese steht bei mir aber nirgents. nur die:

-----------------
Internet-Port
MAC-Adresse 00:0F:B5:39:25:7B
IP-Adresse 80.171.135.174
DHCP None
IP-Subnetzmaske None
Domain Name Server 213.191.74.18
213.191.92.87

LAN-Port
MAC-Adresse 00:0F:B5:39:25:7A
IP-Adresse 192.168.0.1
DHCP Server
IP-Subnetzmaske 255.255.255.0
-------------
noctua
 
Posts: 12
Joined: 13. March 2005 00:19

Postby noctua » 15. March 2005 00:04

es funktioniert nun ........... :D

ich musste bei WAN konfiguration auch meine Rechner IP angeben und freischalten, damit er auf pings von ausen reagiert und so (naja steht da zumindest). also über meien externe IP komme ich zwar immer noch nicht auf meinen rechner, aber andere. jetzt geht es .... DANKE :D ich liebe dich dafür



DANKE DANKE DANKE , ich liebe dich echt
noctua
 
Posts: 12
Joined: 13. March 2005 00:19

Postby deepsurfer » 15. March 2005 12:36

ich liebe dich dafür

DANKE DANKE DANKE , ich liebe dich echt


liebe ist zuviel des guten :)

Ein "Danke" reicht, gebe aber dieses Danke an die ganze Community weiter, denn viele haben an diesem Weg mitgearbeitet :shock:
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby noctua » 15. March 2005 12:45

stimmt ....


DANKE an euch alle, ohne euch hätte ich das NIE geschaft.

nochmal DANKE DANKE DANKE :D


ich bin jetzt so glücklich, dass das funtzt, wow ....
noctua
 
Posts: 12
Joined: 13. March 2005 00:19

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests