Problem mit SSL bei WebDAV und Passwortabfrage

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit SSL bei WebDAV und Passwortabfrage

Postby chriZ » 09. March 2005 13:00

Hi Jungz und MädelZ 8)
ich hab da mal ein kleines anliegen: Ich setze auch Xampp ein und hab das Problem das die SSL verschlüsselung bei WebDav nicht funtzt.
Laut der Konfig wird das Module über den Port81 angesteuert.
Meine Frage ist, was muss ich in welcher Config ändern, damit ich mein WebDav- Module ach über SSL Verbindung ansprechen kann?


Die zweite Frage ist, bei mir kommt keine Username und Passwort abfrage wenn ich auf meinen Apache und Webdav raufgehe.... was muss ich wiederrum in der Konfig eintragen damit dies geschieht...

Ich weiss das sind eigentlich sachen die man sicherlich selber lösen kann... aber ich steh schon kurz vor der verzeiflung und blicke im moment nicht mehr so richtig durch.....

Wenn jemand Konfig auszüge benötigt dann bitte bescheid geben..

Vielen Herzlichen Dank für die Hilfe im Vorraus...

mfg

christian
chriZ
 
Posts: 5
Joined: 09. March 2005 12:52

Postby deepsurfer » 09. March 2005 14:36

Zu WebDav kann ich nix sagen.



Die zweite Frage ist, bei mir kommt keine Username und Passwort abfrage wenn ich auf meinen Apache und Webdav raufgehe.... was muss ich wiederrum in der Konfig eintragen damit dies geschieht...


Kann es sein das du die Automatische User und PW abfrage eingebaut hast, sodass der IE automatisch sich einloggt.

Diesbezüglich käme ein frage... wie hast du das Verzeichniss (webzugang) PW technisch umgesetzt ?? (htaccess...phpscript...javascript)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

passwort abfrage

Postby chriZ » 09. March 2005 15:30

das läuft alles über .htaccess


AccessFileName .htaccess

also die einzige abfrage geht von statten wenn ich z.b. über sunbird ein kalenderfile vom freigegebenen WebDAV verzeichniss ziehen möchte....

gehe ich über den browser auf das verzeichniss kommt keine abfrage
chriZ
 
Posts: 5
Joined: 09. March 2005 12:52

Postby deepsurfer » 09. March 2005 18:43

auch mal über einen anderen client probiert, ist es bei diesem genauso ???
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby chriZ » 10. March 2005 09:22

die passwort abfrage ist ja eigentlich nicht mein problem...
... die ssl verschlüsselung ist mein problem....

die frage ist.. wie löse ich das?
webdav ist über port 81 zugänglich... ich möchte aber das dass module nur über ssl erreichbar ist

SSLRequireSSL im Directory ist klar... aber wie weiter??
Vielen Danke für die Hilfe im Vorraus :?
chriZ
 
Posts: 5
Joined: 09. March 2005 12:52


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests