Localhost soll Ordnerinhalt anzeigen!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Localhost soll Ordnerinhalt anzeigen!

Postby spunks » 03. March 2005 15:30

Hey!

Ich will dass der Localhost beim Start den Inhalt von httdocs anzeigt und nicht die XQMP Startseite - wie geht das? einfaches löschen der index.html funktioniert ja mal gar nich :o

Und kann ich den Localhost Ordner ändern ? also das httdocs verzeichnis woanders hinschieben oder so?

Danke,

Spunks
spunks
 
Posts: 4
Joined: 03. March 2005 15:25

Postby deepsurfer » 03. March 2005 15:40

Ich will dass der Localhost beim Start den Inhalt von httdocs anzeigt und nicht die XQMP Startseite - wie geht das? einfaches löschen der index.html funktioniert ja mal gar nich :o

Um das zu wollen musst du die httpd.conf editieren
in ca. Zeile 353 steht folgendes
Code: Select all
Options Indexes FollowSymLinks MultiViews Includes ExecCGI

einfach ändern in
Code: Select all
Options +Indexes FollowSymLinks MultiViews Includes ExecCGI

Also ein Pluszeichen for Indexes.

Apache neu starten !!!, diese Directive gilt jetzt für jedes verzeichnis unterhalb /htdocs, solange du dies nicht mit einem .htaccess ändern solltest.


Und kann ich den Localhost Ordner ändern ? also das httdocs verzeichnis woanders hinschieben oder so?

Ja kannste, aber dazu musst du in der httpd.conf die Verzeichnisfolge auch eintragen sonst klappt es nicht.

Dazu aber auch die Suchfunktion dieses Forums benutzen, denn dein Anliegen wurde schon etliche Male beschrieben.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Ceelight » 03. March 2005 15:42

Versuchs mal mit der Suche - wurde schon seeehr oft beantwortet.

Egal.

Die index.html kannst Du durch Deine eigene austauschen. XAMPP ist dann immernoch durch Eingabe von localhost/xampp erreichbar.
There's no place like 127.0.0.1
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby spunks » 03. March 2005 15:49

So das + hab ich jetzt hinzugefüht, aber es wird trotzdem noch sofort auf

http://localhost/xampp/splash.php

weitergeleitet, gibt aber auch keine index.html mehr??

Danke für den Such tipp =)
spunks
 
Posts: 4
Joined: 03. March 2005 15:25

Postby deepsurfer » 03. March 2005 16:01

spunks wrote:So das + hab ich jetzt hinzugefüht, aber es wird trotzdem noch sofort auf

http://localhost/xampp/splash.php

weitergeleitet, gibt aber auch keine index.html mehr??

Danke für den Such tipp =)



browser cache leeren !! dann kallpt es auch mit dem nachbarn :)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby spunks » 03. March 2005 16:05

Und das geht wie :lol:
spunks
 
Posts: 4
Joined: 03. March 2005 15:25

Postby Ceelight » 03. March 2005 16:14

Welchen Browser benutzt Du?

Beim IE Internetoptionen. Temporäre Dateien löschen oder so...
There's no place like 127.0.0.1
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby deepsurfer » 03. March 2005 16:18

oh oh....


im IE open auf EXTRAS --> INTERNETOPTIONEN im neuen bild siehst du im Mittelteil drei bottums
Cookies löschen | Dateien löschen | Einstellungen


auf "Dateien löschen" klicken, in der zusatzabfrage "Alle Offlineinhalte löschen" anklicken und dann OK.

Da du eine standart Installation hast kann es jetzt bis zu 60 Sekunden dauern, da der IE ca. 3% deiner Festplatte als Internet Cache reserviert hat.
Fenster einfach schliessen und localhost aufrufen


Bei FireFox oben auf EXTRAS --> EINSTELLUNGEN (Options) im neuen Fenster links auf DATENSCHUTZ (Security) klicken, es erscheint nun rechts 6 Punkte.
Der letzte heisst "Cache", dort kannst du auf löschen (empty cache) klicken, es dauert auch hier einige sekunden.

Fenster schliessen und localhost aufrufen
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby spunks » 03. March 2005 16:41

ah jetzt darf ich gar nich mehr .. :(

Forbidden

You don't have permission to access / on this server.
spunks
 
Posts: 4
Joined: 03. March 2005 15:25

Postby deepsurfer » 03. March 2005 17:28

sooo.... habs jetzt gegengetestet..

den eintrag in der httpd.conf wieder rückgängig machen
Code: Select all
    Options Indexes FollowSymLinks MultiViews Includes ExecCGI


das Pluszeichen löschen, apache neu starten ...

ich hab dein gewünschtes ergebnis damit vorliegen.
testen und melden !!
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests