kein MySQL mit PHP 4 aber mit PHP5?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

kein MySQL mit PHP 4 aber mit PHP5?

Postby gieser » 21. February 2005 19:17

Hallo Leutem
ich arbeite normalerweise immer unter PHP5, deshalb ist mir erst heute aufgefallen, dass MySQL mit der PHP4 Version nicht funktioniert (4.3.9).
Wie gesagt, mit PHP 5 funktioniert alles, aber wenn ich mit PHP4 irgendwie versuche auf die Datenbank zuzugreifen bekomme ich folgende Fehlermeldung (CD-Verwaltung):

Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in C:\apachefriends\xampp\htdocs\xampp\cds.php on line 65

weiß jemand eine Lösung, weil ich unbedingt mal ezpublish ausprobieren will und des mit PHP5 nicht geht.
gieser
 
Posts: 4
Joined: 21. February 2005 19:12

Postby Wiedmann » 21. February 2005 19:22

Du könntest z.B. deinen XAMPP updaten...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gieser » 21. February 2005 19:24

hab ich heute gemacht. hat davor und danach nicht funktioniert
gieser
 
Posts: 4
Joined: 21. February 2005 19:12

Postby Wiedmann » 21. February 2005 19:28

hab ich heute gemacht.

Und wie hast du das gemacht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gieser » 21. February 2005 19:29

die xammp-upgrade-1.4.12.exe runtergeladen und ausgeführt
gieser
 
Posts: 4
Joined: 21. February 2005 19:12

Postby Wiedmann » 21. February 2005 19:33

Das war ein Fehler. Du musst jedes Update was dazwischen liegt auch machen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gieser » 21. February 2005 19:33

ok, danke, das wusst ich.
gieser
 
Posts: 4
Joined: 21. February 2005 19:12


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests