xampp funktioniert nicht auf Laptop

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp funktioniert nicht auf Laptop

Postby rainer23 » 14. February 2005 12:46

Hallo,

ich habe xampp auf meinem Desktop Computer (mit win xp) installiert - und
es funktioniert ohne Probleme.

Auf meinem Laptop (Medion mit Win ME) läuft es nicht.
Beim Start kommt die Fehlermeldung:

Please wait [bitte warten] Can´t start Server: Bind on TCP/IP Port: No
error 050214 11:06:10 [Error] Do you already have another mysql-Server
running on Port: 3306?
050214 11:06:10 [Error] Aborting

[Mon Feb 14 11:06:10 2005] [crit] <OS 10038> Socket Operation on
non-socket: make _sock:for adress 0:0:0:443, apr_socket_opt_set:
<SO_KEEPALIVE>
unable to open logs
050214 11:06:10 [Note] mysql\bin\mysql.exe: Shutdown complete

.

Es läuft aber kein anderer sql-Server. netstat -an zeigt, dass am port 3306
abgehört wird erst an, nachdem ich versucht habe, xampp zu starten.
Daher kann ich mit den Tipps, die ich bislang gelesen habe, nichts anfangen. (Ich gebe zu, alle 64 Seiten habe ich nicht durchgearbeitet.)

Versuche ich nur apache zu starten, bekomme ich den Fehler:
[Mon Feb 14 11:06:10 2005] [crit] <OS 10038> Socket Operation on
non-socket: make _sock:for adress 0:0:0:443, apr_socket_opt_set:
<SO_KEEPALIVE> no listening sockets available.
unable to open logs

Habt ihr eine Idee, wie ich das Programm zum Laufen bringe?

Rainer
rainer23
 
Posts: 3
Joined: 14. February 2005 12:38

Postby Wiedmann » 14. February 2005 12:53

Hmm, XAMPP und Win Me ist manchmal nicht zur Zusammenarbeit zu bewegen...

Versuche mal folgende Directive in der httpd.conf ("\xampp\apache\conf"):
Code: Select all
Win32DisableAcceptEx
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rainer23 » 14. February 2005 13:06

Wiedmann wrote:Hmm, XAMPP und Win Me ist manchmal nicht zur Zusammenarbeit zu bewegen...


Das ist ja blöd.

Wiedmann wrote:Versuche mal folgende Directive in der httpd.conf ("\xampp\apache\conf"):
Code: Select all
Win32DisableAcceptEx

Da stand Win32DisableAcceptEx on.
Mit Win32DisableAcceptEx off geht es auch nicht. :(

Rainer
rainer23
 
Posts: 3
Joined: 14. February 2005 12:38

Postby Wiedmann » 14. February 2005 13:56

Mit Win32DisableAcceptEx off geht es auch nicht.

Logisch. Diese Directive kennt keine Parameter wie On oder Off. Nur ist die vorhandene Zeile ja normal auskommentiert (#), so dass diese Directive nicht zum Zuge kommt (Hat diese Zeile kein Kommentarzeichen, dann kannst du zum Testen ja mal eines hinmachen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rainer23 » 14. February 2005 15:48

Wiedmann wrote:
Mit Win32DisableAcceptEx off geht es auch nicht.

Logisch. Diese Directive kennt keine Parameter wie On oder Off. Nur ist die vorhandene Zeile ja normal auskommentiert (#), so dass diese Directive nicht zum Zuge kommt (Hat diese Zeile kein Kommentarzeichen, dann kannst du zum Testen ja mal eines hinmachen).


Du ahnst es: es funktioniert weder mit noch ohne diese Zeile.

Rainer
rainer23
 
Posts: 3
Joined: 14. February 2005 12:38


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests