Datenimport in PHPMyAdmin > keine Umlaute

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Datenimport in PHPMyAdmin > keine Umlaute

Postby CrazyWolf1981 » 11. February 2005 11:59

Hab mich hier jetzt bissel durchgewühlt jedoch konnte bisher nichts helfen.

Es werden keine Umlaute importiert. Auf der PHPMyAdmin - Startseite steht als Zeichensatz uft8. das konnte ich auch nicht per my.cnf ändern.

Beim import habe ich bei "Zeichencodierung der Datei" alles ausprobiert. Latin1, utf8, cp1250 und die anderen mit cp, egal was ich mache, nichts hilft.

Der Export ist von einer älteren PHPMyAdmin Version (2.5.1-rc1) und im Export sind die Umlaute alle drin.

Kann mir mal jemand genau sagen welche Zeichenkodierung ich:
- in der my.cnf
- Zeichensatz / Sortierung der MySQL-Verbindung ( in phpMyAdmin )
- Zeichencodierung der Datei ( in phpMyAdmin )

einstellen muss, dass es funktioniert?

Ich versteh eigentlich gar nicht wieso es so kompliziert gemacht wurde mit phpMyAdmin 1.6. Früher ging immer alles reibungslos ohne Probleme als es diese Zeichensatz und Codierungseinstellungen noch nicht gab...

Danke im voraus.

Gruß
Wolf
CrazyWolf1981
 
Posts: 23
Joined: 03. October 2004 21:51

Postby Fasse » 04. May 2005 09:37

Mir geht es leider genauso.

Bei meiner XAMPP-Installation zeigt PhpMyAdmin an, dass die DB als Zeichensatz utf-8 hätte. Mein Provider hat aber iso-8859-1. Wenn ich nun meine DB dort exportiere und bei mir importieren will, werden alle Umlaute nicht korrekt dargestellt. :-(

Wie und wo kann ich die Zeichenkodierung ändern ?
Fasse
 
Posts: 3
Joined: 04. May 2005 09:00

Postby deepsurfer » 04. May 2005 12:49

Bei meiner XAMPP-Installation zeigt PhpMyAdmin an, dass die DB als Zeichensatz utf-8 hätte. Mein Provider hat aber iso-8859-1.


Was hindert dich daran im XAMPP die DB auf "Kollation (collate) = latin1_german1_ci"
zu setzen ??? latin1_german1_ci = ISO-8859-1
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby spike » 07. May 2005 18:29

Versuchs doch mal so (Ich habe es selbst bisher nur beim Import von csv-Dateien in eine mysql-Tabelle ausprobiert):

Entscheidend ist der verwendete Zeichensatz. Ich habe mit Hilfe von Textpad
http://www.textpad.com/ meine csv-Dateien erst mal in utf-8 neu gespeichert und die so erzeugten Dateien per phpmyadmin importiert. Hat funktioniert und die Umlaute blieben auch erhalten.

Bevor was schief geht könnte man ja erst mal mit ner Sicherheitskopie anfangen.
spike
 
Posts: 1
Joined: 07. May 2005 18:13

Postby Fasse » 08. May 2005 15:15

Vielen Dank für eure Hinweise.

Ich hab jetzt die Datenbank neu mit latin1-german-ci angelegt und dann beim Einspielen der SQL-Datei "Latin1" als Zeichencodierung der Datei angegeben und damit hat es jetzt wunderbar geklappt :-)

Gruß Fasse
Fasse
 
Posts: 3
Joined: 04. May 2005 09:00

Postby fragenmensch » 08. May 2005 19:39

oder einfach das alte pma installieren...
geht genauso
und meines wissens nach kannst du die config datei behalten
fragenmensch
 
Posts: 17
Joined: 01. May 2005 18:59


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests