localhost aufrufen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

localhost aufrufen

Postby jan_miguel » 09. February 2005 19:57

Kann nach Installation die Seite http://localhost nicht aufrufen!
Benutze WinXP SP1 mit der integrierten firewall!
Befinde mich in größerem uni-netzwerk, bin jedoch ziemlich sicher
das die betreffenden ports nicht gesperrt werden.

Woran kann das liegen?

Gruß
as
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Postby Wiedmann » 09. February 2005 20:01

Woran kann das liegen?

Läuft denn der Server überhaupt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jan_miguel » 09. February 2005 20:03

jupp, habe "xampp basic start" aus dem startmenü und als alternative auch
"apache_start.bat" und "mysql_start.bat" gestartet.
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Postby Wiedmann » 09. February 2005 20:47

Naja, das Aufrufen eines Links/Datei bedeutet ja nicht zwangsläufig das ein Programm auch läuft.

Hast du das verifiziert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jan_miguel » 09. February 2005 20:55

wie kann ich es überprüfen?
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Postby Wiedmann » 09. February 2005 21:10

Du könntest zumindest ja mal beschrieben, was genau passiert wenn du den Apachen startest.

BTW:
Nach wie vor zeigt dir Windows im Taskmanager die laufenden Prozesse an..
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jan_miguel » 09. February 2005 21:24

nach dem starten der "xampp basic start" öffnet sich ein DOS-Fenster, was sich abschließend wieder schließt und es öffent sich im browser die \xampp\install\start.html
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Postby Wiedmann » 09. February 2005 22:58

was sich abschließend wieder schließt

Was bedeutet das das Apache nicht läuft.

--> Und somit gehörtst du zu dem Kreis von Leuten, die tägöich hier im Forum dieses "Problem" vortragen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jan_miguel » 09. February 2005 23:12

gibt es vielleicht Hinweise, wie ich weiter vorgehen kann?
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Postby Wiedmann » 09. February 2005 23:23

Yup. Die Fehlermeldung/nummer lesen die der Apache ausgibt.

(Das das Fenster gleich wieder zugeht, liegt am Doppelklick auf das Konsolenprogramm)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jan_miguel » 09. February 2005 23:29

hier steht folgendes:

Please wait [Bitte warten] Syntax error on line 1 of I:/WebSERVER/apachefriends/
xampp/apache/conf/perl.conf:
Cannot load /xampp/perl/bin/perl58.dll into server: Das angegebene Modul wurde n
icht gefunden.
Can't start server: Bind on TCP/IP port: No error
050209 23:26:49 [ERROR] Do you already have another mysqld server running on por
t: 3306 ?
050209 23:26:49 [ERROR] Aborting

050209 23:26:49 [Note] mysql\bin\mysqld.exe: Shutdown complete

...

### APACHE + MYSQL IS STARTING NOW ###
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Postby Wiedmann » 09. February 2005 23:52

Ups, OK, dein Fehler kommt nicht täglich vor...

Leider bist du gerade über einen Bug vom XAMPP gestolpert. :-( Du musst den XAMPP in ein anderes Verzeichnis installieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jan_miguel » 09. February 2005 23:53

wohin am besten? Anderes Laufwerk?
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Postby Wiedmann » 10. February 2005 00:02

Im Pfad darf nicht das Wort "server" enthalten sein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jan_miguel » 10. February 2005 00:25

Vielen DAnk, das hätte ich wohl so schnell nicht herausgefunden!

Hann jetzt localhost aufrufen, beim starten des servers treten aber immer noch Probleme auf, siehe:

Use the xampp_stop for shutdown!

Please wait [Bitte warten] ..Can't start server: Bind on TCP/IP port: No error
050210 0:21:09 [ERROR] Do you already have another mysqld server running on por
t: 3306 ?
050210 0:21:09 [ERROR] Aborting

050210 0:21:09 [Note] mysql\bin\mysqld.exe: Shutdown complete

.

### APACHE + MYSQL IS STARTING NOW ###
jan_miguel
 
Posts: 13
Joined: 09. February 2005 19:53

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests